Do I need a subwoofer? [Archive] - Dodge Challenger Forum: Challenger & SRT8 Forums

: Do I need a subwoofer?


Chango
07-29-2013, 08:48 AM
When I bought my '13 Challenger it had an aftermarket Pioneer touch screen stereo w/backup camera, speakers and amp already installed, but no sub. I'm not a big sound guy but I think the music sounds great as it is.

Still, is the rest of the system wasted without a sub? Would you buy one?

2013 RALLYE REDLINE
07-29-2013, 11:37 AM
Yes,I for one think that a sub is good in a car audio system. You can go for something simple like a box and sub with an amp built in. Look into an Infinity BassLink or one of the JL Audio subs with an amp built. If your NOT looking to shake rattle your car than they will work out fine. You say that when you bought the car it had a Pioneer aftermarket Stereo in it? You must have bought it used then....Do you still have front to rear fading with the Pioneer??

Bart_24
07-29-2013, 10:16 PM
I started with just one 10" sub in mine and two weeks later went back for a second. I will never regret that decision at all, it made the difference in the world. Sure it took up room in my trunk, and now I have to decide between wanting to hear my exhaust or my bass.

My setup is a Pioneer avh-x5500bhs
10" Rockford Fosgate P2
Rockford Fosgate amp (its mounted on the back of my seat behind the subs so I am unsure of which model it is).
I love it, it sounds great to me and I listen to a little of everything. Also added a backup camera as well.

2013 RALLYE REDLINE
07-30-2013, 05:56 AM
Bart 24....I see that you have a 2013 challenger like I do....Also I see that you are using the Pioneer AVH-X5500BHS....I was thinking of getting that same unit for my car. How do you like it and how is it working for you with your system?? How is the sound quality? Did you swap out the factory speakers?? What adaptor did you use ?? Did you retain the factory amp?? Do you still have fading?? Thank you much

Bart_24
07-30-2013, 06:13 AM
Bart 24....I see that you have a 2013 challenger like I do....Also I see that you are using the Pioneer AVH-X5500BHS....I was thinking of getting that same unit for my car. How do you like it and how is it working for you with your system?? How is the sound quality? Did you swap out the factory speakers?? What adaptor did you use ?? Did you retain the factory amp?? Do you still have fading?? Thank you much

Only regret I have about the X5500 is that it didn't have navigation. The touchscreen works perfect for me its not overly or under sensitive its just right. The sound quality is amazing with the factory speakers still installed the only speakers I added was the subs in the back. I had it installed where I bought it but on my invoice it says the adapter is an Axxess ASWC1 which it kept all of my steering wheel controls active for me and my USB hookup works inside the console. Now on the dash it always shows "radio off" but since I use that to see my speed and not my radio information that didn't bother me. I also had them install a different mic for my phone instead of the one that came in the car however the factory one would have worked as well I just wanted a better mic. Overall, I was thoroughly impressed with this Pioneer unit its my favorite so far out of the three that I have owned in previous vehicles. I like the tilt feature for when DVD's are being played and I'd recommend to get the backup camera for it, I use it way more than I thought I would. Hope this helps!

Also, if you have an iPhone you will love the app feature. I have Android but I got to watch a demonstration of the unit being used with an iphone and how it accessed the apps and everything. So I am currently waiting out my Verizon contract to get me an iphone so I can have that fun as well!!

2013 RALLYE REDLINE
07-30-2013, 09:47 AM
Thank you Bart 24 for all the info.....I guess that being I replaced all my factory speakers already it should sound even better. Just one more question,What factory radio did you have and do you have the 7 or the 7+sub sound group II system?

Bart_24
07-30-2013, 10:57 AM
Thank you Bart 24 for all the info.....I guess that being I replaced all my factory speakers already it should sound even better. Just one more question,What factory radio did you have and do you have the 7 or the 7+sub sound group II system?

Mine came with the Uconnect 130 with six speakers.

crater
07-30-2013, 11:24 AM
No sub here. Don't find it necessary. Decent rear deck speakers and door speakers will provide more than enough Bass and mids. The in dash speakers should be good ones to to provide better highs and mids. Thats how I've always seen it and my car audio sounds great.

BromR1
07-30-2013, 11:49 AM
My motto is you shouldn't need a radio because your exhaust should be loud

Sent from AutoGuide.com Free App (http://www.autoguide.com/mobile)

fortion
07-30-2013, 01:44 PM
you really dont need one with the already installed stuff

WheelStudio
07-31-2013, 02:58 PM
Keep in mind you don't have to go crazy on a subwoofer setup. However, a simple 8" or 10" dedicated subwoofer that covers 75hz and below really helps accentuate the mid-range and front stage...more-so than you would think it could.