problem with my new corsa x - Dodge Challenger Forum: Challenger & SRT8 Forums
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-14-2013, 11:19 AM
Senior Member
 
KILLASCRIMP's Avatar
 
Join Date: Nov 2011
Location: Panama City beach Fl
Posts: 151
Thanks: 0
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
problem with my new corsa x

I finally got my new corsa extreme in had them installed by a exhaust shop. I noticed when I pull in my driveway that I get a rubbing noise from the car. At first I thought it was my brakes. Is this normal? It happens every time I am going just a few miles per hour like when I roll to a stop, or when I pull in to my garage. I can feel it slightly from the floorboard.. again it only happens when I go really slow but my car has never had this problem before, I am thinking maybe something is rubbing but everything looks ok

2011 srt8 A5 black, mopar CAI,87 TB, Trinity Tuner and CMR tune from Brian@SNL,12 Steering wheel, mopar strut brace,Corsa Cat back, kicker upgrade, lockpic,loaded with no hole in the roof.
KILLASCRIMP is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-14-2013, 11:43 AM
Moderator
 
OmahaRumble's Avatar
 
Join Date: Feb 2011
Location: Omaha, NE
Posts: 4,361
Thanks: 381
Thanked 597 Times in 396 Posts
Feedback Score: 10 reviews
Quote:
Originally Posted by KILLASCRIMP View Post
I finally got my new corsa extreme in had them installed by a exhaust shop. I noticed when I pull in my driveway that I get a rubbing noise from the car. At first I thought it was my brakes. Is this normal? It happens every time I am going just a few miles per hour like when I roll to a stop, or when I pull in to my garage. I can feel it slightly from the floorboard.. again it only happens when I go really slow but my car has never had this problem before, I am thinking maybe something is rubbing but everything looks ok
If you are noticing it after the install, go back to the shop PRONTO, and have them fix/readjust the system. Quite possible a pipe is rubbing up against something, it's a tight fit.

Happened to me before, where the tailpipe was hitting against under the trunk well... HORRIBLE sound.

2010 Dodge Challenger R/T Classic STP, sunroof, tint, 430 rbz, 3.92 gears, 6 speed.
MODS:
Zoomers catback exhaust
AFE Stage II cold air intake
Barton short throw shifter
Fastman ported throttle body
Diablo CMR tune by Johan
Mopar hood struts
Mopar strut tower brace
Spohn sway bar end links
Speedlogix rear adjustable control arms
Speedlogix tension bars
Jet 180* t-stat
SRT8 6.1 chin spoiler
Billet Technology catch can
OmahaRumble is offline  
#3 (permalink) Old 01-14-2013, 12:41 PM
Senior Member
 
KILLASCRIMP's Avatar
 
Join Date: Nov 2011
Location: Panama City beach Fl
Posts: 151
Thanks: 0
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
ya its kind of hard to get under there

W out a lift but I think you are right on the sound is damn right nasty thank you.
KILLASCRIMP is offline  
#4 (permalink) Old 01-14-2013, 05:07 PM
Lifetime Premium Member
 
Yellow Jacket 2012's Avatar
 
Join Date: Jul 2012
Location: Northern Jersey
Posts: 5,591
Thanks: 427
Thanked 1,493 Times in 935 Posts
Feedback Score: 0 reviews
And the issue was caused by? Why do we always get left hanging?

As I have grown older, I've learned that pleasing everyone is
impossible- but pissing everyone off, is a piece of cake.



Yellow Jacket 2012 is offline  
#5 (permalink) Old 01-14-2013, 07:29 PM
Senior Member
 
KILLASCRIMP's Avatar
 
Join Date: Nov 2011
Location: Panama City beach Fl
Posts: 151
Thanks: 0
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
just got back from shop

the guy who did the install didn't do such a good job. One side of the pipe was about a 1/8" off of the bottom of the trunk so when I stoped it would make a really bad noise. You would think a shop would catch that.. Anyway problem solved... Omaha nailed it.....
KILLASCRIMP is offline  
#6 (permalink) Old 01-14-2013, 07:33 PM
Senior Member
 
KILLASCRIMP's Avatar
 
Join Date: Nov 2011
Location: Panama City beach Fl
Posts: 151
Thanks: 0
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
Now that ITS FIXED OMG the car sounds Awesome. so glad I went with it. On my last two chargers I just replaced the muffler and called it a day, the srt sounds soooo good, With Corsa extreme
KILLASCRIMP is offline  
#7 (permalink) Old 01-14-2013, 07:43 PM
Moderator
 
OmahaRumble's Avatar
 
Join Date: Feb 2011
Location: Omaha, NE
Posts: 4,361
Thanks: 381
Thanked 597 Times in 396 Posts
Feedback Score: 10 reviews
Same damn thing happened to me.. glad it all worked out! Enjoy your new sound.
OmahaRumble is offline  
#8 (permalink) Old 01-14-2013, 08:07 PM
Senior Member
 
Trevster344's Avatar
 
Join Date: Feb 2011
Posts: 351
Thanks: 0
Thanked 7 Times in 6 Posts
Feedback Score: 0 reviews
I was going to say I don't see how exactly that could be caused by the Corsa. I installed my own exhaust system, and if you know what you're doing there is no way you could screw it up lol.

IE 2011 392 #102 - SOLD
Trevster344 is offline  
#9 (permalink) Old 01-14-2013, 09:14 PM
Senior Member
 
KILLASCRIMP's Avatar
 
Join Date: Nov 2011
Location: Panama City beach Fl
Posts: 151
Thanks: 0
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
ya I will not be going back to that shop anytime soon,
KILLASCRIMP is offline  
#10 (permalink) Old 05-25-2013, 10:16 PM
Junior Member
 
Join Date: May 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Me too, but...

Quote:
Originally Posted by KILLASCRIMP View Post
I finally got my new corsa extreme in had them installed by a exhaust shop. I noticed when I pull in my driveway that I get a rubbing noise from the car. At first I thought it was my brakes. Is this normal? It happens every time I am going just a few miles per hour like when I roll to a stop, or when I pull in to my garage. I can feel it slightly from the floorboard.. again it only happens when I go really slow but my car has never had this problem before, I am thinking maybe something is rubbing but everything looks ok
It happened to me, in the corsa manual it says the exhaust will heat up and twist. (comes in separate pieces). Then tighten them up. I even had them tach welded afterwards , no more rubbing.
Snotslo is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > Model Specific Discussion > Dodge Challenger SRT8 Specific > 6.4L / 392ci (2011 - ?)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mystery Grey IAT Sensor Connector - SOLVED! rayzazoo General Challenger Discussion 118 05-31-2014 10:17 PM
New Owner with a problem wkcominatchya New Member Introductions 11 10-23-2013 09:24 AM
Would the Challenger be your 1st MOPAR? Jimbo General Challenger Discussion 116 07-16-2010 11:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome