Electronic throttle control warning light - Dodge Challenger Forum: Challenger & SRT8 Forums
Dodge Challenger Forum Dodge Challenger Forum
 

» Featured Product
Auto Insurance

Wheel & Tire Center

Go Back   Dodge Challenger Forum: Challenger & SRT8 Forums > Model Specific Discussion > Dodge Challenger SRT8 Specific > 6.1L / 372ci (2008 - 2010)

ChallengerTalk.com is the premier Dodge Challenger Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07-25-2009, 04:50 PM
Member
 
Join Date: Apr 2009
Posts: 85
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electronic throttle control warning light

has anyone had problem with this dash light. started my car today and would not get out of park to put in gear. i cut engine off and tried again and and went into gear and drove it with dash light on. now i have engine light on.the manuel says to do this unless the light starts flashing. the car is not under warranty , to many mods, supercharged being the main one. any ideas thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-25-2009, 05:47 PM
lukester's Avatar
Senior Member
 
Join Date: Mar 2009
Location: Munich, Germany
Posts: 733
Photos: (0)
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
got a predator?
check the engine codes and let us know which one shows up.
__________________
09 Challenger SRT8 6speed
KW Stage 2, Hotchkis Sways, Front & rear Strut Bars, Catch Can, MBRP, Vortech V3, Hurst Shifter, Magnaflow Catted Mids, 8-Piston Brembos, OZ Wheels (front 10x20, rear 11x20) w 285/35 Toyo R888 all around, Pedders Bushings, Custom Oil Cooler, and much more...

see some of my "keep on rockin" Challenger videos:
http://www.youtube.com/user/lukecustoms

Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-25-2009, 07:36 PM
Member
 
Join Date: Apr 2009
Posts: 85
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dash light issue

havenot really used it much . if i plug it in will a code come up, or do i have to do anything special. i dont want to ruin the tune techco installed on the prediator thanks
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-26-2009, 01:13 AM
lukester's Avatar
Senior Member
 
Join Date: Mar 2009
Location: Munich, Germany
Posts: 733
Photos: (0)
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
Originally Posted by dbw47 View Post
havenot really used it much . if i plug it in will a code come up, or do i have to do anything special. i dont want to ruin the tune techco installed on the prediator thanks
just plug the Predator in and put turn your ignition to run but do not start.
then go to Diagnosis and read/ show the trubble codes.

You cannot ruin the Techco installed tune. Just read exactly what the Predator is saying.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-26-2009, 07:30 AM
Member
 
Join Date: Apr 2009
Posts: 85
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dash light problem

i hooked up prediator and code was UO103unknown. any idea what that might be or should i try and clear the code and see what happens, thanks for your help
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-26-2009, 07:38 AM
DCSDawg's Avatar
Lifetime Premium Member
 
Join Date: May 2009
Location: Tomball, TX
Posts: 788
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the red lightning bolt hit me 2 days ago while cruising at 80 mph. The code I got had something to do with high pressure on the ETC controller (vacuum leak.) I didn't write down the exact code. 3 days earlier, I got 2 codes: Bank1 and Bank2 running lean. I strongly suspect these were false codes.

I will follow this thread closely. I need to take it to the dealer now, as I am installing a SC next week. Once the SC goes on, everything will be blamed on it.

Based on the searches I have done, the issue could be a faulty ground wire (or negative battery terminal wire.) OR there could be a vacuum leak. I really don't know. But I also get the flickering lights. I'm leaning towards faulty ground.
__________________
MBRP Exhaust/Jet T-Stat/Mattico Tint/Hurst Short Throw/BT Catch Can/Hawk Performance Ceramics/3.0L Techco QD Twinscrew

"Walk SOFTLY and carry a BIG stick...."

Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 07-26-2009, 12:03 PM
Senior Member
 
Join Date: Jul 2008
Posts: 526
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Originally Posted by dbw47 View Post
i hooked up prediator and code was UO103unknown. any idea what that might be or should i try and clear the code and see what happens, thanks for your help
U0103 Lost Communication with electronic gearshift module.If you have the NAG Auto trans,it's usually a bad shifter assembly.The module is inside the shifter.I replace a lot of these on Chargers and 300's.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 07-26-2009, 01:51 PM
Member
 
Join Date: Apr 2009
Posts: 85
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
light issue

im going to clear the code and see what happens. can i buy this part from dodge and is it something i can install myself.do you take shifter plate off to acess it or is underneath the car. buy the way i used the cruise control yesterday for first time do you think that might have anything to do with it
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 07-26-2009, 02:38 PM
Senior Member
 
Join Date: Jul 2008
Posts: 526
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The center console needs to come out(couple screws and some 10mm bolts)You can buy a shifter from the dealer parts counter.The module is inside the shifter assembly.Chrysler has a new policy that all cars in for service should have all the computers checked for flash updates, with approval from the owner.It's something I would do to keep all my on board computers up to date.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 07-26-2009, 04:23 PM
Member
 
Join Date: Apr 2009
Posts: 85
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dash light problem

i cleared it with the prediator and everything seemed okay. although i was mistaken which light was on . it was one on the right straight across from the D for drive, it was a square with an 8 in the center of it, not the lightning bolt which is right above it. i looked in the owners manuel for that symbol but couldnot find it. i am going to try and take my car to hennessey this week and have it dynoed and tuned, they are only 20 minuets from where i live,maybe they can fix it. any idea what that symbol might be thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > Model Specific Discussion > Dodge Challenger SRT8 Specific > 6.1L / 372ci (2008 - 2010)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedlogix Ported Throttle Bodies-V6, 5.7, 6.1, 392 SRT8U Speedlogix 38 03-25-2014 07:43 AM
And you think electronic throttle is bad... SRT8Tech The Garage: For OTHER car talk 3 10-29-2012 05:36 AM
Help with HID conversion Dellhoney General Challenger Discussion 26 09-03-2012 11:34 AM
Electronic Throttle Control Problem BlackBetty10 Dodge Challenger R/T Specific 6 08-01-2012 05:33 AM
Check Engine Light is On...Help! 2BLU4U 6.4L / 392ci (2011 - ?) 19 07-13-2012 10:35 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:42 AM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.5.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.