Engine Stalling? - Dodge Challenger Forum: Challenger & SRT8 Forums
Dodge Challenger Forum Dodge Challenger Forum
 

» Featured Product
Auto Insurance

Wheel & Tire Center

Go Back   Dodge Challenger Forum: Challenger & SRT8 Forums > Model Specific Discussion > Dodge Challenger SRT8 Specific > 6.1L / 372ci (2008 - 2010)

ChallengerTalk.com is the premier Dodge Challenger Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04-05-2010, 03:32 PM
Junior Member
 
Join Date: Apr 2010
Posts: 9
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Engine Stalling?

Proud owner of a new 2010 B5 Blue SRT8 automatic. So far I've got about 800 miles on it, and the strangest thing happened to me twice while driving around two days ago. The first time I was on a side street and noticed the the car was hard to steer. The power steering had gone out and the red oil light and orange traction control lights had come on. I was able to hit the Start Engine button, the engine restarted after a slight hesitation, and I went on my way. A short while later while driving through an intersection a similar thing happened. This time the engine died as well, but only the red oil light came on and not the traction control. When I tried pressing the Start Engine button a message came up saying "Vehicle is not in Park" I had to put it in park, start the engine, and put it back in drive. When I hit the gas it sounded/felt like gears were grinding for the first few seconds and then slipped into gear. When I got home I parked it and called the dealer who wants me to bring it in.

Guess I'm going to be calling Chrysler roadside assistance since I don't want to be driving it down the highway and having it die on me. Has anyone heard of this or something similar happening?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-05-2010, 04:27 PM
moparmafia's Avatar
Senior Member
 
Join Date: Feb 2009
Location: Jefferson County ,Pa
Posts: 1,067
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, yes, but only one other time and it was also a SRT.
__________________
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-05-2010, 04:46 PM
RT6SPD's Avatar
Senior Member
 
Join Date: Apr 2009
Posts: 943
Photos: (4)
Thanks: 21
Thanked 26 Times in 24 Posts
Feedback Score: 2 reviews
Traction control will cause engine stalls in slippery conditions. It reduces power to gain traction and then the engine stalls. I always drive with ESP off. Autos are different than 6 speeds. You need to use the key trick to disable in the automatic.

But I would get it checked out at the dealer.

B5 is my fav color. Take care of her, you lucky SOB!!!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-06-2010, 06:23 PM
rayzazoo's Avatar
Senior Member
 
Join Date: Jan 2009
Location: Texas
Posts: 3,880
Photos: (0)
Thanks: 84
Thanked 293 Times in 185 Posts
Feedback Score: 5 reviews
I had this happen too. Engine would stall or shut off with the oil light. The code that I had was low engine oil which I traced back to my oil catch can and the hose lines not being clamped down.

If you are stock, it might just be time for an oil change even if it's less than 3000mi.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 04-15-2010, 08:42 AM
Junior Member
 
Join Date: Apr 2010
Posts: 9
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Took the Challenger into the service shop and they had it for a day and a half. They said everything checked out perfectly and they couldn't find anything wrong with it. Strange, I hope it doesn't happen again.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 04-15-2010, 03:35 PM
Senior Member
 
Join Date: Nov 2008
Location: chicago burbs
Posts: 219
Photos: (25)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, you have documented it with the dealer. that way if it happens again (and I hate to even say this, so I appologize! )If god forbid some thing was to happen to her like not being able to stop her ect ect. they would probably be responsibe.With that said, Im sure it will be fine and it was just a isolated one time thing. best of luck.
__________________
silver 08 srt8,#3706 fully loaded w/sun roof. my gig lock pic,zoomers cat backs{high polish} with x pipe,venture-shield clear bra,zaino paint protection, limo tint,door sills, custom floor mats,custom trunk mat,bright pedals.mopar strut tower brace. Billit catch can w/braided hoses. custom raised Dodge nose badge from billit. predator tuner. Aria stainless intake #005 and show quality painted carbon fiber intake.AAC Halos,and fog light upgarde to HID,all 6000k.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 04-15-2010, 03:56 PM
Member
 
Join Date: Feb 2010
Posts: 57
Photos: (0)
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Happened to me 3 times within the first couple hundred miles but hasn't happened again. Freaked me out the first time...
__________________


2010 Challenger SRT8
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 04-15-2010, 04:47 PM
PRZ3124's Avatar
Senior Member
 
Join Date: Sep 2009
Location: Chicago
Posts: 234
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Originally Posted by RT6SPD View Post
Traction control will cause engine stalls in slippery conditions. It reduces power to gain traction and then the engine stalls. I always drive with ESP off. Autos are different than 6 speeds. You need to use the key trick to disable in the automatic.
On my SRT auto I only have to hold the esp button in for like 5 sec while stopped and the esp goes full off. The little yellow traction control lights up and the evic will read ESP off.

I don't know about the six speeds but the first time you hit the button without holding it in you only turn esp to 60%. Until you get readout esp off its still partially on.

JandA good luck hope its nothing serious.
__________________

Black pearl 2009 SRT8
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 04-15-2010, 05:34 PM
RT6SPD's Avatar
Senior Member
 
Join Date: Apr 2009
Posts: 943
Photos: (4)
Thanks: 21
Thanked 26 Times in 24 Posts
Feedback Score: 2 reviews
At least our cars stall occasionally... not go full throttle and the brakes quit working.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 05-06-2010, 09:39 PM
porkchop36's Avatar
Member
 
Join Date: Nov 2009
Posts: 59
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my car has also did this 4 times took it to dealer and they said they couldnt make it do it again so i had to come pick it up strange thing they say it is not trowing any codes? 1600 miles on it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > Model Specific Discussion > Dodge Challenger SRT8 Specific > 6.1L / 372ci (2008 - 2010)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine light constantly codes. 180 thermostat?? JJJ Challenger Issues & Problems 1 10-28-2012 06:10 AM
Revving the engine caused a check engine light on my 392 JakeInFla Challenger Issues & Problems 16 10-04-2012 11:36 AM
Torq specs for motor mounts? GR8 PMKN Performance Modifications 3 09-14-2012 11:36 AM
Check Engine Code P2066, Engine Stalled on Highway... HELP!! ShastaMcNasty Challenger Issues & Problems 2 08-13-2012 09:56 PM
Code P000B kbr577 Tuning/Data 3 07-27-2012 12:56 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:59 AM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.5.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.