2012 Challenger wont start - Page 2 - Dodge Challenger Forum: Challenger & SRT8 Forums
Reply
 
LinkBack Thread Tools Display Modes
#11 (permalink) Old 07-31-2012, 05:22 PM
Member
 
Join Date: Jun 2012
Location: Toronto
Posts: 83
Thanks: 5
Thanked 7 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
Hate to bump my own thread...but challengers back at the dealership. 3x within 2 week period. Is there anything that says the car can be returned within 90 days of purchase?

Gexx is offline  
Sponsored Links
Advertisement
 
#12 (permalink) Old 07-31-2012, 05:41 PM
Junior Member
 
Join Date: May 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you are probably missing an ignition feed from the win module to the tipm I've had one that came to our dealership from the train yard and what was happening ins that the win module was not powering up an ignition feed to the tipm they should be able to monitor the ignition voltage and see proper voltage with a meter at the back side of the tipm


Sent from my Autoguide iPhone app
bouch is offline  
#13 (permalink) Old 07-31-2012, 06:23 PM
Member
 
Join Date: Jun 2012
Location: Toronto
Posts: 83
Thanks: 5
Thanked 7 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
Quote:
Originally Posted by bouch View Post
you are probably missing an ignition feed from the win module to the tipm I've had one that came to our dealership from the train yard and what was happening ins that the win module was not powering up an ignition feed to the tipm they should be able to monitor the ignition voltage and see proper voltage with a meter at the back side of the tipm


Sent from my Autoguide iPhone app
Todays problem is a bit different. My Car started up. As i was reversing it went apes**t. Said Power steering needed to be serviced, ABS was off, i was losing traction and then It kept jerking my steering wheel making it very difficult to turn. After about 2-3 minutes of this all the errors went away and the check engine light came on. No more ECO mode since that point; the car still starts up.
Gexx is offline  
#14 (permalink) Old 07-31-2012, 06:54 PM
Junior Member
 
Join Date: May 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have you made the m10 recall complete there is a mini fuse it is 25 amp in the UPC in the engine bay what has to happen is the fuse needs to be relocated to a bigger fuse I belevie it's moving fuse 14 into fuse 6 location what happens is the power feed gets lost due to back cone tion and your ESP and abs will light up and then it will come back


Sent from my Autoguide iPhone app
bouch is offline  
#15 (permalink) Old 07-31-2012, 06:54 PM
Junior Member
 
Join Date: May 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
not UPC the ipc fuse box


Sent from my Autoguide iPhone app
bouch is offline  
#16 (permalink) Old 08-01-2012, 06:55 AM
Member
 
Join Date: Jun 2012
Location: Toronto
Posts: 83
Thanks: 5
Thanked 7 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
Quote:
Originally Posted by bouch View Post
have you made the m10 recall complete there is a mini fuse it is 25 amp in the UPC in the engine bay what has to happen is the fuse needs to be relocated to a bigger fuse I belevie it's moving fuse 14 into fuse 6 location what happens is the power feed gets lost due to back cone tion and your ESP and abs will light up and then it will come back


Sent from my Autoguide iPhone app
Doesn't this recall only affect the Charger/300c? I found the guide on how to do this.
Gexx is offline  
#17 (permalink) Old 08-01-2012, 10:39 PM
Senior Member
 
Join Date: May 2012
Posts: 124
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 2 reviews
Won't start - Brake Lights Drain Battery

Quote:
Originally Posted by magnumforc View Post
Mine wouldn't start and after all the diagnostics at the dealer, they said nothing was wrong. I told them the brake lights stuck on and they said there was nothing wrong with the switch etc. Came out of a restaurant today and viola, the brake lights were on. Backing into the garage, took my foot off the brake and the brake lights stayed on. Lift the pedal with my toe and they go off. Just as I told them. Another danged trip to the dealer for something they should have fixed three weeks ago! This time I have a photo to prove it!
Took it in today, first tried to adjust switch and found that wouldn't work, plunger kept activating lights. Discovered could not be adjusted and the brake light switch faulty and replaced. No longer makes "clicking sound" when brake pedal is pressed. Hope this solves dead battery issue. Becoming much too friendly with this dealer, although they are the best around. Jack Powell Dodge in Escondido, CA
magnumforc is offline  
#18 (permalink) Old 08-02-2012, 09:07 AM
Member
 
Join Date: Jun 2012
Location: Toronto
Posts: 83
Thanks: 5
Thanked 7 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
Quote:
Originally Posted by magnumforc View Post
Took it in today, first tried to adjust switch and found that wouldn't work, plunger kept activating lights. Discovered could not be adjusted and the brake light switch faulty and replaced. No longer makes "clicking sound" when brake pedal is pressed. Hope this solves dead battery issue. Becoming much too friendly with this dealer, although they are the best around. Jack Powell Dodge in Escondido, CA
Haha...yeh man im feeling the same way with the dealer, I come in and they know me by name, im not liking it
Gexx is offline  
#19 (permalink) Old 08-16-2012, 07:59 PM
Member
 
Join Date: Jun 2012
Location: Toronto
Posts: 83
Thanks: 5
Thanked 7 Times in 5 Posts
Feedback Score: 0 reviews
(Thread Starter)
3 Weeks after initial problem started, i finally received my car today. They tech said that there were some loose connectors between the ECU/and Wire harness. Don't know why it took them 3 weeks to figure this out and i hope this issue doesnt come back.
Gexx is offline  
#20 (permalink) Old 12-14-2012, 04:44 PM
Member
 
Shads Challenger's Avatar
 
Join Date: Aug 2012
Posts: 46
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I am going throug this right now. Had car at dealer almost 2 weeks with no start. They are replacing tipm on monday.

Sent from my SCH-I500 using AutoGuide.Com Free App
Shads Challenger is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Challenger Discussion > Challenger Issues & Problems

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 Challenger Information Thread ResumeSpeed General Challenger Discussion 1300 10-03-2014 01:02 PM
I love my new 2012 Challenger!!! CURAMEN New Member Introductions 22 04-28-2013 01:50 PM
West Coast Challengers Car Club 2012 raVenX California 126 01-07-2013 07:58 PM
2013 Dodge Challenger ResumeSpeed General Challenger Discussion 8 09-02-2012 09:26 AM
2012 charger sxt seat in 2012 sxt challenger gcook67 Interior Discussion / Modifications 0 07-11-2012 08:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome