Brake Problem with New 2013 Challenger - Dodge Challenger Forum: Challenger & SRT8 Forums
Dodge Challenger Forum Dodge Challenger Forum
 

» Auto Insurance

» Wheel & Tire Center

» Featured Product
Go Back   Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Challenger Discussion > Challenger Issues & Problems

ChallengerTalk.com is the premier Dodge Challenger Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03-07-2013, 07:36 PM
Senior Member
 
Join Date: Feb 2011
Posts: 101
Photos: (0)
Thanks: 1
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Brake Problem with New 2013 Challenger

2013 SRT8 Manual and yestersay I started having some brake problems. It started when... In stop and go traffic...the same amount of pressure to slow the car, would either cause the brakes to grab or there being no response.

Tonight getting in the car to drive home, before starting it up... I found the brake pedal hard as a rock... No reserve. Then, tonight, after sitting on 15 minutes... Same thing.

Vacuum leak? Bad booster?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-07-2013, 08:38 PM
O_Racing's Avatar
Lifetime Premium Member
 
Join Date: Aug 2012
Location: USA
Posts: 638
Photos: (0)
Thanks: 191
Thanked 223 Times in 148 Posts
Feedback Score: 0 reviews
Originally Posted by jmatero View Post
2013 SRT8 Manual and yestersay I started having some brake problems. It started when... In stop and go traffic...the same amount of pressure to slow the car, would either cause the brakes to grab or there being no response.

Tonight getting in the car to drive home, before starting it up... I found the brake pedal hard as a rock... No reserve. Then, tonight, after sitting on 15 minutes... Same thing.

Vacuum leak? Bad booster?
dealership!
__________________
Billet 2013 Challenger SRT8, 6sp
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-07-2013, 09:28 PM
Hal H's Avatar
Super Moderator
 
Join Date: Aug 2008
Location: Portland, OR
Posts: 7,596
Photos: (0)
Thanks: 1
Thanked 1,037 Times in 704 Posts
Feedback Score: 0 reviews
I'd suspect a faulty vacuum booster - erratic brake pedal pressure (or being grabby with poor modulation) is a typical symptom.
__________________
2009 R/T 27J pkg (6 speed MT) ordered 7/17/08, built 10/23/08, home on 11/13/08

Eibach Sportline Suspension
Hotchkis Sway Bars
Nitto 555 Extreme 265/50-18"
392 Cam / DS CMR tune
Hurst /G&K modded short-throw shifter
Reply With Quote Quick reply to this message
The Following User Says Thank You to Hal H For This Useful Post:
driller (03-09-2013)
  #4 (permalink)  
Old 03-08-2013, 07:12 PM
Fast Freight's Avatar
Senior Member
 
Join Date: Sep 2011
Location: Maryland
Posts: 415
Photos: (0)
Thanks: 0
Thanked 32 Times in 26 Posts
Feedback Score: 0 reviews
Make sure you check the Lemon Laws for your state.....In Maryland, a problem with brakes or steering MUST be fixed in the first visit or the car must be replaced or your money refunded!!
__________________


2012 R/T Plus
Header Orange
Hurst AutoStick
Magnaflow Competition Exhaust
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 03-08-2013, 11:33 PM
Senior Member
 
Join Date: Feb 2011
Posts: 101
Photos: (0)
Thanks: 1
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Well, brought it in and they were unable to reproduce the brake issue. And they said it is normal for the car to sit a period of time and have no reserve boost befor starting the motor. Can anyone here confirm that, after sitting overnight, their brake pedal is hard as a rock before starting up?

Mine becomes that way in 20 minutes.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 03-09-2013, 02:43 AM
GaryT's Avatar
Premium Member
 
Join Date: Jun 2012
Location: Chillicothe, Ohio
Posts: 640
Photos: (0)
Thanks: 2
Thanked 100 Times in 85 Posts
Feedback Score: 1 reviews
Mine has been stored since November, and even when I start it up once every 3-4 weeks, the brake pedal feels normal.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 03-09-2013, 03:48 AM
Yellow Jacket 2012's Avatar
Lifetime Premium Member
 
Join Date: Jul 2012
Location: Northern Jersey
Posts: 5,248
Photos: (0)
Thanks: 373
Thanked 1,397 Times in 880 Posts
Feedback Score: 0 reviews
I have noticed on startup the pedal is hard but being my first molar never gave it a second thought. Why not go to your dealer and ask to try one or two more on the lot to compare? The sensitivity is more of an issue than the feel after sitting.
__________________
As I have grown older, I've learned that pleasing everyone is
impossible- but pissing everyone off, is a piece of cake.



Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 03-09-2013, 04:20 AM
Junior Member
 
Join Date: Jan 2013
Posts: 13
Photos: (0)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Re: Brake Problem with New 2013 Challenger

Wow... Have a 2012 Jeep Grand Cherokee that doe same thing, had dealer review and they tried the possible vacuum leak and changed a part near the booster, still does it, start doing this at 1500 miles and now have 10000 without degradation in braking performance. I have a 2013 challenger with 1600 miles and so far it is good, pedal has play. Will have service 2 next week on Cherokee and have them check again.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 03-09-2013, 06:35 AM
rayzazoo's Avatar
Senior Member
 
Join Date: Jan 2009
Location: Texas
Posts: 4,446
Photos: (0)
Thanks: 236
Thanked 602 Times in 359 Posts
Feedback Score: 5 reviews
Brake Problem with New 2013 Challenger

I wonder if you have an air bubble in the brake lines. You might need a brake fluid flush.


Sent from AutoGuide.com App
__________________

Torred '15 6.2L SRT8 Hellcat - 11.2 @ 125.4 mph - NHRA (August 2014)
Tungsten '12 392 SRT8 - 12.847 @ 109.89 mph
Torred '10 6.1L SRT8 - 12.604 @ 112.11 mph / 12.817 @ 110.05 mph
Torred '09 5.7L R/T - 13.291 @ 103.67 mph

Intakes, Throttle Bodies, Catch Cans, Tuners, Heatsoak
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 03-10-2013, 07:20 PM
Junior Member
 
Join Date: Mar 2013
Posts: 28
Photos: (0)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Brembo brakes squealing badly

Anybody have problems with their Brembos squealing when applied? Bought my 2009 SRT about 4weeks ago. The second day I had it I noticed the noise. Brought the car back to dealer and they said there's nothing wrong! Brembos make noise, it's normal. I was upset that I paid $31,000 for a car squealing. They said front brakes were 90% good and rear were 65% good. I finally had enough and took it to them again demanding them to do something. The manager told the service dept to resurface them a little bit. He said the rotor could of been glazed. It worked about a week, and they are doing it again! Any input guys?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Challenger Discussion > Challenger Issues & Problems

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
8 Speed for GC SRT Go Goody The Garage: For OTHER car talk 5 07-20-2013 05:21 PM
Canada - 2008 MSRP about 50,000 money2burn General Challenger Discussion 6 08-05-2011 12:28 PM
Mopar(R) Reveals Dodge Challenger Drag Race Package Cars at the 29th Annual Mopar Mil SRT8 WOOLF General Challenger Discussion 2 07-14-2008 03:48 PM
History Of The Dodge Challenger Pony Car - 1970 to 2006 Rambit General Challenger Discussion 4 02-10-2008 08:01 PM
Dodge Challenger to be built at Brampton, Ontario plant ekool Dodge Challenger News 2 02-15-2007 08:42 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:11 PM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.5.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.