Burning Oil Smell While Driving - Dodge Challenger Forum: Challenger & SRT8 Forums
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-16-2012, 08:02 PM
Member
 
4DEATER's Avatar
 
Join Date: Dec 2005
Location: Lima, OH
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to 4DEATER
(Thread Starter)
Burning Oil Smell While Driving

That's the gist of it. Driving along about 45 to 50 and out of no where a strong smell of burning oil. Smells like dropping oil on your headers during an oil change and it goes away in a few seconds. Just happens randomly and I seem to smell it more times after coming to a stop. I looked under the hood the best I could tonight with a flashlight and no visible signs of oil. On a side note I never smelled it before my first oil change at the dealer. Any thoughts or others with this issue?

2011 Challenger 392 GWE
Purchased 10/15/11



**SOLD** Charger SRT-8
Brilliant Black Crystal Pearl Coat
SRT- options I and II
Purchased 12/21/05


Last edited by 4DEATER; 11-30-2012 at 05:55 PM.
4DEATER is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-30-2012, 05:52 PM
Member
 
4DEATER's Avatar
 
Join Date: Dec 2005
Location: Lima, OH
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to 4DEATER
(Thread Starter)
Just a follow up in case this becomes an issue for anyone else. Had two dealers check it out and finally found that I had a leaking valve cover gasket. Problem solved so far.
4DEATER is offline  
#3 (permalink) Old 11-30-2012, 06:39 PM
Senior Member
 
viva hemi's Avatar
 
Join Date: Aug 2011
Location: toronto canada
Posts: 155
Thanks: 3
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 4DEATER View Post
Just a follow up in case this becomes an issue for anyone else. Had two dealers check it out and finally found that I had a leaking valve cover gasket. Problem solved so far.
Will have to have mine checked. I have the same issue. Happens after I drive her hard, which is every time I take her out.
Which side and approx where was it leaking?
Thanks
viva hemi is offline  
#4 (permalink) Old 11-30-2012, 07:01 PM
Member
 
4DEATER's Avatar
 
Join Date: Dec 2005
Location: Lima, OH
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to 4DEATER
(Thread Starter)
I saw oil that had ran down on my oil filter when I changed it last so I am guessing the passenger side. Sounds like you have the same thing though.
4DEATER is offline  
#5 (permalink) Old 11-30-2012, 07:41 PM
Senior Member
 
RT23's Avatar
 
Join Date: Nov 2012
Location: Near the Dallas/Ft Worth Metroplex
Posts: 379
Thanks: 26
Thanked 94 Times in 68 Posts
Feedback Score: 0 reviews
Did you get a look at the gasket? Just curious as to whether it was torn, defective or what. Glad you got it fixed.
Like your screen name BTW.

Life is hard. It's harder if you're stupid.

Last edited by RT23; 11-30-2012 at 07:42 PM.
RT23 is offline  
#6 (permalink) Old 12-12-2012, 01:02 PM
Member
 
4DEATER's Avatar
 
Join Date: Dec 2005
Location: Lima, OH
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to 4DEATER
(Thread Starter)
I did not get a look at the gasket sorry.

Last edited by 4DEATER; 12-12-2012 at 01:03 PM.
4DEATER is offline  
#7 (permalink) Old 01-08-2013, 10:20 AM
Lifetime Premium Member
 
FourMopars's Avatar
 
Join Date: Jun 2008
Posts: 95
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 4DEATER View Post
Just a follow up in case this becomes an issue for anyone else. Had two dealers check it out and finally found that I had a leaking valve cover gasket. Problem solved so far.

My 2011 SRT8 Challenger has just under 7000 miles and I have always smelled oil usually after I stop, I thought it was other vehicles around me. But I have confirmed it is no other vehicles causing the odor. I have not taken it to the dealer yet. I have had two oil changes and still the same thing. I have used Bosch and Mobile 1 filters...made no difference.

Thanks for the information. I will let the dealership know what was causing your burned oil smell. Thanks again.


Never too many Mopars, only too little garage.

(2011 Dodge Challenger SRT 392 in Toxic Orange, 1973 Dodge Challenger 340 B-5Blue, 2005 Dodge Daytona Ram GoManGo, 2003 Chrysler PT/GT Dream Cruiser Tangerine)
FourMopars is offline  
#8 (permalink) Old 01-09-2013, 05:10 PM
Junior Member
 
Join Date: Jan 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by FourMopars View Post
My 2011 SRT8 Challenger has just under 7000 miles and I have always smelled oil usually after I stop, I thought it was other vehicles around me. But I have confirmed it is no other vehicles causing the odor. I have not taken it to the dealer yet. I have had two oil changes and still the same thing. I have used Bosch and Mobile 1 filters...made no difference.

Thanks for the information. I will let the dealership know what was causing your burned oil smell. Thanks again.
The gaskets are too brittle. They get hot and crack. The old bimmers did that too.
After some mileage you can change to a HM oil
dodgedart is offline  
#9 (permalink) Old 01-15-2013, 01:02 AM
Lifetime Premium Member
 
FourMopars's Avatar
 
Join Date: Jun 2008
Posts: 95
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by FourMopars View Post
My 2011 SRT8 Challenger has just under 7000 miles and I have always smelled oil usually after I stop, I thought it was other vehicles around me. But I have confirmed it is no other vehicles causing the odor. I have not taken it to the dealer yet. I have had two oil changes and still the same thing. I have used Bosch and Mobile 1 filters...made no difference.

Thanks for the information. I will let the dealership know what was causing your burned oil smell. Thanks again.
Well my car went to the dealership today, they tried and could not find a leak. I went into the garage and looked with them...no leak could be found. One of the Mechanics suggested it was the cosmoline burning off. So no answers yet. Not upset with the mechanics as I was with them and could not find it. No TSB's on the issue either.
FourMopars is offline  
#10 (permalink) Old 03-28-2013, 06:48 AM
Junior Member
 
Join Date: Jul 2012
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey 4DEATER, thanks for this info. I'm experienceing the same thing and no sign of leak. Plan on bringin'er to the dealer for a checkup. Hopefully they'll spot the source.
Carmen_SRT is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Challenger Discussion > Challenger Issues & Problems

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Arrington Oil Separator install on Kenne Bell, fresh air side. rick s Forced Induction 6 12-27-2012 10:57 AM
Goodbye, V-8s, the Engines That Could GreatAmerican General Challenger Discussion 96 09-02-2012 02:31 PM
First oil change - oil soaked air filter. laurag146 Challenger Issues & Problems 7 07-28-2012 10:03 PM
Code P000B kbr577 Tuning/Data 3 07-27-2012 02:56 PM
Oil Change From HELL!!! KDodge75 General Challenger Discussion 44 07-07-2012 09:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome