Dodge Challenger Forum: Challenger & SRT8 Forums - View Profile: rick s

rick s rick s is offline

Senior Member

  Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Audinator
    04-06-2012 12:18 AM - permalink
    Audinator
    Hi Rick,
    I installed my KB system and now working on bleeding the coolant system.
    Did exactly as you said, got a T and hoses and went to blowing the air out. All seemed ok, however after running it up to 195 degrees, the upper radiator hose feels hot but the lower hose feels cool and seems like no coolant is flowing through the lower hose, feels empty, So I did all the steps again, but again the same results? Is this normal? it seems like there should be flow through the lower radiator hose, there is a constant stream of fluid in the overflow tank, and I want to be sure before bolting the front end back on. Everything else seems to be working just right.

    Thanks AW

  About Me

  • About rick s
    Location
    Chester, VA
  • Signature
    Rick

    2009 Challenger SRT8, Automatic, Hemi Orange
    Kenne Bell Supercharger, 2.8 LC

  Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: 10-24-2014 06:19 PM
  • Join Date: 04-19-2009
  • Referrals: 0

  Mentions

No results to display...

  Thread Tags

No results to display...

  Quotes

10-18-2014
07:16 PM - Mapearso quoted rick s in post 0-60 time after supercharging you R/T
I can't speak for the R/T b...

  Feedback Score

iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0
 
For the best viewing experience please update your browser to Google Chrome