Check Engine Light 2013 Challenger R/T 2k miles - Dodge Challenger Forum: Challenger & SRT8 Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 11-26-2012, 08:03 PM Thread Starter
Member
 
Moonblink's Avatar
 
Join Date: Nov 2012
Posts: 93
Thanks: 16
Thanked 29 Times in 18 Posts
Feedback Score: 0 reviews
(Thread Starter)
Check Engine Light 2013 Challenger R/T 2k miles

My new 2013 Challenger R/T Plus has only 2,100 miles on it and I was driving up the hill from my house and I hear a clang sound and then my check engine light comes on :/ I took it to the local dealer (who has excellent reviews on Yelp) and they told me that the code was pointing to the Transmission and that it had a problem shifting between 3 & 4th gear and that the code was from 600 miles ago? I asked how a code from 600 miles ago is related to a check engine light that just happened yesterday. The answer I got was that the computer logged to code and tried to fix the problem and when it couldn't (600 miles later) it turned on the CEL. Sounds fishy to me. I also got out of the service manager that it could be a valve in the transmission. They cleared the CEL and told me if it happens again they will pull the tranny apart and look further. I took it out for a long 1.5 hour drive through the mountains today putting the car through Auto mode, Sprots mode, and Manual mode and no problems and no CEL. Anyone have this happen? Thanks!


EDIT******* Sorry Auto Transmission :P

2013 Dodge Challenger R/T Plus W/Super Track Pack, Petty Garage R/T Strut Brace, Functional Hood Scoops, GPM Caliper Covers, and 3gcustomz Engine Half Covers, Flowmaster Super 44's, K&N air filter, Airaid throttle body spacer, Speedlogix catch can, and tons of billet aluminum engine dress up.

Last edited by Moonblink; 11-26-2012 at 08:06 PM.
Moonblink is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 11-26-2012, 10:08 PM
Senior Member
 
Join Date: May 2011
Posts: 159
Thanks: 1
Thanked 4 Times in 3 Posts
Feedback Score: 0 reviews
Did they happen to tell you what CEL was for (what the code was)?
Blackbird is offline  
post #3 of 18 (permalink) Old 11-27-2012, 08:36 AM
Senior Member
 
Join Date: Nov 2012
Location: IL
Posts: 1,033
Thanks: 3
Thanked 139 Times in 109 Posts
Feedback Score: 0 reviews
Many issues need to be logged twice before the CEL comes on.
3boystoys is offline  
The Following User Says Thank You to 3boystoys For This Useful Post:
Moonblink (12-05-2012)
Sponsored Links
Advertisement
 
post #4 of 18 (permalink) Old 11-28-2012, 12:48 PM
Senior Member
 
Join Date: Nov 2012
Posts: 1,007
Thanks: 122
Thanked 379 Times in 243 Posts
Feedback Score: 0 reviews
Not trying to be discouraging, but a brand new car giving a code and making noise that it probably shouldnt.... I may see what my options are on a different one. Did you order this car or was it on lot?

Life is hard. It's harder if you're stupid.

Last edited by RT23; 11-28-2012 at 12:49 PM.
RT23 is offline  
post #5 of 18 (permalink) Old 12-05-2012, 12:20 PM Thread Starter
Member
 
Moonblink's Avatar
 
Join Date: Nov 2012
Posts: 93
Thanks: 16
Thanked 29 Times in 18 Posts
Feedback Score: 0 reviews
(Thread Starter)
I ordered it. The dealer told me the code but I didn't write it down. I drove the hell out of it for 1.5 hours in the mountains with no problems and since then no CEL. I am just chalking it up to a software glitch. I have the extended warranty so I am not going to lose any sleep over it. The car drives like a dream and my dealer seems to be a good one. I will follow up if it happens again.

Last edited by Moonblink; 12-05-2012 at 12:27 PM.
Moonblink is offline  
post #6 of 18 (permalink) Old 01-04-2013, 11:50 AM Thread Starter
Member
 
Moonblink's Avatar
 
Join Date: Nov 2012
Posts: 93
Thanks: 16
Thanked 29 Times in 18 Posts
Feedback Score: 0 reviews
(Thread Starter)
Check engine light came back on and the dealer opened up the transmission and found metal burs in the valve that shifts the 3rd and 4th gear. They pulled the valve, cleaned it, and refilled the transmission. The CEL is gone and everything is back to normal.
Moonblink is offline  
post #7 of 18 (permalink) Old 01-04-2013, 12:01 PM
Lifetime Premium Member
 
MoparOhio's Avatar
 
Join Date: Sep 2008
Location: Columbus, Ohio
Posts: 4,356
Thanks: 14
Thanked 420 Times in 309 Posts
Garage
Feedback Score: 0 reviews
Good deal. Glad it happened a second time so quickly and hopefully they have fixed it so you can relax and enjoy that beast.

TorRed SE Model purchased: 2/05/09 (gone but not forgotten)
TorRed R/T Classic ordered: 4/06/13
R/T Classic born on: 6/04/13
R/T Classic delivered on: 6/21/13
Mods installed:
Mopar CAI
RiderGraphix spoiler graphic
Skip-to-shift eliminator
Cursive Challenger on grille
Engine Cover air brush painted
Billet under the hood stuff
MOPAR door sills

Member of Frederick Scat Pack

Other vehicle: 1978 Dodge Little Red Express
MoparOhio is offline  
post #8 of 18 (permalink) Old 01-04-2013, 12:35 PM
Senior Member
 
Join Date: Nov 2012
Location: IL
Posts: 1,033
Thanks: 3
Thanked 139 Times in 109 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Moonblink View Post
Check engine light came back on and the dealer opened up the transmission and found metal burs in the valve that shifts the 3rd and 4th gear. They pulled the valve, cleaned it, and refilled the transmission. The CEL is gone and everything is back to normal.
Doesn't sound good to me, bet there is more PAIN in your future.
3boystoys is offline  
post #9 of 18 (permalink) Old 01-04-2013, 02:25 PM Thread Starter
Member
 
Moonblink's Avatar
 
Join Date: Nov 2012
Posts: 93
Thanks: 16
Thanked 29 Times in 18 Posts
Feedback Score: 0 reviews
(Thread Starter)
Quote:
Originally Posted by 3boystoys View Post
Doesn't sound good to me, bet there is more PAIN in your future.
I am not worried about it. I have the extended warranty and my dealer is a good one so it's covered for the life of the car.
Moonblink is offline  
post #10 of 18 (permalink) Old 01-04-2013, 05:28 PM
Senior Member
 
Join Date: Nov 2012
Location: IL
Posts: 1,033
Thanks: 3
Thanked 139 Times in 109 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Moonblink View Post
I am not worried about it. I have the extended warranty and my dealer is a good one so it's covered for the life of the car.
Does not mean it still won't be painful, especially if it's your daily driver.
3boystoys is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Challenger Discussion > Challenger Issues & Problems

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mid-West Owner List Venthos Mid-West 285 05-04-2019 07:53 AM
Check Engine Light -Reading Codes 2012 Challenger Perfracer General Challenger Discussion 12 04-09-2016 08:38 PM
Solo Performance Mach X-3 and X-3NT Catback for 2008-2010 Challenger SRT-8 GOINGSOLO2 Solo Performance 180 12-28-2014 12:56 PM
Check Engine Light with P0508 Error Code??? jboogie Challenger Issues & Problems 1 07-02-2012 07:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome