Engine failure - Dodge Challenger Forum: Challenger & SRT8 Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 01-25-2019, 06:56 AM Thread Starter
Junior Member
 
SatoriSRT's Avatar
 
Join Date: Aug 2018
Posts: 13
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
(Thread Starter)
Engine failure

Hi All.

I have a 2014 SRT challenger with 30,000 miles
Last night driving to friends house . I see my whole dash light up like a Christmas tree. Engine stops dead. Had to get it towed back to house .
Then to dodge dealer .now I wait to see if they are going to replace or repair. My question is this a common issue with dodge hemi s ? Also will this hurt car value?

Thanks
SatoriSRT is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 01-25-2019, 08:10 AM
Senior Member
 
ChallyTatum's Avatar
 
Join Date: Dec 2016
Location: The state where 4 out of 7 former Governors went to jail
Posts: 4,036
Thanks: 378
Thanked 889 Times in 746 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by SatoriSRT View Post
Hi All.

I have a 2014 SRT challenger with 30,000 miles
Last night driving to friends house . I see my whole dash light up like a Christmas tree. Engine stops dead. Had to get it towed back to house .
Then to dodge dealer .now I wait to see if they are going to replace or repair. My question is this a common issue with dodge hemi s ? Also will this hurt car value?

Thanks
What makes you think it is a mechanical (i.e. engine) failure and not electrical (i.e. PCM or bad harness)?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2015 Challenger RT+ (non-STP)
8lb Magnuson w/ Innovate PSB-1 wideband/boost/shift light gauge
Corsa extreme (2.5")
4" Aluminum one-piece driveshaft
Hellcat bottom airbox
Stainless Works LT headers (2" primaries)
Barton shifter assembly w/ Lou's short shaft and Speed Dawg knob
Comp Cam 7929 & 7748 push rods (gives slightly more lifter preload)
A2speed aluminum coil and valve covers (built in catchcan)
ChallyTatum is offline  
post #3 of 25 (permalink) Old 01-25-2019, 08:30 AM
Senior Member
 
Join Date: Jan 2015
Posts: 993
Thanks: 0
Thanked 224 Times in 186 Posts
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by SatoriSRT View Post
Hi All.

I have a 2014 SRT challenger with 30,000 miles
Last night driving to friends house . I see my whole dash light up like a Christmas tree. Engine stops dead. Had to get it towed back to house .
Then to dodge dealer .now I wait to see if they are going to replace or repair. My question is this a common issue with dodge hemi s ? Also will this hurt car value?Thanks

ChallyTatum asks the right question.

If the engine is toast and needs to be replaced the new engine, a new factory engine with some warranty, can actually help boost the car's value if you choose to sell/trade in the car afterwards.

You want to be sure to save all the paperwork that shows the engine failed through no fault of yours.

As for the no longer "matching" numbers (VIN and engine number) big deal. Older Dodges that become worth a lot of money have mismatching numbers the least of their problems when they are found and resurrected. Years of sitting in a barn or worse. Mice and rat you know what knee high in the car. Rust. And so on.

Best thing you can do to preserve the car's value is give it proper servicing. Take care of issues when they arise. Don't mod the car. Avoid accidents. And last but not least just drive the car, enjoy the car.
Rockster is offline  
The Following User Says Thank You to Rockster For This Useful Post:
Bob Ricewasser (01-27-2019)
Sponsored Links
Advertisement
 
post #4 of 25 (permalink) Old 01-25-2019, 10:15 AM Thread Starter
Junior Member
 
SatoriSRT's Avatar
 
Join Date: Aug 2018
Posts: 13
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
(Thread Starter)
Ok thanks for responding. From dealer they know its mechanical. Only question now they are waiting on corporate to say repair or replace motor.
SatoriSRT is offline  
post #5 of 25 (permalink) Old 01-25-2019, 10:30 AM
Senior Member
 
Clevetown's Avatar
 
Join Date: Jul 2017
Location: MI
Posts: 561
Thanks: 131
Thanked 108 Times in 86 Posts
Feedback Score: 0 reviews
Wow never heard of that happening before at 30K miles!! Good luck!

2015 Scatpack 392 M6
Black/black
Stainless Works LT Headers
High flow cats
Resonator delete
274 Comp Cam with vvt limiter
Arrington 84 mm throttle body
Barton short throw shifter
Unlocked PCM
Diablo Sport Tuner
HHP Tune
Mopar CAI
Mopar front/rear strut tower braces
Speedlogix SS eliminator
Black lug nuts with Hellcat center caps
Mopar Performance Lowering Springs
Hellcat ram air intake
Hellcat red start button
275 Nittos
Heated/Ventilated seats

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Clevetown is offline  
post #6 of 25 (permalink) Old 01-25-2019, 11:01 AM
Senior Member
 
Slidd's Avatar
 
Join Date: Oct 2013
Location: Louisiana
Posts: 13,079
Thanks: 3,666
Thanked 3,704 Times in 2,786 Posts
Feedback Score: 0 reviews
Still have warranty?

And only thing on FCA and the powertrain, do you have service records or proof that you changed your oil and filter at least every 6 months?


Sent from my SM-N920T using Tapatalk

2016 SRT 392 - Billet Silver, Black Stripes, A8, Tech Group ...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Slidd is online now  
post #7 of 25 (permalink) Old 01-25-2019, 12:22 PM
Senior Member
 
rickytan's Avatar
 
Join Date: Jun 2016
Posts: 103
Thanks: 146
Thanked 10 Times in 6 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by SatoriSRT View Post
Hi All.

I have a 2014 SRT challenger with 30,000 miles
Last night driving to friends house . I see my whole dash light up like a Christmas tree. Engine stops dead. Had to get it towed back to house .
Then to dodge dealer .now I wait to see if they are going to replace or repair. My question is this a common issue with dodge hemi s ? Also will this hurt car value?

Thanks


I’m having the same issue with my 2014 Dodge Challenger SRT it’s at the dealership due to a cyclinder misfire ignition 6

I haven’t heard anything back from the dealership as of yet it’s been there for a week now.


Sent from my iPhone using Tapatalk
rickytan is online now  
post #8 of 25 (permalink) Old 01-25-2019, 01:10 PM
Senior Member
 
DodgeCares's Avatar
 
Join Date: Apr 2012
Location: MI
Posts: 1,320
Thanks: 159
Thanked 393 Times in 230 Posts
Feedback Score: 0 reviews
Hi @SatoriSRT and @rickytan ,

We're terribly sorry to hear that you are experiencing this with your Dodge Challenger! Please let us know if you need additional assistance while your vehicle is in service by sending our team a private message.

Darlene
Dodge Social Care Specialist
DodgeCares is online now  
post #9 of 25 (permalink) Old 01-25-2019, 01:38 PM
Senior Member
 
Join Date: Jan 2015
Posts: 993
Thanks: 0
Thanked 224 Times in 186 Posts
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by rickytan View Post
I’m having the same issue with my 2014 Dodge Challenger SRT it’s at the dealership due to a cyclinder misfire ignition 6

I haven’t heard anything back from the dealership as of yet it’s been there for a week now.


Sent from my iPhone using Tapatalk

That may not be the dealer's fault, though of course regardless you are still in the dark.


Had a car in for some servicing. Tech spotted a transmission selector shaft fluid leak. Car under warranty. The dealer service department contacted the factory to ask repair? Or replace? Silence from the factory. Finally after IIRC nearly a week the factory got back to the dealer and said to "replace" and said a new transmission would be shipped. A couple of weeks later the transmission arrived and a day or so later I had the car back. But all told it took around 3 weeks.
Rockster is offline  
post #10 of 25 (permalink) Old 01-25-2019, 02:21 PM
Senior Member
 
ChallyTatum's Avatar
 
Join Date: Dec 2016
Location: The state where 4 out of 7 former Governors went to jail
Posts: 4,036
Thanks: 378
Thanked 889 Times in 746 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by rickytan View Post
I’m having the same issue with my 2014 Dodge Challenger SRT it’s at the dealership due to a cyclinder misfire ignition 6

I haven’t heard anything back from the dealership as of yet it’s been there for a week now.


Sent from my iPhone using Tapatalk
I have seen a couple of threads where the cylinder misfire was linked to a bad lifter/cam lobe.
ChallyTatum is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Challenger Discussion > Challenger Issues & Problems

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome