Engine Stalling and Trans Issue after Engine Rebuild - Dodge Challenger Forum: Challenger & SRT8 Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-11-2019, 02:16 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Posts: 28
Thanks: 15
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
(Thread Starter)
Engine Stalling and Trans Issue after Engine Rebuild

This is a follow up to an earlier posting of my "Seized Engine" due to a Lifter failure which put metal filings into my engine. This is a 2008 SRT8 6.1

The mechanic pulled my Engine and completely disassembled it, cleaned and rebuilt it.
The Crank had to be resurfaced, all new bearings, new Oil pump, new water pump, replaced 2 Piston Connecting Rods etc.

We re-installed the SRT Max Plus cam and new Hellcat Lifers.
After the engine was HP tuned and Dyno'd I noticed that the car would periodically stall after I put in into Reverse of Drive.
There was nothing of a pattern that I could observe and it seemed random_sometimes it did it and sometimes it didn't.

The other odd thing is that after an Engine Stall the Trans would not engage when I put the car in either Reverse or Drive for a period of approximately 5 seconds.
This happens when the car is Cold or Hot and it can happen at an Idle or when I abruptly shift into Reverse after braking from 40 mph and quickly executing a 3 point turn.

The sequence of events is as follows:
1_Shift into Reverse or Drive_Car would Stall
2_Shift into Nuetral and Restart Engine
3_Shift into Reverse or Drive
4_Transmission would not engage for approximately 5 seconds

If I stepped on the Gas in either Reverse or Drive the Engine would only Rev_sometimes Shifting back to Drive or Reverse would allow Trans to engage the gears correctly.
On some occasions I have had the Stalling happen 2-3 times in a row which besides being annoying it almost got me Broadsided by an oncoming car while I was stuck across an opposing lane of traffic after a 3 point turn which caused the Stall.

I have brought the car back to the shop twice since the rebuild to have the mechanic check the Tuning and readjust it to try and fix this Stalling issue. Neither re-adjustment of the Tune has fixed the Stalling and the Trans Issue has got me perplexed. How is this related?
The mechanic doesn't seem to have any idea whats causing the Stalling or the Trans issue and I'm once again wondering what the hell is happening.

I have been dealing with this headache between the Seized Engine and now this for weeks on end and once again am asking for any/all suggestions. I am frustrated to my wits end_Please advise.

Thanks all
gday111 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-11-2019, 04:03 PM
Senior Member
 
ChallyTatum's Avatar
 
Join Date: Dec 2016
Location: The state where 4 out of 7 former Governors went to jail
Posts: 4,029
Thanks: 377
Thanked 888 Times in 746 Posts
Feedback Score: 0 reviews
If it stalls when you put in reverse or drive it is most likely the tune...air tables, torque reserve, idle torque spark or idle torque throttle might not be set-up correctly. You might have better luck asking the guys on the HP tuners forum, but if you do they typically need a copy of your tune and a data log of when the stall occurs.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2015 Challenger RT+ (non-STP)
8lb Magnuson w/ Innovate PSB-1 wideband/boost/shift light gauge
Corsa extreme (2.5")
4" Aluminum one-piece driveshaft
Hellcat bottom airbox
Stainless Works LT headers (2" primaries)
Barton shifter assembly w/ Lou's short shaft and Speed Dawg knob
Comp Cam 7929 & 7748 push rods (gives slightly more lifter preload)
A2speed aluminum coil and valve covers (built in catchcan)
ChallyTatum is offline  
post #3 of 6 (permalink) Old 02-11-2019, 05:09 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Posts: 28
Thanks: 15
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
(Thread Starter)
Is the HP Tuners forum part of this website or is that an entirely different website?

Another quick question_Is there a preference for HP or Diablo when tuning these cars?

Thanks
gday111 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 02-11-2019, 05:59 PM Thread Starter
Junior Member
 
Join Date: Nov 2008
Posts: 28
Thanks: 15
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
(Thread Starter)
I just got an email response from Stu at Inertia Motorsports_they sell the SRT Max Plus cam that I installed.
I explained to him the issues I was experiencing_the Stalling and Trans delay when Shifting into gear.

According to Stu:
If the car stalls it's normal for it to take about 5 seconds to go into gear on restart. They all do it.

Before replacing the cam my car never stalled so I have no experience with this delay.
Would you all agree that this is normal?
gday111 is offline  
post #5 of 6 (permalink) Old 02-12-2019, 12:05 AM
Senior Member
 
ChallyTatum's Avatar
 
Join Date: Dec 2016
Location: The state where 4 out of 7 former Governors went to jail
Posts: 4,029
Thanks: 377
Thanked 888 Times in 746 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by gday111 View Post
Is the HP Tuners forum part of this website or is that an entirely different website?

Another quick question_Is there a preference for HP or Diablo when tuning these cars?

Thanks
It's a different site:
https://forum.hptuners.com/

For a while diablo was really the only tuner but recently HP entered the game an some tuners have been migrating over to HP with great results. In the end it's what you want out of the tuner? If you don't ever plan on tweaking the tune yourself then Diablo would probably be a better fit. Now if you do plan on tweaking the tune, then HP is where it is at but there is a fairly steep learning curve.

BTW looks like someone on the LX forum had a similar issue.
https://www.lxforums.com/board/trans...nt-engage.html

Last edited by ChallyTatum; 02-12-2019 at 12:36 AM.
ChallyTatum is offline  
post #6 of 6 (permalink) Old 02-12-2019, 07:38 AM
Super Moderator
 
Hal H's Avatar
 
Join Date: Aug 2008
Location: Lowell NC
Posts: 14,323
Thanks: 22
Thanked 3,338 Times in 2,556 Posts
Garage
Feedback Score: 0 reviews
your issues are involved with the tuning

In Nov 2018, I installed a Modern Muscle NSR cam into a friend's '15 SRT 392 (M6).

It wouldn't idle w/o holding the throttle; if this was an automatic it would not have been drivable to get to the tuner for them to work on it. With this M6 / 392, if you didn't the engine idle would drop and stall - every time with the tune that was on it. (car already had LT headers and high flow cats with tuning for that)

One odd thing I found was with the throttle body connector disconnected, the engine would idle at 1,500 and still had throttle response!

The shop spend the better part of the week tuning it; the NSR cam has a very choppy idle, so it requires tuning to make it all work.

2016 392 Hemi Scat Pack Shaker 23Y pkg (M6) ordered 8/28/15, born 10/23/15, home 11/20/15
Torred / Black/ Ruby Red leather
2009 R/T 27J pkg (M6) ordered 7/17/08, born 10/23/08, home 11/13/08
Hemi Orange / Dark Slate/Light Slate Gray leather
-Sold 9/1/15
Hal H is offline  
The Following User Says Thank You to Hal H For This Useful Post:
A Guy (02-12-2019)
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Challenger Discussion > Challenger Issues & Problems

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome