2011 Uconnect update - Dodge Challenger Forum: Challenger & SRT8 Forums
Car Electronics- Lights, Fuses, Audio & Video Anything that pertains to the interior electronics modifications such as stereos, A/V, lighting...not exclusive to the Challenger please feel free to share

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-23-2012, 11:31 AM Thread Starter
Senior Member
 
Join Date: Jul 2011
Location: Over Here, Hi
Posts: 362
Thanks: 0
Thanked 20 Times in 18 Posts
Feedback Score: 1 reviews
(Thread Starter)
2011 Uconnect update


Hello,
In response to a PM that I received today from a member:

I know that I have this information in several threads, but I can't remember which ones. So I'm going to start a thread with the update title.
This is the update that has been out since June of 2011. It's for 2011 vehicles that were built prior to 6-1-2011 and have the Mitsubishi radios (RES, REQ, RBZ & RHB) ONLY. It is not for the Harman radios (RER, RHR).
This update will fix the "error occurred" that is displayed when connecting an iPod or Iphone to the docking cable. It will also fix the choppy audio when streaming audio thru BT.
Here are the instructions: Make sure that you DO NOT have any power interuptions during the update, for best results have the motor running so there are no interuptions).
You will need at least a 2 GB thumb drive. If you have files on the thumb drive, please delete them and format the drive (to FAT32) just to make sure that it is completely clean.
Download it to the thumb drive that has no other files on it. Turn the radio on, Place the thumb drive in the center console USB connector (on vehicles with the dealer installed unit, it should be in the glove box), press and hold the Uconnect button for about 12 - 15 seconds, you should here "update started". This process should take about 15 - 20 minutes, there will be some beeps during the process. Please listen during the update for any error message that may be said by Uconnect. When the update is completed, the radio screen will go back to a radio display. Turn the ignition off, open & close the drivers door. Wait about 1 minute, then turn the key on and test the system.

and here is the file location uconnect.upd


******NOTE**** I do have a second update for 2011 streaming audio sound quality, the update above needs to be done prior to performing the sound quality update....

Last edited by xsdbs; 10-23-2012 at 11:34 AM.
xsdbs is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-24-2012, 07:44 PM
Senior Member
 
luma's Avatar
 
Join Date: Apr 2011
Posts: 146
Thanks: 5
Thanked 9 Times in 4 Posts
Feedback Score: 0 reviews
This is fantastic. I'm out of town on business this week but will give this a shot this weekend. Any word on the second update?
luma is offline  
post #3 of 10 (permalink) Old 10-29-2012, 08:24 AM Thread Starter
Senior Member
 
Join Date: Jul 2011
Location: Over Here, Hi
Posts: 362
Thanks: 0
Thanked 20 Times in 18 Posts
Feedback Score: 1 reviews
(Thread Starter)
This one has to be applied first, then yes, there is another update that recently came out for the streaming audio sound quality. But it needs to be done after this one.


Quote:
Originally Posted by luma View Post
This is fantastic. I'm out of town on business this week but will give this a shot this weekend. Any word on the second update?
xsdbs is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 11-04-2012, 01:19 PM
Lifetime Premium Member
 
Join Date: Dec 2011
Location: RI
Posts: 410
Thanks: 6
Thanked 48 Times in 41 Posts
Feedback Score: 0 reviews
I attempted to run this update today. The radio announced "updating" and it beeped for about 10 minutes then it said there was an error with the update file (I think it was the archive not compatible message). For reference I believe the current software version is 20.02.01 as the RBZ shows this as the "Application". Audio CPU is 081910. I'll search around to see if it was already updated.

After further investigation and opening the uconnect.upd file in Ubuntu I found a text file that shows the versions v42.12.08:v43.01.40. I wonder if my uconnect is outside of this range. I need a way to check the version without looking at the module because it might be different anyway. The quest continues.

SteveB
2011 Bright White SS/T-Rallye

Last edited by BW2011; 11-04-2012 at 05:38 PM.
BW2011 is offline  
post #5 of 10 (permalink) Old 11-05-2012, 05:00 PM
Lifetime Premium Member
 
Join Date: Dec 2011
Location: RI
Posts: 410
Thanks: 6
Thanked 48 Times in 41 Posts
Feedback Score: 0 reviews
Hi xsdbs,

I decided to open up the glove box to check the Uconnect module. I slipped my phone in to get a pic.



So this does not have the 4x.xx.xx software but 63.01.23. My car was built in May of 2011. I found the 63.01.23 to 63.02.48 upgrade on a Dodge Ram forum but it seems that it was intended for other than audio quality problems. My iPhone 4s and my Blackberry Pearl before it never really had any problems connecting. The big problem is that BT streaming audio is terrible.

Do you know if there is a fix in the pipeline for this module?

Thanks.
BW2011 is offline  
post #6 of 10 (permalink) Old 11-08-2012, 01:42 PM
Junior Member
 
Join Date: Apr 2011
Location: Utah
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thank you xsdbs! You have just saved me a 60 mile trip to the dealer! The updated fixed worked flawlessly! Ill be sure to try your BT update next!
Spidervalve is offline  
post #7 of 10 (permalink) Old 11-09-2012, 03:00 PM
Senior Member
 
Join Date: Oct 2012
Posts: 143
Thanks: 0
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by xsdbs View Post
This one has to be applied first, then yes, there is another update that recently came out for the streaming audio sound quality. But it needs to be done after this one.
Hi xsdbs. Thanks for the info. Do you know if there is an update for the 2012 challenger RHR head units?


Sent from my iPhone using Autoguide.com App
adrake23 is offline  
post #8 of 10 (permalink) Old 12-19-2012, 09:22 AM Thread Starter
Senior Member
 
Join Date: Jul 2011
Location: Over Here, Hi
Posts: 362
Thanks: 0
Thanked 20 Times in 18 Posts
Feedback Score: 1 reviews
(Thread Starter)
I must have missed this post some how. Go ahead and do the update to the 63.2.48, it does have a BT streaming audio update in it that has an enhanced Bitpool rate.



Quote:
Originally Posted by BW2011 View Post
Hi xsdbs,

I decided to open up the glove box to check the Uconnect module. I slipped my phone in to get a pic.



So this does not have the 4x.xx.xx software but 63.01.23. My car was built in May of 2011. I found the 63.01.23 to 63.02.48 upgrade on a Dodge Ram forum but it seems that it was intended for other than audio quality problems. My iPhone 4s and my Blackberry Pearl before it never really had any problems connecting. The big problem is that BT streaming audio is terrible.

Do you know if there is a fix in the pipeline for this module?

Thanks.
xsdbs is offline  
post #9 of 10 (permalink) Old 12-20-2012, 01:50 PM
Lifetime Premium Member
 
Join Date: Dec 2011
Location: RI
Posts: 410
Thanks: 6
Thanked 48 Times in 41 Posts
Feedback Score: 0 reviews
xsdbs, Thanks for your support. I updated to 63.2.48 today and the BT streaming quality is MUCH better! Voice command phone functions still work as well. I guess I can put a fork in this project. Its done!
BW2011 is offline  
post #10 of 10 (permalink) Old 12-27-2012, 09:16 AM Thread Starter
Senior Member
 
Join Date: Jul 2011
Location: Over Here, Hi
Posts: 362
Thanks: 0
Thanked 20 Times in 18 Posts
Feedback Score: 1 reviews
(Thread Starter)
Glad to be of assistance. Enjoy it.



Quote:
Originally Posted by BW2011 View Post
xsdbs, Thanks for your support. I updated to 63.2.48 today and the BT streaming quality is MUCH better! Voice command phone functions still work as well. I guess I can put a fork in this project. Its done!
xsdbs is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > Car Electronics- Lights, Fuses, Audio & Video

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dodge Challenger TSB's 2008-2014 Models ResumeSpeed Technical Service Bulletins & Recalls 81 05-06-2015 04:40 AM
Uconnect issues - voice recognition m_pritchett Challenger Issues & Problems 23 08-28-2014 07:14 AM
2011 Uconnect streaming audio quality xsdbs Car Electronics- Lights, Fuses, Audio & Video 29 09-16-2013 08:20 AM
RER radio update CruzKing Dodge Challenger R/T Specific 12 03-31-2013 05:14 PM
2011 Challenger Uconnect and SMS GJMohrJr Challenger Issues & Problems 3 10-12-2012 09:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome