spark plug? - Page 2 - Dodge Challenger Forum: Challenger & SRT8 Forums
General Maintenance Discussion This sub-forum is for the discussion of general maintenance of your Challenger such as oil changes, coolant maintenance, brake pad replacement, differential fluid changes, alignments, air filters and everything else to maintain your ride.

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 04-13-2019, 04:50 AM
Super Moderator
 
Cuda340's Avatar
 
Join Date: Sep 2006
Location: southern New Jersey
Posts: 13,050
Thanks: 12
Thanked 2,703 Times in 1,849 Posts
Garage
Feedback Score: 0 reviews
Your spark plug seems normal, with minimal deposits and electrode wear. See the attached comparison chart.
Attached Thumbnails
Click image for larger version

Name:	Plugs.jpg
Views:	23
Size:	94.8 KB
ID:	943479  


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Cuda340 is offline  
The Following User Says Thank You to Cuda340 For This Useful Post:
Flat Top (04-13-2019)
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Maintenance Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY Spark Plug Replacement 5.7L Demiskus How-To, DIY and Tips & Tricks 6 04-11-2017 03:57 PM
Amp harness help pbwin Car Electronics- Lights, Fuses, Audio & Video 2 03-25-2013 06:15 PM
help!! No sound coming from aftermarket radio. Need to identify wire! Gator Brah Car Electronics- Lights, Fuses, Audio & Video 5 12-09-2012 11:40 AM
audio turn off pop ? justflewbyu Car Electronics- Lights, Fuses, Audio & Video 17 12-06-2012 04:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome