Water Pump Replacement 5.7 - Dodge Challenger Forum: Challenger & SRT8 Forums
General Maintenance Discussion This sub-forum is for the discussion of general maintenance of your Challenger such as oil changes, coolant maintenance, brake pad replacement, differential fluid changes, alignments, air filters and everything else to maintain your ride.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 05-22-2019, 09:20 PM Thread Starter
Senior Member
 
RT_Kujo's Avatar
 
Join Date: Jun 2013
Location: Portland, OR
Posts: 167
Thanks: 12
Thanked 19 Times in 18 Posts
Feedback Score: 0 reviews
(Thread Starter)
Water Pump Replacement 5.7

About 1/2 mile from home I smelled coolant. After some trouble shooting I confirmed that the water pump failed (45,000 miles). I am considering replacement pumps and would appreciate some input. The standard Mopar 68346915AA says that it is for "without oil cooler." I added an oil cooler 6,000 miles ago as part of my build. Could this have caused the pump to fail? Regardless, anyone know if the SRT water pump (for with an oil cooler) will fit my RT, and if it is the right water pump to get? what's the difference?

I could also go aftermarket at the local O'Reilly's. There are (2) Murray water pumps that will fit. One has a plastic impeller, and one has a metal impeller (but is "from 3/4/2013" - my car was manufactured in 2012). Not sure why there are different part for the same model year but with different build dates. Anyone have any thoughts on this?

2013 Challenger R/T "Stella"
20" Chrome wheels / 3.92 rear gears / STP Suspension / Solo Mach-X Cat Back Exhaust / Functional hood scoops / Challenger door sills / Moroso catch can / Speedlogix strut tower brace / Stop Tech Rotors / BBK Shorty Headers / Mopar Scat Pack Stage 3 Ported Heads / 392 Cam / Manley Push Rods / Mopar Oil Cooler / Custom Tune Sound: Audio Control LC7i LOC, Alpine 500MRXV60 Amp, Focal 165A1/CA1 speakers, 8" Kenwood Excelon + 10" Infinity Reference subs in custom cabs
RT_Kujo is online now  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 05-31-2019, 10:05 AM
Member
 
wjv007's Avatar
 
Join Date: Mar 2016
Location: Toccoa GA
Posts: 97
Thanks: 11
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by RT_Kujo View Post
About 1/2 mile from home I smelled coolant. After some trouble shooting I confirmed that the water pump failed (45,000 miles). I am considering replacement pumps and would appreciate some input. The standard Mopar 68346915AA says that it is for "without oil cooler." I added an oil cooler 6,000 miles ago as part of my build. Could this have caused the pump to fail? Regardless, anyone know if the SRT water pump (for with an oil cooler) will fit my RT, and if it is the right water pump to get? what's the difference?

I could also go aftermarket at the local O'Reilly's. There are (2) Murray water pumps that will fit. One has a plastic impeller, and one has a metal impeller (but is "from 3/4/2013" - my car was manufactured in 2012). Not sure why there are different part for the same model year but with different build dates. Anyone have any thoughts on this?
I have a 2017 scatpack 15,000 miles just had to replace the water pump after it was replaced I notied shavings in my engine coolant reservoir did you see any in yours?
wjv007 is offline  
post #3 of 12 (permalink) Old 05-31-2019, 10:43 AM
Senior Member
 
Frank Julian's Avatar
 
Join Date: Jun 2015
Location: Ohio
Posts: 4,151
Thanks: 775
Thanked 824 Times in 626 Posts
Feedback Score: 0 reviews
My 2015 R/T with less than 12k smells like coolant from time to time. I am hoping prices come down on electric water pumps for our motors. Right now they are about $640. I'll just have to figure out a new way to run the belt.

https://www.jegs.com/i/Meziere/680/WP314S/10002/-1
Frank Julian is online now  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 06-01-2019, 09:58 PM Thread Starter
Senior Member
 
RT_Kujo's Avatar
 
Join Date: Jun 2013
Location: Portland, OR
Posts: 167
Thanks: 12
Thanked 19 Times in 18 Posts
Feedback Score: 0 reviews
(Thread Starter)
Quote:
Originally Posted by wjv007 View Post
I have a 2017 scatpack 15,000 miles just had to replace the water pump after it was replaced I notied shavings in my engine coolant reservoir did you see any in yours?


No I didn’t notice any metal in the tank. All in all I think I was lucky because I was only 1/2 mile from home when it gave out. In a couple days time I would have been on a road trip a couple hours south to look at a college with my son. That would have sucked.

When I pulled it off, the bearings were completely shot. The pulley wobbled around. It wasn’t too bad. I had the pump off in a couple hours.


Sent from my iPhone using Tapatalk
RT_Kujo is online now  
post #5 of 12 (permalink) Old 06-02-2019, 07:38 AM
Senior Member
 
Join Date: Jan 2015
Posts: 1,063
Thanks: 0
Thanked 248 Times in 204 Posts
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by Frank Julian View Post
My 2015 R/T with less than 12k smells like coolant from time to time. I am hoping prices come down on electric water pumps for our motors. Right now they are about $640. I'll just have to figure out a new way to run the belt.

https://www.jegs.com/i/Meziere/680/WP314S/10002/-1

If you smell coolant there's a leak. A cooling system with a leak can't hold pressure which means hot coolant can flash to steam which form pockets which block coolant flow to the hot areas. Localized overheating can occur which can cause a head gasket failure or worse.


You should locate the source of the leak and address it. If it is a water pump replace it now rather than wait for an electric water pump solution. Electric water pumps will bring with them their own issues. The belt driven pump is the best solution and I would stick with the factory water pump.
Rockster is online now  
The Following User Says Thank You to Rockster For This Useful Post:
Frank Julian (06-02-2019)
post #6 of 12 (permalink) Old 06-02-2019, 09:28 AM
Senior Member
 
Join Date: Jan 2014
Location: Sugar Land, TX
Posts: 482
Thanks: 1
Thanked 75 Times in 57 Posts
Feedback Score: 0 reviews
I have a 2014 RT Shaker....5.7L...92,000 miles....Im on my 3rd Water Pump....can't remember exact mileage they went out...luckily, all covered uder the 100,000 mile drive train warranty...Obviously a bad Water Pump Design....I think many, many WP's on 5.7's have went out..common issue..

2014 RT Shaker #196 - Header Orange....Corsa Extreme, CQuartz Finest, Huper Optik Ceramic Window Tint
2010 RT Classic - Hemi Orange
daly double is offline  
post #7 of 12 (permalink) Old 06-02-2019, 11:45 AM
Super Moderator
 
Hal H's Avatar
 
Join Date: Aug 2008
Location: Lowell NC
Posts: 14,378
Thanks: 22
Thanked 3,355 Times in 2,569 Posts
Garage
Feedback Score: 0 reviews
the serpentine belt tensioners, IMO, run a very high rate - I wonder if that's contributing to the bearing wear / failures.

My '01 Benz (137K) has a similar tensioner setup, very high level - no issues with the original water pump.
-this car lived in the Bay Area for the first 50K of its life...so it spent a lot of time idling in traffic vs. steady state driving on the highway

2016 392 Hemi Scat Pack Shaker 23Y pkg (M6) ordered 8/28/15, born 10/23/15, home 11/20/15
Torred / Black/ Ruby Red leather
2009 R/T 27J pkg (M6) ordered 7/17/08, born 10/23/08, home 11/13/08
Hemi Orange / Dark Slate/Light Slate Gray leather
-Sold 9/1/15
Hal H is offline  
post #8 of 12 (permalink) Old 06-02-2019, 03:54 PM
Senior Member
 
Join Date: Jan 2014
Location: Sugar Land, TX
Posts: 482
Thanks: 1
Thanked 75 Times in 57 Posts
Feedback Score: 0 reviews
The first time the pump went out, local mechanic originally diagnosed as a bad tensioner pulley...so he replaced it...he then called and said the WP was also shot...got that replaced at dealer..15,000 -20,000 miles later...water pump went out again...and dealer once again replaced...never smelt coolant..just a real bad grinding noise...both times...now out of warranty..so hate to see how much they will charge me...
daly double is offline  
post #9 of 12 (permalink) Old 06-02-2019, 04:46 PM
Senior Member
 
Tshane72's Avatar
 
Join Date: Jun 2013
Posts: 1,931
Thanks: 143
Thanked 278 Times in 254 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by daly double View Post
The first time the pump went out, local mechanic originally diagnosed as a bad tensioner pulley...so he replaced it...he then called and said the WP was also shot...got that replaced at dealer..15,000 -20,000 miles later...water pump went out again...and dealer once again replaced...never smelt coolant..just a real bad grinding noise...both times...now out of warranty..so hate to see how much they will charge me...

What route did you end up going? How much did it cost? My car is out of warranty now also but so far no problems with my water pump...5.7L here too...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Living my life....one quarter mile at a time
Tshane72 is offline  
post #10 of 12 (permalink) Old 06-04-2019, 10:45 AM
Senior Member
 
Join Date: Jan 2014
Location: Sugar Land, TX
Posts: 482
Thanks: 1
Thanked 75 Times in 57 Posts
Feedback Score: 0 reviews
Water pump isn’t out...just talking about previous times..
daly double is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Maintenance Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
392 water pump replacement - sealant required? CF392 General Challenger Discussion 1 05-31-2018 04:19 PM
Billet Water Neck 05+ HEMI 5.7, 6.1, 392 Speedlogix Speedlogix 41 01-30-2018 08:40 AM
Everything you need to know about Water/Methanol Injection! SRT8U Speedlogix 27 10-04-2016 11:29 PM
performance pullys or electric water pump hemi2010rt General Challenger Discussion 1 06-16-2014 04:41 PM
MOPAR CAI caused water pump to fail??? Mach2 Performance Modifications 14 06-02-2014 04:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome