IAT sensor - Page 2 - Dodge Challenger Forum: Challenger & SRT8 Forums
General Challenger Discussion This section contains general discussion about the Dodge Challenger. If it does not fit into a more specific area, it probably belongs in here. (Dodge Challenger General Discussion)

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 19 (permalink) Old 05-07-2019, 09:07 AM Thread Starter
Member
 
cubanogar's Avatar
 
Join Date: Mar 2019
Posts: 54
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
(Thread Starter)
Iat temp at cold start was at ambient temp.
cubanogar is offline  
Sponsored Links
Advertisement
 
post #12 of 19 (permalink) Old 05-07-2019, 09:11 AM
Senior Member
 
ChallyTatum's Avatar
 
Join Date: Dec 2016
Location: The state where 4 out of 7 former Governors went to jail
Posts: 4,043
Thanks: 380
Thanked 891 Times in 747 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by cubanogar View Post
Iat temp at cold start was at ambient temp.
So you were seeing 160-175F while driving?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2015 Challenger RT+ (non-STP)
8lb Magnuson w/ Innovate PSB-1 wideband/boost/shift light gauge
Corsa extreme (2.5")
4" Aluminum one-piece driveshaft
Hellcat bottom airbox
Stainless Works LT headers (2" primaries)
Barton shifter assembly w/ Lou's short shaft and Speed Dawg knob
Comp Cam 7929 & 7748 push rods (gives slightly more lifter preload)
A2speed aluminum coil and valve covers (built in catchcan)
ChallyTatum is online now  
post #13 of 19 (permalink) Old 05-07-2019, 09:21 AM Thread Starter
Member
 
cubanogar's Avatar
 
Join Date: Mar 2019
Posts: 54
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
(Thread Starter)
when I got in the car it was 170. and while driving around 150 but I might be jumping to conclusions. I see today
cubanogar is offline  
The Following User Says Thank You to cubanogar For This Useful Post:
ChallyTatum (05-07-2019)
Sponsored Links
Advertisement
 
post #14 of 19 (permalink) Old 05-07-2019, 09:52 AM
Super Moderator
 
Hal H's Avatar
 
Join Date: Aug 2008
Location: Lowell NC
Posts: 14,337
Thanks: 22
Thanked 3,343 Times in 2,558 Posts
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by ChallyTatum View Post
On a NA engine, only way IAT would get close to that hot is if the car sat for a short period (intake heat soaked) of time after running for a while, but the temperature would drop as fresh air charge was coming in. On my SC setup I usually see 30F above ambient...never seen it that hot though.

I thought the pre-2015 models had the EVIC screens.

Dodge Challenger Hidden EVIC Screens and Meanings | West Coast Challengers Car Club

On my 2015 RT, I needed zautomotive's Tazer to enable performance pages on my instrument cluster.
There was no IAT readout in the '14 and earlier EVIC - unless you brought up the engineering screen (required a specific set of buttons to hold down to access it)

- otherwise, you can access IAT with hand-held tuners that will display those PIDs

the regular EVIC screens would have Oil Temp and exterior (ambient) Temp readouts.

The IAT temps will rise quickly sitting idling or in slow traffic - I've seen mine rise to the 140 - 150* F range, once moving, they drop off quickly (I have a 392 Shaker).
-in the '14 and earlier models, the stock airbox design tends to have IATs about 18*F above ambient in motion and get hotter than that otherwise at slower speeds.

The pre '11 "stubby" IAT was prone to holding higher IAT temps - on '09 / '10 5.7s, the stubby IAT can be swapped out for the "long" style that has been in use since. Any '08 - '10 SRT 6.1 required an adapter to utilize the gray color connector to use a long IAT sensor

The 5.7s were sensitive to IAT heat soak and 2nd / 3rd gear (M6) was noticeable for heat soak driving in town from my experience

2016 392 Hemi Scat Pack Shaker 23Y pkg (M6) ordered 8/28/15, born 10/23/15, home 11/20/15
Torred / Black/ Ruby Red leather
2009 R/T 27J pkg (M6) ordered 7/17/08, born 10/23/08, home 11/13/08
Hemi Orange / Dark Slate/Light Slate Gray leather
-Sold 9/1/15
Hal H is offline  
The Following User Says Thank You to Hal H For This Useful Post:
ChallyTatum (05-07-2019)
post #15 of 19 (permalink) Old 05-07-2019, 09:54 AM
Super Moderator
 
Hal H's Avatar
 
Join Date: Aug 2008
Location: Lowell NC
Posts: 14,337
Thanks: 22
Thanked 3,343 Times in 2,558 Posts
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by cubanogar View Post
when I got in the car it was 170. and while driving around 150 but I might be jumping to conclusions. I see today
are you certain this wasn't Transmission Oil Temp (A8) readout?
Hal H is offline  
post #16 of 19 (permalink) Old 05-07-2019, 10:03 AM Thread Starter
Member
 
cubanogar's Avatar
 
Join Date: Mar 2019
Posts: 54
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
(Thread Starter)
I'll post a video shortly.
cubanogar is offline  
post #17 of 19 (permalink) Old 05-07-2019, 10:25 AM
Senior Member
 
ChallyTatum's Avatar
 
Join Date: Dec 2016
Location: The state where 4 out of 7 former Governors went to jail
Posts: 4,043
Thanks: 380
Thanked 891 Times in 747 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Hal H View Post
There was no IAT readout in the '14 and earlier EVIC - unless you brought up the engineering screen (required a specific set of buttons to hold down to access it)
According to the link I posted it does not appear IAT is available even after entering the hidden evic.
ChallyTatum is online now  
post #18 of 19 (permalink) Old 05-07-2019, 10:26 AM Thread Starter
Member
 
cubanogar's Avatar
 
Join Date: Mar 2019
Posts: 54
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
(Thread Starter)
my kenwood shows iat, like i said I'll post a video shortly after work
cubanogar is offline  
post #19 of 19 (permalink) Old 05-07-2019, 10:31 AM
Senior Member
 
ChallyTatum's Avatar
 
Join Date: Dec 2016
Location: The state where 4 out of 7 former Governors went to jail
Posts: 4,043
Thanks: 380
Thanked 891 Times in 747 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by cubanogar View Post
my kenwood shows iat, like i said I'll post a video shortly after work
Yup understood, just trying to determine if the pre-2015 models did have IAT readout available? I see other parameters but not IAT which would be unusual not to include.
ChallyTatum is online now  
Sponsored Links
Advertisement
 
Reply

  Dodge Challenger Forum: Challenger & SRT8 Forums > General, Performance, and Technical > General Challenger Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Challenger Forum: Challenger & SRT8 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No More Excuses for Not Datalogging Nuke Tuning/Data 27 04-06-2018 08:15 AM
Hemi long stem vs stock 3.6 IAT sensor bench testing ddeennis Dodge Challenger SE/SXT Specific 6 10-16-2017 06:27 PM
Help with IAT Sensor RockanRoll Dodge Challenger SE/SXT Specific 2 01-17-2017 03:57 PM
Mystery Grey IAT Sensor Connector - SOLVED! rayzazoo Articles - Engine, Other 130 10-11-2016 02:37 AM
P0016, cruise control not working, stalling under wot, terrible fuel economy Hamtaro Challenger Issues & Problems 11 12-20-2014 12:54 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome