Dodge Challenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited by Moderator)
Have been fixing my 09 R/T that has blown airbags. Dash destroyed of course so I found a donor car and removed the dash from both. Swapped the donor car airbags and complete dash pad. Used my same dash frame and wiring harness. Due to work, weather and working outside and waiting on extra hands for carrying the dash, the car has sat for over a month with the battery unhooked. I've got the dash re-installed into my car. Everything is plugged back in and I've gone back over the plugs to verify all are plugged up. It's had the airbag module completely reset (myairbags.com) and the seatbelt rebuilt. I put the battery on a charger and it's sitting pretty at 14 volts, hooked the cables up to it and immediately the tail lights come on. It's late evening so there's shade on the car so I assumed automatic running lights BUT the headlamps were not on. No interior lights on. I turned the headlights on and nothing. Put the key fob in the ignition and turned it to accessory, nothing. Headlights will come on with the key turned on though. Pressed the clutch and tried to start, nothing. No dash lights, no door chimes, no anything. The only thing that is not currently hooked up is the radio and the ac control knobs. left that out b/c I want to buy a new stereo to put in it thanks to some dipstick losing the radio plug.

Is there something that has to be done after replacing the dash to reset the car so it will start? Anyone else had a similar issue? I just was not expecting there to be anything more than just re-plugging all the plugs and firing it up.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
20,115 Posts
Chllngrswpr may be able to advise when he sees this

A Guy
 
  • Like
Reactions: BurninRubber

·
Registered
2018 Scat Pack SHAKER in Plum Crazy
Joined
·
2,510 Posts
Brake light switch correctly connected?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Brake light switch correctly connected?
yes, brake light switch is correctly connected.

Wondering if it could be the WIN module ....

Anyone else have any suggestions ? I cleaned the WIN module with brake cleaner today and tried again, still same results. Guess I'll try to test the power going to the WIN tomorrow and make sure it's got sufficient power and ground.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
installed new dash, now nothing works. Can't get any dash lights to come on and nothing electronic works.

Battery was disconnected for 6 weeks, it's now fully charged and as soon as i connect the cable to the battery the tail lights come on. They stay on. Nothing else in the car comes on, headlights won't turn on. If i put the key into the WIN and turn to accessory, at that point i can cut headlights on ... but again absolutely nothing else electrical on the car works. No windows, no horn, no lights

Does anybody have any suggestions ? Been fighting this for two weeks so any help is appreciated
 

·
Registered
2015 RT 5.7 M6
Joined
·
8,762 Posts
All I can say is when I accidentally shorted the can bus (was sniffing the can bus for a member and tapped into the cluster) there was zero electronic activity...I mean nothing, no door locks, no lights...nada. Once I found the problem everything came back on-line.

I would double check your connections making sure none of the wires were pinched...especially the bus.

You can use this link for pinouts.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
All I can say is when I accidentally shorted the can bus (was sniffing the can bus for a member and tapped into the cluster) there was zero electronic activity...I mean nothing, no door locks, no lights...nada. Once I found the problem everything came back on-line.

I would double check your connections making sure none of the wires were pinched...especially the bus.

You can use this link for pinouts.

Thanks ! I'll take a look again tomorrow night. Hopefully I can get this thing back online !!
 
1 - 7 of 7 Posts
Top