Dodge Challenger Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
That seems slow for a magnacharged R/T. I do have 18" wheels with street tires and a 3.06 rear with the autostick. Online calculaters put my flywheel HP at around 430 at my weight and speed. Something isn;t right here.

Decent R/T and 60 ft, just put it at 1500 RPM and eased into the throttle, let it shift at the redline. I figure I can shift before the power band begins tapering off and maybe pick up a little time, but it just seems too damn slow.

I did go against a SRT8 w/Vortech, and he was running mid-12s, if that means anything.
 

·
Registered
Joined
·
3,733 Posts
Well my bone stock Mopar 10 R/T auto just did a best of 13.20 @ 105.8 with a 1.95 60ft. There is more in it though. It does seem a bit off. The MPH should be in the teens at least.
 

·
Registered
Joined
·
864 Posts
That does sound not so good, how was traction? Where at in Ga? What was your 60' time?
 

·
Registered
Joined
·
89 Posts
Discussion Starter #4
I thought traction was good. It was my first time out and I dropped pressure on my tires to about 23 lb and averaged about a 2.2 60 foot. I ran 4 times. On the fourth time, I ramped the tach up to about 1700 at launch and the tires barked once but there was no spinning. Ran at Atlanta Dragway in Commerce, temp maybe high 40s to low 50s.

I also ran against a stock R/T with a manual transmission. His first time out, and he ran just over 14, which I thought was pretty doggone good for a first ever run.

It was my first time out, too. I ran 13.4 the first time but was consistent around 13.1 the next 3 runs, after getting the timing down. All four runs ended at 108 MPH.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #5
Well my bone stock Mopar 10 R/T auto just did a best of 13.20 @ 105.8 with a 1.95 60ft. There is more in it though. It does seem a bit off. The MPH should be in the teens at least.
Your 60' is a bit better than mine, maybe 3 10ths or so. Auto or stick? If auto, shift strategy? Rear axle ratio?
 
Joined
·
5,134 Posts
Man that does seem low. With a 1.92 60' time I ran 12.20 on my 6 psi Maggie.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #7
I wonder how much the 3.06 rear costs me?

I've also had issues (maybe issues) in that whenever I am cruising the highway at a level tach I can hear/feel what seems to be a pressure build up, that comes with a droning sound for about 3 seconds, then there's a sudden release and the tach drops about 200 rpm, then slowly builds back up. If I deccelerate slightly when the drone starts it goes away. Some guys tried to explain how to troubleshoot but my mechanical aptitude stops at changing flats.

From my best timesheet:

R/T .216
60' 2.129
1/4 13.094
MPH 108.76
 
Joined
·
5,134 Posts
Post some good pics of your under-hood connections from every angle around the blower. Also, learn how to datalog with your predator, then come back and we can help you diagnose.
 
Joined
·
5,134 Posts
FWIW, launching harder (much harder) with a 1.9 60' time you will be in the mid-to-high 12s easily. If you're running the stock tires and not spinning, you're not launching hard enough and it's costing you big time.
 

·
Registered
Joined
·
287 Posts
What tune are you running?
Your signature just says "Predator Tune".
Is it the MagnaCharger tune?

Brad
 

·
Registered
Joined
·
3,733 Posts
What tune are you running?
Your signature just says "Predator Tune".
Is it the MagnaCharger tune?

Brad
That did catch my eye at first, but if he was running just a regular Predator canned tune I dont think it would even start let alone run.
 

·
Registered
Joined
·
33 Posts
Try running with traction control completely off, I think you are holding the car back by running with traction control on. You will be in the 12's for sure.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #14
Try running with traction control completely off, I think you are holding the car back by running with traction control on. You will be in the 12's for sure.
I think I'll try that. I turned it on become someone here recommended it. You ran 14.06 first time out with yours off and pretty much stock, which is damn good. Did you get under 14 yet?

To B Kirk: My predator is tuned for magnacharger

BigBear: not sure where reynolds is. I am in Buford. Will mapquest it later.

Toofart: Will post us some pics. I hooked up predator yesterday and had no idea what I was doing, but was pretty sure I needed to back the hell out before I programmed a 1972 Pinto sequence.
 

·
Registered
Joined
·
33 Posts
My next two runs after that were 13.8's. I kept bogging on the launch a little.

Glad you posted because I had forgotten to ask you what supercharger you had installed.
 

·
Registered
2009 Challenger R/T
Joined
·
2,991 Posts
Yeah try with traction control completely off. I would never have ESP on at the track(never have it on period lol), especially with a supercharged application. I'm betting that is holding you back a good bit
 

·
Registered
Joined
·
254 Posts
Don't feel bad. My first time out at the track with your same setup except I'm a 6spd my best run was a 13.6 @ 109. It was 100+ degrees outside. Now with drag radials I ran a 12.6 @ 108. I'm going to track again today so hopefully I'll be able to hit low 12's.
 

·
Registered
Joined
·
33 Posts
Here is the video of our run.

 

·
Registered
Joined
·
89 Posts
Discussion Starter #19
That's awesome. Hury up and get yours supercharged so we can take out all the ricers. Buy a pulley and run 12 pounds of boost so I can see if its safe to push my boost limit upwards. I can give you a ride home and help pick up the piston rings on the track.
 

·
Registered
Joined
·
33 Posts
Hahaha I hear you. I am hoping to get it supercharged sometime before next spring.
 
1 - 20 of 20 Posts
Top