Dodge Challenger Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
After getting cmr tune, when at wot in first gear (manual mode and auto mode) when hitting rev limiter - i assume, the trans makes a clunk then goes into limp mode, and check engine light comes on with no codes setting. Then I have no drive or reverse function unless I power cycle the car. I havent found a solid answer, but it sounds that by raising the rev limiter using the predator by 200-300 rpms this may solve my problem.

Anyone have any insight or experience with this ???
 

·
Registered
Joined
·
528 Posts
I've hit the rev limiter a bunch of times and it never went into limp mode, but I do have a 6-speed.

Did you beef up your valve train when you rebuilt your motor? If not, I would not raise the rev limiter.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #3
raised rev limit +250 same problem
lowered rev limit -250 same problem
diabled esp same problem
did key trick while driving to diable everything same problem

anyone have any ideas ??
 

·
Super Moderator
09 RT Challenger auto
Joined
·
3,467 Posts
Well, I think its your cmr tune,, in conjunction with pcm and tcm there is a tq manipulation and speed sensor settings. Tuners spend a lot of time there I was told. I have an 07 tcm with gear hold in my 09 RT. When I was having my tune worked on, we ran my car up in these setting untill it also went to limp mode right at the rev limit. I made a couple more pulls and the tuner adjusted it with the CMR software until it didnt go to limp mode, having maximizing tq settings. Food for thought.
FlatTop
 

·
Registered
Joined
·
68 Posts
Discussion Starter #9

·
Registered
Joined
·
3,881 Posts
The limp mode is caused by hitting the rev limiter before it can shift gears. Raise the rev limiter up so that there is a larger gap between the shift point and the rev limiter which will minimize the issue.

BTW, how much power did it make and at what boost level?
 

·
Registered
Joined
·
68 Posts
Discussion Starter #12
The limp mode is caused by hitting the rev limiter before it can shift gears. Raise the rev limiter up so that there is a larger gap between the shift point and the rev limiter which will minimize the issue.

raised the rev limited by 600 (max on predator) and problem still happened


BTW, how much power did it make and at what boost level?
476 hp 480 torque (to clarify, you do know that it is your short block in there ?)
 

·
Registered
Joined
·
68 Posts
Discussion Starter #14

·
Registered
Joined
·
36 Posts
Well like Andy has said.... with all that new found power come's the reality.... with STREET tires you just CANNOT stomp the pedal... cause all your going to do is embarrass yourself... and continue to hit limp mode. You can adjust rev limiter all you want...only can adjust it so far... then you just have to learn....

Welcome to power HE double Heck !
 

·
Registered
Joined
·
68 Posts
Discussion Starter #16
Its something I can deal with, but the car belongs to pops. Really don't want him hitting limp mode if he get excited at a stop light on a busy street. But am thinking there may not be a solution.
 

·
Super Moderator
09 RT Challenger auto
Joined
·
3,467 Posts
As I said, its in the cmr software you have to make the changes, your preditor or trinity will do Nothing. Mine done the exactely as yours is during the forum wars I went to and I had just installed a sc had a stock vortech tune, CMR software was on site with RDP Dyno Steve we used the parking lot and street for a dyno, he tweeked these problems away. Just sayin,,,, I had this same problem. And thats the fix.
FlatTop
 

·
Banned
Joined
·
7,566 Posts
As I said, its in the cmr software you have to make the changes, your preditor or trinity will do Nothing. Mine done the exactely as yours is during the forum wars I went to and I had just installed a sc had a stock vortech tune, CMR software was on site with RDP Dyno Steve we used the parking lot and street for a dyno, he tweeked these problems away. Just sayin,,,, I had this same problem. And thats the fix.
FlatTop
There ya go Chad. Sounds like these guys are telling ya what the fix is.

Who tuned the car? Having this issue makes me wonder about the tuning as a whole.

I think 10psi has more than 476HP in it, especially with a motor from Andy.
 

·
Registered
Joined
·
3,881 Posts
Its just a forged 5.7 but with it being a centrifugal blower, tq should not be equal to hp. Tells me that timing is really lazy up top or air/fuel is fat. Centrifugals almost always have 40-50 more hp than tq.

Also, we dont know what dyno this was on. 475rwhp on one dyno is crappy and on another its huge. All depends on where the baseline is.
 

·
Banned
Joined
·
7,566 Posts
Its just a forged 5.7 but with it being a centrifugal blower, tq should not be equal to hp. Tells me that timing is really lazy up top or air/fuel is fat. Centrifugals almost always have 40-50 more hp than tq.

Also, we dont know what dyno this was on. 475rwhp on one dyno is crappy and on another its huge. All depends on where the baseline is.
True on the dyno. I meant to ask about that....I always assume Dynojet since that's kinda the "standard" as it were.
 
1 - 20 of 27 Posts
Top