Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I just swap 5.7 hemi engine on my 2009 challenger rt with a newer engine off a 2014 charger and now won't start, it crank but won't start, fuel pressure and spark is okay, I heard a comments that I need to swap the cam phaser and crank sprocket because the computer is not reading the signal on the right time, is there any diference on the cam phase in between 2009 and 2014 any help i would appreciated please.
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
8,579 Posts
The 2014 has VVT, does the 2009? I cannot remember the year they started using VVT in the Hemi...

Did the 2009 engine have an EGR valve & tube? If it did, it was pre-VVT, and I imagine making the 2014 engine (with VVT) work with a non-VVT car’s PCM would be very difficult. It will be looking for sensors and data input that aren’t necessarily there, or vice-versa...
 

·
Registered
Joined
·
2,318 Posts
VVT and no EGR started in 2009. Both engines in question should have it.

Just throwing a guess here but you might have the wrong reluctor gear. I thought I had heard somewhere that they changed it around 2013. If the tooth count or pattern is wrong on the gear, the crank sensor sends the wrong signal. The PCM has no idea where the pistons are on what strokes and can't time fuel or spark properly.
 
1 - 3 of 3 Posts
Top