Dodge Challenger Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Alright so this all stared about 2 weeks ago,I was driving it and then the abs and trc control popped on then the the gages started going on and off so I pulled into a gas station and it just die. Had a buddy bring a different battery to get her home and then the same thing happened on the way home but it made it. So I figured it had to be the alternator. Got a reman one and put it in and charged up the battery. Decided to let her idle a bit before driving again and the same thing happened. Re checked the connection on the alt and gave it another try and same thing. So now I'm thinking ita either the voltage regulator which is conveniently in the pcm (dumb) or possibly the reman alt is also bad. Tonight I'm going to take both the old and reman all to the parts store and see if they both charge or not. Figured if the old and new one both charge right it possibly is the pcm or ???? and if they both fail its probably the alts. What do you guys think it could be? Thanks!
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
27,425 Posts
Welcome to Challengertalk ;) What does the EVIC say the voltage is when running? Any voltage tests done? Confirmed all grounds and alternator lead connections?

A Guy
 

·
Registered
Joined
·
2,463 Posts
This is where some actual diagnosis and understanding how the charging system works would be your friend. Throwing parts at something is not the right answer. First of all, what trouble codes do you have? Is the battery light on in the dash? What duty cycle is the PCM trying to get out of the alternator? What voltage is it charging at, and what is the desired charging voltage? (probably need a scan tool for that). We'll need some more/better info to help you find your answer.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
For anyone who cares it was the voltage regulator. Was able to purchase a external one and it work perfectly. See picture of what I got
1002364
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
27,425 Posts
Interesting...as you know the regulator is in the PCM. I wonder what the PCM not knowing what the regulator is doing will affect? Good you got it working, hopefully no problems

A Guy
 

·
Premium Member
Joined
·
3,025 Posts
For anyone who cares it was the voltage regulator. Was able to purchase a external one and it work perfectly. See picture of what I got View attachment 1002364
That's amazing that they can make an old school regulator work in your car. Where did you mount it?
 
1 - 7 of 7 Posts
Top