Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter · #1 ·
So today its hot as hell and my a/c was on full blast. While driving the fan speed cut down and stopped after another 30 seconds. I did smell more electrical burning up. The fan won't work on any setting. In past warranty so I want to fix this myself. I figured either the fan,fan switch or the fan resistor is bad. I pulled the dash and the climate control switch doesn't smell burnt out. Im going to try to power up the fan and look or damage. Any tips?
 

·
Registered
Joined
·
10,166 Posts
Sounds like the AC/Heat control module. A handful of failures reported with the same issue/problem.

Some heat up too much by the connector area on the back of the module, and it eventually distorts/melts the connector on the board..............thus the smell and sometimes a little smoke.

Mine failed under warranty, and got it replaced. Thankfully the wiring harness itself wasn't damaged, and the new one had been fine so far.

Best of luck.
 

·
Registered
Joined
·
193 Posts
Discussion Starter · #4 ·
Yup to was the climate control module. Im surprised since it doesn't smell burnt at all. I found one on ebay so I should be up and rolling in a few days. Lucky my buddy has a challenger as well I swapped the part.
 

·
Premium Member
Joined
·
10,053 Posts
Nice to know it's not more involved than that.
 
1 - 5 of 5 Posts
Top