Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Just picked up a 10 se. On the ac controls, half the blower speed control doesn't work unless I tweek the knob. I bought a used switch and after the blinking calibration everything works accordingly. But it does the blinking calibration Everytime I start the car up.

From what I'm reading, because it was a used switch the vins don't match. If I bought a new switch will it work from the start since it doesn't have vin in it or do I need to have it programmed at the dealer?

Thanks!
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,439 Posts
Just picked up a 10 se. On the ac controls, half the blower speed control doesn't work unless I tweek the knob. I bought a used switch and after the blinking calibration everything works accordingly. But it does the blinking calibration Everytime I start the car up.

From what I'm reading, because it was a used switch the vins don't match. If I bought a new switch will it work from the start since it doesn't have vin in it or do I need to have it programmed at the dealer?

Thanks!
I haven’t heard of the VIN issue you reference with HVAC controls. It could just be the system needs to be reset. I’ve got a post on here somewhere from way back when I had my 2011 SE that I detailed how I resolved my blinking HVAC control problem. In a nutshell you just set the knobs all to their default positions and unhook the battery and when you hook it back up, it should not be an issue anymore.

I may be misremembering my own post, best to search for it and make sure. Do an advanced search for posts by Nuke with blinking as the keyword. That should find it.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
26,743 Posts
I just search for owe me a beer Nuke, and there it is


A Guy
 
  • Like
Reactions: Nuke

·
Registered
Joined
·
34 Posts
Discussion Starter · #4 ·
The stock controls don't blink, just the used one. I'll try it with the used controls tomorrow... Fingers crossed
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
9,439 Posts
That may be a good thing. The blinking usually means a reset can resolve it. Try it out and see...
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #6 ·
No luck with the fuses. Spoke to a tech, the "new" control needs to be programmed and calibrated to the car -$200!!! I took the control apart and saw where the terminals weren't making contact and were pretty grody. Cleaned, added some dielectric grease and I'm back in business. Thanks for the tips
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
26,743 Posts
"Tech" would have done what Nuke said...and no beer for Nuke! Glad you got it figured out

A Guy
 
1 - 7 of 7 Posts
Top