Dodge Challenger Forum banner

2010 se ac controls

827 6
Just picked up a 10 se. On the ac controls, half the blower speed control doesn't work unless I tweek the knob. I bought a used switch and after the blinking calibration everything works accordingly. But it does the blinking calibration Everytime I start the car up.

From what I'm reading, because it was a used switch the vins don't match. If I bought a new switch will it work from the start since it doesn't have vin in it or do I need to have it programmed at the dealer?

Thanks!
1 - 2 of 2 Posts

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
12,986 Posts
Just picked up a 10 se. On the ac controls, half the blower speed control doesn't work unless I tweek the knob. I bought a used switch and after the blinking calibration everything works accordingly. But it does the blinking calibration Everytime I start the car up.

From what I'm reading, because it was a used switch the vins don't match. If I bought a new switch will it work from the start since it doesn't have vin in it or do I need to have it programmed at the dealer?

Thanks!
I haven’t heard of the VIN issue you reference with HVAC controls. It could just be the system needs to be reset. I’ve got a post on here somewhere from way back when I had my 2011 SE that I detailed how I resolved my blinking HVAC control problem. In a nutshell you just set the knobs all to their default positions and unhook the battery and when you hook it back up, it should not be an issue anymore.

I may be misremembering my own post, best to search for it and make sure. Do an advanced search for posts by Nuke with blinking as the keyword. That should find it.
 

·
Premium Member
The Bacon Hauler (‘12 Cop Charger)
Joined
·
12,986 Posts
That may be a good thing. The blinking usually means a reset can resolve it. Try it out and see...
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top