Dodge Challenger Forum banner

2010 SRT

1194 6
2010 srt changed battery now stuff not working on my car battery was totally dead but shouldn’t matter
1 - 7 of 7 Posts

·
Registered
2015 RT 5.7 M6
Joined
·
12,791 Posts
Welcom to the forum.

This is a very common problem on the pre-2015 that I have seen on this forum. Basically what happens is either the battery dies, was disconnected and/or replaced. The result is either the car won't start, or starts but the keyfobs don't work. Problem is, I have seen lots of posts saying "my battery died, I replaced but car won't run" and they never seem to come back to state what the fix was.

Now on 2010-2011 models there was a recall on the WIN module, which could be the problem if the car does not start. However, there was a member on the HP tuner forum that recently disconnected his battery on his 2009 and the car would not turn over. Turns out it was a loose connection.


Now if the battery was completely discharged it is a good chance the battery will need to be replaced as one or more of the cells could have gone bad.

That said, what are the symptons...engine won't crank, engine cranks but won't start, engine cranks and starts but keyfobs don't work?
 

·
Registered
2015 RT 5.7 M6
Joined
·
12,791 Posts
Now if have a start-up issue and want to further diagnose you can go to the online chiltons manual

enter your year, make, model and then navigate to the starting system. -- Top /Engine Electrical/Starting System/Diagnosis & Testing/Standard Starting System
 

·
Registered
2016 R/T Scat Pack
Joined
·
1,743 Posts
Guess I was extra lucky. My 2010 RT battery lasted 9 years, 2 months. It grunted one morning but started so replaced it that afternoon. ZERO issues....
 

·
Registered
2016 R/T Scat Pack
Joined
·
1,743 Posts
LOL. Traded for a low mile 2016 SP end of March so the 2010 is someone else's problem now haha.
 
  • Like
Reactions: ChallyTatum

·
Super Moderator
Joined
·
18,723 Posts
Guess I was extra lucky. My 2010 RT battery lasted 9 years, 2 months. It grunted one morning but started so replaced it that afternoon. ZERO issues....
Mine died after 7 years. It was embarassing because it occurred while my 2009 SRT was undergoing NJ state motor vehicle inspection. It had to be pushed out of the garage! I replaced it with a Bosch AGM battery.

So a word to the wise, replace your old battery before it strands you someplace.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top