Dodge Challenger Forum banner
1 - 20 of 45 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
is it normal to be getting 6sec on the evic for 0-60??....seems slow to me.I have the 6 speed and i guess i thought it would be faster...i cant even spin my tires...i have to pop the clutch..is this normal????or do i have a lemon????the car is brand new with 500kms on it....thanks
 

·
Registered
Joined
·
139 Posts
Manuals tend to be slower now unless you're really quick. If your car is stock you probably need to cut off the esb to do some burnouts.

Sent from my Milestone X using AutoGuide App
 

·
Registered
Joined
·
139 Posts
Oh yea. To cut esp off completely hold the button down (while you aren't moving) for about 8 or 10 seconds. You should hear a chime.


Sent from my Milestone X using AutoGuide App
 

·
Registered
Joined
·
2,311 Posts
perfectly normal, my 09 srt 6spd ran 6.47 on my first attempt. Over time it slowly improved to 5.02, 6 seconds is normal despite what some people here will tell you.Remember, the car was advertised at 5.5 seconds! I thought something was wrong with my car too, but there isn't. Your times will get better as miles increase. My technique didn't change at all, the car just got faster. I can't spin my tires in any gear at anytime either without dumping the clutch. Don't listen to people here about that either. I can tell you to put a good quality 91 octane fuel in the car however, if someone is selling you 89 at 91 prices( it does happen) your car will be slower. Put some miles on her and it will improve, mine was a dog when it was new. And below 4000rpms, it still is IMO. Makes me want the 392.
 

·
Registered
Joined
·
432 Posts
Normal for a new car and first time trying. My best so far is 5.8 and I've only tried twice. No problem spinning the wheels though in 1st gear, that's one of the reasons my 0-60 sucks, no traction.
 

·
Registered
Joined
·
92 Posts
Normal for a new car and first time trying. My best so far is 5.8 and I've only tried twice. No problem spinning the wheels though in 1st gear, that's one of the reasons my 0-60 sucks, no traction.
I agree, traction sucks on these cars. I can spin first, and bark the tires through fourth gear no problem. First time i tried the 0-60 i got 6.3, getting better now but need a traction upgrade bad.
 

·
Registered
Joined
·
3,380 Posts
thats why in the end i chose a automatic...i did 4.8 on my first try...all i did was floor it...nothing else special...just let the car do what it does....with stick shift it takes skill to be good....

the car spun the tires a bit and a bit more into 2nd, but not too much....ive tried it w/ the traction control 1/2 off, but my times are 5.0 - 5.2 that way....ive only dont the 0-60 thing a few times and know i can improve on the 4.8 w/ practice

6 cylinder Mustangs will kick your ass unless you improve...work on it....dont embarrass your srt brothers by loosing to a 6 banger mustang
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #9 ·
perfectly normal, my 09 srt 6spd ran 6.47 on my first attempt. Over time it slowly improved to 5.02, 6 seconds is normal despite what some people here will tell you.Remember, the car was advertised at 5.5 seconds! I thought something was wrong with my car too, but there isn't. Your times will get better as miles increase. My technique didn't change at all, the car just got faster. I can't spin my tires in any gear at anytime either without dumping the clutch. Don't listen to people here about that either. I can tell you to put a good quality 91 octane fuel in the car however, if someone is selling you 89 at 91 prices( it does happen) your car will be slower. Put some miles on her and it will improve, mine was a dog when it was new. And below 4000rpms, it still is IMO. Makes me want the 392.
That is exactly how i feel. Under 4000rpm its like wheres the other 2 cylinders, but i thought mine was just a p.o.s. i do only have 900kms on it though so i was hopping it would get better with time. I do have a k&n c.a.i., and i just put a flowmaster american thunder exhaust...sounds and looks amazing just was expecting more bag...hopefully time will cure that..THANKS EVERYONE FOR YOUR REPLIES!!!!!
 

·
Registered
Joined
·
59 Posts
same here. 2010 srt auto. slow 0-60 times while new. 4000 miles now and ran 4.8 this weekend. 113 mph in the quarter at 13.3 sec.
 

·
Registered
Joined
·
37 Posts
tried mine this weekend just for fun and low 6s. i am kinda dissapointed too. its an auto but there isnt much in the low rpms. waiting for the INTUNE to finnaly get released then we'll see. until then no racing for me, dont want to be embarassed
 

·
Registered
Joined
·
120 Posts
I have an 09 6speed SRT8. I have tried it a few times now. The car currently has about 16k on it. The first few times I tried it with about 10k on the car I SUCKED. I was getting like 6.5's. If you make any sort of error on the 6speed your time goes to total ****. A few weeks later I tried it again and found a decent sweet spot in the RPM to launch the car without it dogging out "1500-2000" rpm. Came out of the clutch fairly fast and shift second right before redline. You should get a nice "chirp" on second gear shift. That gave me 5.6 with a heat soaked engine. That was the last time really tried it as it's 100deg in texas.

That brings me to my next point. If you are trying this in 90deg weather with a heat soaked engine, your times will be horrible and don't even bother. As soon as it gets cool again I know I will be able to get a 5sec flat run. You have to hit everything just right on the 6speed to get those low numbers you read about. Your car sounds normal to me. Give it a few more tries and get that launch down. Spinning Tires, and dogging off the line will easily add one second to your time. I would have done it about 10 more times but I felt like I was beating the living crap out of my car.
 

·
Banned
Joined
·
368 Posts
My R/T auto is getting better...then again so are my launches. 95 degree day, hot motor same roads over the last 2 months (2100 miles on car) times have gone from 6.3 to now 5.7. ESP 1/2 off put into Auto-Stick and let the computer shift.
 

·
Registered
Joined
·
3,338 Posts
I think your times will improve when you get more practice. not easy to get a good launch. what rpm are you leaving at.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #16 ·
I think your times will improve when you get more practice. not easy to get a good launch. what rpm are you leaving at.
I am leaving at around 2000rpm......i have noticed a huge difference since turning off the esp completely(stabiltrak).....I bought this car for its looks more then anything....i knew it wasnt a rocket when i bought it......but i had no idea the r/t was just as fast...ohwell
 

·
Registered
Joined
·
347 Posts
Last summer I found myself on a nice deserted stretch of straight county highway. Two lanes, older asphalt (smooth surface texture). Temperature: about 70F. No wind. Our premium in this area is 93 octane. My totally bone stock '09 5.7 RT 6-speed has 20" RSAs, a 3.92 axle, every option except the spare tire, and had about 5000 miles on it at the time. After reading all the wheel hop horror stories on this forum, I pushed the ESP button, revved to about 2000 and, on the release, I feathered the clutch slightly. Got just a bit of the hop, and then hammered it. Got a bit more hop going onto second. Into third was smooth. When I checked the time...5.16! What? On the first run? The car is so smooth and quiet that it just does not feel that fast. I was really thrilled with that time, as I'm in my mid 50s now. 30 years ago I was fairly big into auto-crossing, but nothing since..and I've never been a drag racer by any stretch. This lead me to suspect that there might even be a bit more left in it, for someone who actually knew what they were doing. A couple of months later, I found myself back on the same road at the same location (but going the other direction), so I thought "what the hell" and tried it again. The only difference was that the temperature may have been slightly cooler. It was pretty much a repeat of my earlier run, and the time: 5.00! So, it was no fluke. I have to believe that if I'd had F1s on it instead of the RSAs, it would probably have broken into the 4s. Now, if it only had an SRT suspension...maybe it wouldn't drive so much like my brother's 300C...
 

·
Banned
Joined
·
368 Posts
I am leaving at around 2000rpm......i have noticed a huge difference since turning off the esp completely(stabiltrak).....I bought this car for its looks more then anything....i knew it wasnt a rocket when i bought it......but i had no idea the r/t was just as fast...ohwell
Get your technique down, let the motor get a few more km's on it....you'll be fine.
 

·
Registered
Joined
·
978 Posts
thats why in the end i chose a automatic...i did 4.8 on my first try...all i did was floor it...nothing else special...just let the car do what it does....with stick shift it takes skill to be good....

the car spun the tires a bit and a bit more into 2nd, but not too much....ive tried it w/ the traction control 1/2 off, but my times are 5.0 - 5.2 that way....ive only dont the 0-60 thing a few times and know i can improve on the 4.8 w/ practice

6 cylinder Mustangs will kick your ass unless you improve...work on it....dont embarrass your srt brothers by loosing to a 6 banger mustang
:yesnod:

...that's why auto's are for newbz. :browsmiley: :saythat: :banhim:
 

·
Registered
2010 Challenger SRT 6spd detonator yellow
Joined
·
529 Posts
guys you must realize that the 60ft time starts in our cars when the tires start moving.....at the track you have a approx 10" buffer........at the staging light.........also as you get more miles on the 6.1 it wakes up more....wait til you get 400 miles huge difference....do not under estimate the 6spds.......at 1200 miles my freind ran a 12.94 1/4" mile completly stock next to a auto that ran 13.2...... wheel hop is a killer in the 6spds high rpms and feather out the clutch but be careful not to glaze the plate.......have fun.......oh take your car to a road track and experience some different fun you will be amazed how it handles.
 
1 - 20 of 45 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top