Dodge Challenger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 6 speed manual SRT8 and occasionally when i shift from first to second have a hard time getting it into second. tried the shift eliminator and there was no change. anyone else have this problem? what did you do to resolve it? thanks.
 

·
Registered
Joined
·
1,399 Posts
Welcome to the forum Mike.

First off what are some of the symptoms you are experiencing?
Have you now gone back to a stock set up?
Are the gears grinding?
Are the shifts rough?
What RPM are you shifting at? (although this should not influence much)
How are the shifts into other gears?
Can you downshift from 3rd gear smoothly?
Is the clutch's action smooth?

let us know.
 

·
Registered
Joined
·
119 Posts
I have an 09 r/t, manual, skip shift eliminator and have the same issue. Thought maybe I wasn't depressing clutch all the way. Nope. About the only thing that seems to work is to let rpm's fall to almost idle.

Gears don't grind per se but it's just not a smooth shift.
 

·
Registered
Joined
·
119 Posts
My bad. Didn't notice this is your first post, Mike. Welcome to the forum.
 

·
Registered
Joined
·
1,399 Posts
The 6 speeds all seem to "grind" a little when cold when shifting from first to second and then to third when relatively new.
My car now has about 6500 miles and still does it a litte, but once warmed up gets smoother.
A few members with a lot more miles have reported that as time & miles add up things just get better.
Bottom line: Have fun & just get out there and drive.
 

·
Registered
Joined
·
1 Posts
2010 srt8

I have a 6 speed manual SRT8 and occasionally when i shift from first to second have a hard time getting it into second. tried the shift eliminator and there was no change. anyone else have this problem? what did you do to resolve it? thanks.
I have experience the same problem from shifting from 1st to 2nd gear. Plan to ask service dealer about this issue
 

·
Registered
Joined
·
1,413 Posts
I have experience the same problem from shifting from 1st to 2nd gear. Plan to ask service dealer about this issue

Have the Dealer's tech remove the shifter and look into the trans at the 2nd Gear Synchro as this was a common problem on GT500s w/the 6speeds in 2008-10. Dodge uses the same trans.



 

·
Registered
Joined
·
51 Posts
try replacing the fluid, but most likely the sincro will need to be replaced.
Done a few already, and mine has the problem once in a while also, just havent gotton around to it.
 

·
Registered
Joined
·
7 Posts
I have a 6 speed manual SRT8 and occasionally when i shift from first to second have a hard time getting it into second. tried the shift eliminator and there was no change. anyone else have this problem? what did you do to resolve it? thanks.
Its the skip shift, i think its something to do with emission or mpg. i bought a skip shift eliminator from ebay easy to installed, less than 10 min. never had problem again.
 
1 - 11 of 11 Posts
Top