Dodge Challenger Forum banner

1 - 13 of 13 Posts

·
Registered
2011 Challenger RT Classic
Joined
·
228 Posts
I recently talked with a recall representative from FCA about the T36 recall on the 5.7L alternator, and they said that it will affect 2011-2014, RTs, but the recall had yet to be assigned to any specific VIN numbers at that time. Therefore, there is currently no info available as to which specific vehicles may or may not be part of the recall. They said that Info would not be available for probably a few weeks. So the my Dodge Dashboard if anyone uses, will not show any info on this recall yet since it has not been updated yet.







Sent from my iPhone using Tapatalk
 

·
Registered
2011 Challenger RT Classic
Joined
·
228 Posts
I'm confused..... How was yours done in January 2016 if the recall has yet to be assigned to specific VINs (ref: jdhaines32's post)?


I would assume he either has a 3.6L which were recalled for the alternator a year or so ago I believe or he had problems with his Hemi alternator and had to pay to get it fixed or it was still under warranty. If he had to pay there is supposed to be a form to fill out to apply for reimbursement after the new recall go into affect.


Sent from my iPhone using Tapatalk
 

·
Registered
2011 Challenger RT Classic
Joined
·
228 Posts
Just check for my 2011 RT and it now included in the alternator recall. It says that no parts are available yet, so now I guess we wait some more.


Sent from my iPhone using Tapatalk
 

·
Registered
2012 Challenger R/T
Joined
·
129 Posts
I sure did about a month ago my battery indicator light came on as I was driving from work, then the traction indicator light came on. I didn't loose any power so I kept driving.... Just praying I make it home before anything worse happen. Fast forward about a couple of weeks ago it started to do the same thing... I mean the car was acting crazy..... All kinds of indicator light was coming on. My power steering even stopped working. I barely made it home. I called AAA and had it towed to the dealership... Come to find out that when the alternator went out it blew out the PCM as well. I was without a car for a week.... When I got my car back everything was back to normal. The good thing is that I was still under warranty.
 

·
Registered
Joined
·
1 Posts
Just had the alternator fail in my girlfriends 13 R/T, same issues as post above with dead battery symptoms, flashing lights, and warnings all over the dash. I swapped the failed unit out with an OEM Denso unit from a Dodge dealer and put in a new battery. Hopefully they will reimburse us for cost of parts once the remedy is released but everything is back to normal.
 

·
Registered
2012 Challenger R/T
Joined
·
129 Posts
Hey guys and gals I wanted to know if anyone is having or have had problems with there window not wanting to roll up all the way, or if your window will continue to go up and down? My driver side window will go up and down as when I enter my car... It's weird.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,787 Posts
Have you tried to reset? I believe you hold the button down and hold it for several seconds after it's down, the hold it until they are up and hold it a few seconds up. Repeat again and see if that helps

A Guy
 

·
Premium Member
Joined
·
1,642 Posts
Hey guys and gals I wanted to know if anyone is having or have had problems with there window not wanting to roll up all the way, or if your window will continue to go up and down? My driver side window will go up and down as when I enter my car... It's weird.
Hi DJUANP100,
Let us know if you plan to have your dealer look into this. Just send us a private message and we will gladly provide you with additional assistance while your vehicle is at the dealer.
Lydia
Dodge Social Care Specialist
 

·
Registered
2012 Challenger R/T
Joined
·
129 Posts
Have you tried to reset? I believe you hold the button down and hold it for several seconds after it's down, the hold it until they are up and hold it a few seconds up. Repeat again and see if that helps
A Guy
yes I did but that didn't work. I went on YouTube and a few videos help, looks like I need a new regulator.
 
1 - 13 of 13 Posts
Top