Dodge Challenger Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
627 Posts
Discussion Starter #1 (Edited)
Have you been able to access the hidden "Easter egg" screen that displays speed digitally? All the directions I read say to hold the map button for 10sec's. I dont have it on my controls.
 

·
Account Disabled by User
Joined
·
135 Posts
Based on what I have been reading they removed it from the 2011's. I'm really disappointed and hope someone can prove me wrong.
 

·
Registered
Joined
·
105 Posts
If all you're looking for is the digital speedometer display, it can be found through the 430N in two places. When in map view, it's in the lower right hand corner of the map screen. Also, if you tap the speed display it brings up another menu with a large digital speedometer display.

If you're referring to the extended EVIC menu that could be accessed by holding down the compass and down arrow buttons on the steering wheel in <2010 models, people are saying that it has been removed for 2011. I can't find it in mine, but I can't confirm its gone.

I've never heard of the easter egg screen you're referring to.
 

·
Registered
Joined
·
627 Posts
Discussion Starter #4
Can someone please tell me why I chose to buy a 2011? First I find out I can't tune with Diablo and now they took out a pretty cool feature. I wonder what it will take to retro it in. Must do some digging.
 

·
Registered
Joined
·
105 Posts
When you find out how to get the 0-60 timer back on a 2011, let me know. I've been digging, but found nothing yet.
 

·
Registered
Joined
·
627 Posts
Discussion Starter #6
Update

I can't confirm (my car is 20 miles away), but I just spoke to the Engineer here at work that supossedly programed the EVIC controls for the new style steering wheels. He tells me to get the EVIC into engineering mode, you press the "UP" arrow button for 5 seconds and then (within a second) the "Down" arrow. Now, I don't remember (because of those damn rabbit trails I always go on) if the down arrow is to be held for 5 seconds or just release it? Anyone with a 2011 want to try and confirm this?
 

·
Registered
Joined
·
38 Posts
YES!!!! Just tried it in my 2011 R/T Plus and it WORKED!!:werd:
It seems as though you have to do it from the compass/temp screen as thats the only screen where the up down arrows have no function

It was all there, 0-60 timing, digital speedo, G-force and about 5 or 6 other pages of stuff
 

·
Registered
Joined
·
627 Posts
Discussion Starter #9
YES!!!! Just tried it in my 2011 R/T Plus and it WORKED!!:werd:
It seems as though you have to do it from the compass/temp screen as thats the only screen where the up down arrows have no function

It was all there, 0-60 timing, digital speedo, G-force and about 5 or 6 other pages of stuff
sha..weet...how long did you hold down arrow for?
 

·
Registered
Joined
·
38 Posts
LOL i was excited and dont remember but i think I had to press the down arrow for 5 seconds before it went to extended mode.

Now go post this everywhere so you can get the credit you deserve! :thumbsup:
 

·
Account Disabled by User
Joined
·
135 Posts
YES!!!!!!!!!!!!!!
 

·
Registered
Joined
·
255 Posts
Chargerdude,will this work on a 2011 R/T Ram 1500? Same radio,same Evic? I know it is a Truck but I hope it works.
Thanks
Mike
 

·
Registered
Joined
·
37 Posts

·
Registered
Joined
·
83 Posts
It worked for me just fine. Now, where to find a secluded straight and level piece of road in LA...:browsmiley:
 

·
Registered
Joined
·
627 Posts
Discussion Starter #18
This trick will not work on my 2011 Base RT... Any suggestions?
Did you attemp it with car running and EVIC at the temperature screen? Hold "UP" arrow on steering wheel for approx 5 seconds then within a second, the "DOWN" arrow untill alternate screen appears(approx 5 seconds). My car is a base R/T.
 

·
Registered
Joined
·
627 Posts
Discussion Starter #19
Chargerdude,will this work on a 2011 R/T Ram 1500? Same radio,same Evic? I know it is a Truck but I hope it works.
Thanks
Mike
BART...did you attempt it on your RAM? Did it work? Sorry I never answered. I don't own a RAM so I have no Guinea pig to test on.
 

·
Registered
Joined
·
781 Posts
Did you attemp it with car running and EVIC at the temperature screen? Hold "UP" arrow on steering wheel for approx 5 seconds then within a second, the "DOWN" arrow untill alternate screen appears(approx 5 seconds). My car is a base R/T.
I start the car, its on the default screen w/ outside temp, do as instructed and...... NOTHING!

Do you continue to hold "UP" when pressing "DOWN" or do you release UP then press down?
 
1 - 20 of 38 Posts
Top