Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just bought this car the only mods I know are the obvious cat back and cai. First off car ran perfect it had a shake at idle which I thought was normal. Connected new diablosport I tune i3 it said diablosport tune already exists. I went ahead and saved the current tune and installed 91 octane tune car would start and idle for about 10 seconds tried to reinstall the saved tune and same thing. Cel light for rich fuel on banks A&B. Talked to diablosport and updated everything still same thing. They told I would have to get a custom tune. What if it’s had a cam swap anyway to know? Any ideas where to go from this point?
 

·
Premium Member
2018 Scat Pack SHAKER in Plum Crazy
Joined
·
3,729 Posts
Back to whoever you bought it from.
 

·
Registered
Joined
·
2,111 Posts
Sounds like who ever sold you the car had a tune loaded and did not load up the stock tune back to the car before they sold it to you. I would go back to the seller, use his tuner to re-install the stock tune then go form there. The stock file should still be saved in his tune device.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Bought it from a dealer he bought at auction. Got on the Carfax and called the dealership where they were having There services done. They would not give me any information (privacy policy)only what they had done to the car
 
1 - 4 of 4 Posts
Top