Dodge Challenger Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
60 Posts
Discussion Starter #1
Apologies if this has been covered elsewhere. Had my 2012 SXT w/22k miles less than a month, have driven it less than a full tank of gas, two indicators have been nagging me from day one. Both keyfob batteries are low - no surprise there, apparently changing them once a year is a popular recommendation here on the CT forums (big thanks to West Coast Challengers for keyfob battery replacement how-to YouTube videos). Ordered 4 of them on Amazon for around $1/ea. so that will be fixed this week.

Other dinger is the airbag service/warning light that showed up during the brutal cold of Snowmageddon 2014 here in Indiana last week. At first it was intermittent, I figured it was the frigid temps. It's constant now & comes on immediately after starting the car no matter what. Brought it into the local Dodge dealership today, they took a look, service writer says it WAS a factory recall, then Dodge canceled the recall, now it's back again. They had to order a part, assured me car was perfectly safe to drive, will be fixed next week.

Just curious if anyone else has experienced this?

Sent from AutoGuide.com Free App
 

·
Premium Member
2014 100th Annivesary R/T
Joined
·
517 Posts
Had mine replaced

Yeah had the same thing with mine. They replaced the connector and all fixed, have put 4k on it since it was fixed with no further issues.

-Kenny
 

·
Registered
Joined
·
2,304 Posts
No issue on my 2012
 
  • Like
Reactions: Sith R/T

·
Registered
Joined
·
11 Posts
I had the same issue in my 2012. They replaced the passenger seat airbag harness under a recall and it has been fine ever since.
 

·
Registered
Joined
·
202 Posts
My wife's 2011 Dodge Nitro is at the dealership today for the same problem.
I have not had any issues with my Challenger.
 
  • Like
Reactions: Sith R/T

·
Registered
Joined
·
12 Posts
I'm having this same issue right now with my 2013 SXT. I'm at about 31K miles, I believe the warranty ends at 36K so I hope to be able to get my car to the dealer before then and not have any issues. Weird thing is, my light came on during frigged temperatures as well, and it's been on for about a month or so now. It's so annoying.
 

·
Premium Member
Joined
·
1,680 Posts
I'm having this same issue right now with my 2013 SXT. I'm at about 31K miles, I believe the warranty ends at 36K so I hope to be able to get my car to the dealer before then and not have any issues. Weird thing is, my light came on during frigged temperatures as well, and it's been on for about a month or so now. It's so annoying.
arufolo,

Best of luck with the fix. Keep us posted if you make it to the dealer!
 

·
Registered
12' Dodge Challenger
Joined
·
71 Posts
You shouldn't have an issue taking it in. Should only be about an hour, if that, and you'd be squared away.
 
1 - 8 of 8 Posts
Top