Dodge Challenger Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi all,
just wondering if anyone else out here has had an issue with an oil leak "around" the front of the oil pan? Got the car back in December, (44.5K miles, 1 owner, full dealer service records) and noticed an oil puddle after a week or so, when I moved it. Went to my brother-in-laws service station to put it up on the rack and look ('cause you ain't doing that in the driveway!). Dropped the plastic pan, and it seemed to be concentrated around the front of the pan, and not leaking from the front seal.

Fortunately, another shop in town here is authorized to do FCA warranty repairs, so after having them verify what we had found, they replaced the windage tray/gasket under warranty, and all seemed to be good. (what a PIA job too, btw, un-hook everything, jack up engine,etc. Makes me appreciate my 440 even more!).

I happened to notice the other day, that it appears to be leaking again/still. Car is at the shop right now, getting looked at once more. Slightly concerned, as the 5 Year Warranty ends this Friday. We just want our baby to quit bleeding!

Anyone? thoughts, similar issues?
Thanks!
 

·
Registered
Joined
·
9,457 Posts
Have checked your dip stick? Does it show low? Maybe the leak is from the oil filter. Some oil filters don’t work well on our cars. Specially Mobil 1. Who did the last oil change?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
All those areas have been checked and are clean. I did get the car back a few hours ago, and it appears that it is still leaking around the oil pan bolts. The owner of the shop told me that the tech who did it last time, saw in the re-assembly procedure that "new" oil pan bolts are to be used, and weren't, as he was un-aware. Not sure if these bolts have a special coating/sealant or anything like that, as I didn't get to see them.

So, a new gasket, bolt set (and the grommets that go on them) are on order, along with another set of intake manifold gaskets. It will take a week or so for the parts to get here, but I guess it is encouraging that this doesn't seem to be a "known" issue. Just a temporary bummer! :icon_lol:
 
1 - 3 of 3 Posts
Top