Dodge Challenger Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello everyone . Yes I have read I think just about all the overheating threads. So here is the deal I have going on. About a week ago the check engine light came on. I checked and it's the P0013 code. Looked it up and got me a new OCV part . Before I could get to it the car started overheating about 2 weeks after the check engine light came on . So I replaced the OCV and thermostat and added new coolant (yes the purple mopar coolant. Still have overheating problem and check engine light came on with the same code.

Things checked .
Water pump is not leaking and pully is tight ( not wigging by hand )
I can tell the thermostat is opening.
The fan is kicking on when needs to.

Things replaced
Thermostat
Coolant/ antifreeze
OCV

Car is a 2013 Challenger R/T 5.7 manual transmission 6 speed . All stock with 45k miles

Any help ,ideas , tips welcome
 

·
Registered
Joined
·
12 Posts
Discussion Starter #2
*****UPDATE******

After burping it about 3 more times everything is fine with the overheating. Still have the P0013 code
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,803 Posts
Wow, your car has critters! Some rodent was snacking on your wiring. A Guy
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Didn't seem like animals, more like chemical/heat . The coating was just crumbling off !!!
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
16,803 Posts
If the wires were drawing to many amps and overheated, you'd get that effect too.

A Guy
 

·
Registered
Joined
·
575 Posts
What is a P0013 code? What is OCV? Just learning here. Never saw wiring crumble like that when only 3 years old. Any wires doing that elsewhere?

Never mind....I looked it up. I would replace or repair that wiring obviously(duh).
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Well another update!!! Water pump went out...leaking from weap hole. Took old one off and it is shot. Put new one on and filled with coolant and now having overheating issue again...guess I will just keep burping it and maybe that will clear all the air. So tired of overheating issues
 

·
Registered
Joined
·
575 Posts
Well another update!!! Water pump went out...leaking from weap hole. Took old one off and it is shot. Put new one on and filled with coolant and now having overheating issue again...guess I will just keep burping it and maybe that will clear all the air. So tired of overheating issues
This sounds obvious but have you checked the thermostat?

Edit: should have checked your thread starter....sorry
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
Adding to my own post. After thermostat, water pump, coolant, OVC and many burps later all has been good. Till today. Car seems to lost a little power and when I got home I see the idle is around 1100rpm. Any ideas ???
 

·
Registered
2015 RT 5.7 M6
Joined
·
7,516 Posts
Adding to my own post. After thermostat, water pump, coolant, OVC and many burps later all has been good. Till today. Car seems to lost a little power and when I got home I see the idle is around 1100rpm. Any ideas ???
This is totally off the cuff but check for any vacuum leaks...PCV hose is not crack, evap purge hose is not crack, manifold bolts are tight and throttle body bolts are tight. Forgot to add, make sure brake boost hose is not leaking. Might be the car is pulling "false air" hence the reason for high idle.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #13
Also I am hearing a little bit of a howling noise from the alternator. And on my 10min drive just a bit ago my battery light came on on the dash !!!!
 

·
Registered
2015 RT 5.7 M6
Joined
·
7,516 Posts
Not uncommon for the diodes on the alternator to fail. There was a recall on the 2011-2014 for this but considering the car was recently worked on, I would check all that cables to make sure they are plugged in or bolted on tight. Are you sure the howling is coming from the alternator and not maybe not from a vacuum leak on the intake manifold? If your car has overheated in the past it is possible the plastic creeped which is why I suggested checking the bolts for proper torque.

Although it is likely the alternator is failing.
http://www.challengertalk.com/forums/4067866-post68.html
 

·
Registered
Joined
·
12 Posts
Discussion Starter #17
I took it to the dealership and they said yes it's the alternator and there is a recall and they will replace it and the battery for free. Im waiting for the call to pick it up now. I will let y'all know what happens.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #18
Got the car back and with new alternator all is good again. They wouldn't replace the battery cause it's original to the car....yes 2013 battery still kicking. I know that will be next to fail I'm sure.
 
1 - 18 of 18 Posts
Top