Dodge Challenger Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
Got a CEL monday, pulled the code and its a P0300 and P0303 mutliple misfires.. misfire #3

This is the second time I have gotten a cel.. first time was a fuel trim too rich downstream code. They blamed my AFE stage II on that.. but I think that was BS. I put the stock air box back in and ran it for a week with no code. I then put the AFE back in and ran it for 2 months with no code....

Doing some research it appears this has plagued quite a few people going all the way back to the 6.1. Reading the resolutions do not give me much hope.. just seems like time and time again its a "We dont know whats causing it" response.

I have read that this has turned into a star case for the 2014...

I love my car but this is testing my limits. At the moment this is my daily driver. I figured I would drive this though summer and get a jeep for winter. Anyway.. just wanted to vent. Its at the dealer now, but no loaner. sigh...
 

·
Registered
Joined
·
53 Posts
You are not alone my 14 is doing the same thing. I've taken it in 3 times to have the code cleared they finally just told me to keep driving it and the code will clear itself. My service guy said dodge was supposed to come out with an ecm patch the end of the second quarter but that didn't happen now he's saying October sometime but we'll see.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #3 ·
You are not alone my 14 is doing the same thing. I've taken it in 3 times to have the code cleared they finally just told me to keep driving it and the code will clear itself. My service guy said dodge was supposed to come out with an ecm patch the end of the second quarter but that didnt happen now hes saying October sometime but we'll see.
My concern is of course
#1.. is it really misfiring which I believe it is... then why. Obviously its a brand new high performance machine.. it shouldn't be misfiring brand new. If it is computer related I hope they don't just increase the threshold as noted by others here for their fix.

#2.. What long term damage can arise from driving it around while its misfiring as we wait for a fix
 

·
Registered
Joined
·
5 Posts
It should be getting a pcm update shortly. It is not misfiring constantly just at start up and it is interpreting data false and setting a code there will be no damage to the motor it most likely is getting a bad crankshaft signal at startup causing a rough idle at startup but when it can interpret the data it runs normal. just a processing issue within the pcm Chrysler will come out with a flash for it .
 

·
Registered
Joined
·
53 Posts
Yes please post if you get the light again im curious to see if this fixes it. My dealership doesn't do anything but reset the code so any info on this would at least give me hope of a fix sometime soon.
 

·
Premium Member
Joined
·
697 Posts
Well I have had the engine replaced due to lifter failure and I'm still getting the cold start up hard misfires but I'm not giving up just yet. Waiting on the PCM flash as I really like my 2014 Challenger SRT8. I almost lost it this morning though when it started it up and misfired like you would not believe...lol

I'm going to wait on the PCM flash. The Chrysler engineers better get a move on and get this patch finished or they will loose a lot of customers..

I was almost ready to make them eat the cost of the car...lol


Dale McPeters


Sent from AutoGuide.com App



Sent from AutoGuide.com App
 

·
Registered
Joined
·
31 Posts
I just picked my car back up this morning after the P0300 and P0307 (#7 misfire) lit the CEL last week upon a cold start. They claimed a PCM update as the resolution on the paperwork... we'll see if it comes back on.
 
1 - 13 of 13 Posts
Top