Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Please help, today i received and installed a new CAI for my 2014 Challenger RT that I ordered from Mopar. Problem is after the install I closed the hood and noticed that the hood was slightly raised over the new air box, I reopened the hood and marked the gasket with some blue chalk and closed the hood again, true enough when I reopened the hood, there were blue chalk marks on the underside of the hood. Could I have not seated the box in the chamber properly?? It seemed to fit right in there and everything went together smoothly, so I'm wondering what. May have done wrong..

Any advice would be greatly appreciated:SM030:
 

·
Premium Member
Joined
·
1,819 Posts
Hmm, I am about to install a JLT CAI tomorrow, I bet the instructions are very similar. Do you have the shield seated down in the grommet all the way? That's the only think I can see that might cause what you seeing.

How much is slightly raised? 1/8 inch? 1 inch?

Some other folks will chime in soon
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
The hood is raised about 1/8 of an inch. It's enough for me to notice that something doesn't look right, I plan to pull it and reinstall tomorrow. Thanks for the reply
 

·
Registered
Joined
·
1,222 Posts
Hummm interesting i have a 12 with Mopar CAI, now i know there are 2 version of the mopar cai one fits 08-10 and one goes 11 to I'm guessing 14. Do you have a pic of the cai? I know sometimes the box that holds the filter can sit on the wires and cords may need to move them aside to fully seat the box?

Here is mine ImageUploadedByAutoGuide1393677789.814658.jpg


Sent from AutoGuide.com App
 

·
Registered
Joined
·
532 Posts
On the CAI where you reuse the rubber boot that goes near the coolant tank, is it completely in the hole. I had to fanagle mine to get in the hole. I wish I knew what the part was called, it is the rubber boot that goes over the metal post on the CAI box.
 
1 - 5 of 5 Posts
Top