Dodge Challenger Forum banner

1 - 4 of 4 Posts

·
Registered
2015 Dodge Challenger Scat Pack
Joined
·
276 Posts
Discussion Starter #1
Last night my UConnect became unresponsive/unusable (to a point) after failure to initialize a phone call via bluetooth. This is a fairly large description of what happened but I want to be clear about the steps before and after the freeze.

Coming home from work last night in the car I was listening to some music via the SDCard when I received a phone call from my wife. I always keep the the bluetooth on on my Galaxy S4, and this was connected when I started the car about fifteen minutes before I received the call. So the music stops and the phone rings through the speakers as normal, the Call screen comes up with my wife's name/number, and I press the green answer button. I say "hello" and no response. Say "hello" again a few seconds later and no response. Since I was driving and didn't want to fiddle with the screen or my phone, I pressed the red hang up button on the UConnect. Nothing happened. I pressed it a few more times with the same result. Nothing changed on the screen. Then I pulled out my phone, said "hello" again to see if she was still there and when I got no response, ended the call using my phone. At this point, I noticed that the UConnect call screen was still up and the music didn't start back up as usual.

Almost immediately, the wife calls and my phone starts ringing again, however, this time the phone itself is ringing and not coming through the speakers. I try answering the call through the UConnect Call screen that's still up, which doesn't work. I also tried to press the 'transfer' button and that doesn't work. I finally answer the call via the phone, let the wife know I'm having technical difficulties, and say that I will call her back and hang up. After I end the call, the UConnect screen is still on the Call page and no matter what I push on that page, it still shows the green call button, the red hang up button, the white transfer button (on the right), and my wife's name/number. All other options on the Call page are greyed out including settings, fav's, etc. and no music is coming through.

I try going to other pages. I'm able to navigate to the Radio, SDCard page, Climate pages, Navigation page, I even go into the Performance Pages (which loads fine). All of the pages load and work, with the exception of the Radio & SDCard music pages. No music will play at all no matter what.

Part of my agenda on the drive home today was to stop and get fuel since I was below half a tank and I figured this would be a good time for me to shutdown the entire car and get my tunes back, so I drive for another ten minutes to my regular Shell station, pull up to the pump, and shut down the car. Here is where I made a mistake. I forgot to look at the screen when I was exiting the car. I simply got out and fueled up, the got back in, started the car, and headed for home. It was only when I pulled out of the fuel station onto the street that I noticed the frickin' Call screen was still up! It was still unresponsive and no music, but the Nav, climate, etc. still worked. Being five minutes from home I said the hell with it and would look at it then.

Got home, backed into the garage, shut the car off. Typically, when I open the driver's door after shutting her down, the screen always shuts off. When I did this last night the screen stayed on with the Call screen being displayed. Also noticed that the speed and RPM guages stayed lit the entire time. I tried everything I could think of including restarting, going through Uconnect settings, tried all of the start modes with the 'Start' button, trying to get the screen off but nothing worked. I finally ended up having to disconnect the negative battery cable to shut the damned thing off. To top all of that off, when I'm trying all of these things my wife comes out and asks me if one of those hackers hacked into my car. I'm positive I rolled my eyes since I was already so frustrated.

Everything appears to be working normally now but I want to see if anyone else has had this happen. Is there a trick to resetting the UConnect, either while the car is running or off? If this would've happened on the way in to work I'm not sure how I would've gotten the system shutdown. I wouldn't have a wrench handy in most situations.

I don't usually carry my tools around with me in my car but after this fiasco you bet I have my wrench in my trunk right now. Thoughts?

Thanks.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
14,717 Posts
Welcome to Challengertalk ;) A negative battery disconnect usually has the same effect, but you can also reset the Uconnect

Push the start button twice to RUN with your foot off the brake to keep engine from starting.

Press and hold the Red temp up ^ and Blue temp down v buttons at the same time (The physical buttons below the radio) until the Engineering menu on the Uconnect appears. Scroll down to Reset Radio. Don't try any of the other functions

Do not do Reset to factory default

See if that works


A Guy
 

·
Premium Member
Joined
·
391 Posts
Sounds like the same crap I went through with my 2017 R/T Plus Shaker. Apparently the NAV units have a lot of screwy problems. Traded it in when FCA wouldn't do anything about it for a 2019 G/T Plus and couldn't be happier.
 
1 - 4 of 4 Posts
Top