Dodge Challenger Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hello Gentlemen,

There are so many threads about installing a backup camera to a challenger that does not have it. I was hoping we can just compile all the info in ONE place. Here is what I have found out after looking at dozens of threads.

1. We all have a R A 2 radio with 5. screen
2. The wire for the camera is on the lid of the truck installed from the factory.
3. The dealer needs to activate it with code: XAC

What info we need clarification on is the following.

1. What cameras we should use? Need part #
2. Is there any additional wiring needed or a kit needed?
3. Is the wiring already attached to the monitor on the dash?

So PLEASE, lets put all our knowledge into ONE place. That way when it comes up again, which it will, we can point to this thread. :thumbsup:

Thanks
 

·
Registered
2015 RT
Joined
·
118 Posts
I added the oem cam/spoiler to mine, but I also upgraded to the 8.4 radio. I ordered a spoiler for an SXT Plus in the same color as my car from Steve White Motors (beat every price I could find). Used the parts finder on their site for the correct number. Went to Mopar parts service tab, Steve White Motors Parts from the sub menu, Enter 2015, Dodge, Challenger, SXT Plus in the trim tab, select body tab, then spoiler tab (right side close to bottom), Select color from the list for the correct part number, can also get the hardware numbers from the same tab. Use cha1 for a discount when ordering. I ordered all oem hardware to make the install look like factory.

15 SXT Plus spoilers have the oem camera pre installed with the connector for the harness that is in the trunk (small grey plug, close to the latch under the liner). The harness is all ready hooked to the radio, so no other connections required. A trip to the dealer, or the purchase of the Tazer to get the camera activated, and you are good to go! I went with the Tazer, because I installed oem fog lights (also has to be turned on) and wanted the performance pages as well.

Hope that helps a bit....
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
Where to purchase

Thanks MLR1,

Greatly appreciate your help here. Got a question:

1. Is there a std camera only that I can purchase. Maybe like one from another vehicle? I have a spoiler already and I heard that the std camera in the spoilers are not that good.


You can get a TAZER for $249. at http://www.zautotech.com/tazer.html

Thanks again.
 

·
Registered
2015 RT
Joined
·
118 Posts
Not sure if there is another camera that will work or not. My car didn't have a spoiler at all, so I just went with the factory option. I already have the Tazer to turn things on/off. I figured two trips to the dealer to activate fog lights and the camera, would just about cover the cost. Plus, I was able to access the performance pages!
 

·
Registered
Joined
·
5 Posts
Hardware

I added the oem cam/spoiler to mine, but I also upgraded to the 8.4 radio. I ordered a spoiler for an SXT Plus in the same color as my car from Steve White Motors (beat every price I could find). Used the parts finder on their site for the correct number. Went to Mopar parts service tab, Steve White Motors Parts from the sub menu, Enter 2015, Dodge, Challenger, SXT Plus in the trim tab, select body tab, then spoiler tab (right side close to bottom), Select color from the list for the correct part number, can also get the hardware numbers from the same tab. Use cha1 for a discount when ordering. I ordered all oem hardware to make the install look like factory.

15 SXT Plus spoilers have the oem camera pre installed with the connector for the harness that is in the trunk (small grey plug, close to the latch under the liner). The harness is all ready hooked to the radio, so no other connections required. A trip to the dealer, or the purchase of the Tazer to get the camera activated, and you are good to go! I went with the Tazer, because I installed oem fog lights (also has to be turned on) and wanted the performance pages as well.

Hope that helps a bit....

you mentioned the hardware. when you order the sxt plus spoiler from that website, does it come with the required hardware needed to install the spoiler? on the same note, did you have any problems installing it? any advice as far as where/how to drill the holes? thanks in advance
 

·
Registered
2015 RT
Joined
·
118 Posts
All the hardware needed are the two nuts for the studs on each end of the spoiler and some covers for the nut/studs. The covers are not required, but give it a more finished look. The nuts can be bought at a hardware store, but I was ordering a spoiler anyway, so just added them to the list.

I made a paper template for drilling the holes. I started with a scrap piece of wood. Placed the spoiler on it and traced the mounting pins and studs as best I could. Drilled holes in the marked locations (make holes larger than the pins so they won't grab when inserted). Placed some paper on the wood and pushed the spoiler through the paper/holes. Then I traced the outline of the spoiler and cut paper to match. Taped my template on the trunk lid and center punched the mounting locations for drilling. There are two holes through the inside layer of the trunk for the studs on the ends. Try and line up the template with those two locations. I was able to hit those spots right in the center with my template. Worked great for me and looked just like OE when done.

Hope that helped some...
 

·
Registered
Joined
·
1 Posts
So my SXT came with the 8.4 instead of the 5.0 and it has the harness ready for the camera. I bought a factory spoiler with camera and plugged it in, but when I took it to the dealer to activate it, they said my car wasn't compatible to use a back up camera. They tried programming it in 5 different times with no success. He did say that the camera was working, but when in reverse, nothing was popping up on the screen. They gave me the whole spiel about there is no factory part they have that will connect a back up camera with my SXT. What should I do? I'm thinking about getting a tazer, but I'm not 100% sure it will work, or even if it does, $250 is a lot to spend on just a one time flash.
 

·
Registered
Joined
·
381 Posts
So my SXT came with the 8.4 instead of the 5.0 and it has the harness ready for the camera. I bought a factory spoiler with camera and plugged it in, but when I took it to the dealer to activate it, they said my car wasn't compatible to use a back up camera. They tried programming it in 5 different times with no success. He did say that the camera was working, but when in reverse, nothing was popping up on the screen. They gave me the whole spiel about there is no factory part they have that will connect a back up camera with my SXT. What should I do? I'm thinking about getting a tazer, but I'm not 100% sure it will work, or even if it does, $250 is a lot to spend on just a one time flash.
Did you ever resolve your issue? I’m having a similar problem. The dealer can turn on the aftermarket camera I bought, and it shows on the screen. but it won’t appear on the screen when I shift into reverse.
 

·
Registered
Joined
·
22 Posts
A member here sold me the camera from an accident spoiler that got replaced. I did not want a spoiler, so I put it in the black trim piece where an angle makes room, just a tad off center for clearance. I had to enlarge an existing hole for the connector to pass through. After the dealer, it was effectively plug and play. This was a '16 SXT with only SXM as option, so RA2/5.0.
I also added remote start, and fogs.
The dealer 'activated' them all in an hour, and it was $120 as I remember.
Use all 3, enjoy, well worth the less-than-$500!
And since it's all 'factory', there's no added instructions for 'other drivers' and the value adds to the car.
 

·
Registered
Joined
·
381 Posts
Challytatum, Those install instructions seem to be for a complete kit if your car isn’t already prewired for a camera. Mine already has the harness, fuse, etc. My mechanic (I work at the dealership) set up the software and updated the car as needed. He can use the diagnostics to turn on the video input, and the camera works, displaying on the screen. But when I start the car and put it in reverse, nothing. The screen doesn’t change to reverse mode or display the camera image at all. We’re at a loss. I’m currently wondering if it’s my radio, as I replaced my 5” screen with an RA4 8.4” from a 2014 Grand Cherokee. Everything on the radio works except the media hub, which I’m assuming is an incompatibility between model years. I may try connecting my old radio tomorrow to see if that works.
 

·
Registered
Joined
·
381 Posts
Well, I finally got it working. I’m not sure what happened, but I used the dealer’s computer to flash it again today, and it started working!
 

·
Registered
2015 RT 5.7 M6
Joined
·
5,626 Posts
Yeah I posted the instruction primarily to show people looking for how the spoiler mounts and wires up in case they stumble on this thread. As for your issue I was going to recommend trying the tazer to enable the camera functionality as that is one of it's capabilities but I figured since you were using a dealership there was no point in mentioning it. I have seen a few folks using it with success.

So it is all working now...cool beans...do you have the backup grid lines showing as well?
 

·
Registered
Joined
·
381 Posts
I have backup grid lines that don’t move from the camera itself. It doesn’t appear I can enable the factory grid lines. I don’t want to cut the wire that disables the camera grid to find out, and then have to splice it back together in the likely event it doesn’t work.
 

·
Registered
Joined
·
17 Posts
In settings disable the gribkines and then re-enable them see if that helps. I had to Tazer
Mine then go to settings and turn off then back on for it to work correctly.
 

·
Registered
2015 RT 5.7 M6
Joined
·
5,626 Posts
I think the power steering rack must have a position sensor which I thought only comes with the parking assist package. However, it looks like the SXT,SXT+,RT,RT+ share the same rack and pinion so it looks like the steering sensor is standard. :dunno:
 

·
Registered
Joined
·
4 Posts
Hi Guys,

You are awesome (sharing all that information)

I have added the spoiler with oem cam, the plug was at the trunk lid already.
Now I want to upgrade the radio to 8.4. The question is do the dealer flush the radio unit or they flush the BCM.
My understanding is that all radios have already the wiring and the capability to show the video signal. And the Body Control Module is where all the features are written.
So I think that only activation that needed is the body module but not the radio unit?
 
1 - 17 of 17 Posts
Top