Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Got up this morning and went to start my car up like I do everyday......everything comes on gauges (weakish) but it doesn't crank. I try to start it a couple of times and nothing.

Did i leave something on?
Headlights > Off (On the circle)
Dome lights > Off
Trunk > Closed
Power Ports > Nothing in them

I turned on my headlights to see if they even came on but HIDs just rapidly strobbed.
I went to lock it from the outside and the normal loud Roadrunner beep it makes sounded like he was on his death bed.
?

I just left the car in the garage and took my beater car because I was running late by now.

How can a brand new car with 38,000 miles have a bad battery already???
It's not even 3 years old.....my beater ran with a battery for 5 years lol
I'm sure they last a bit longer than 3 years...

Mods:
Aftermarket HIDs (1 year old)
LED Fogs (1 year old)
Supercharger (4 Months old)

Hopefully this is not the cause....it can't be. I should of seen early signs of it causing it

Going to further look into it when I get home.
 

·
Premium Member
Joined
·
9,346 Posts
Batteries do quit that young, 38,000 miles isn't exactly brand new. Fortunately you were home and had alternate means to get to work.
I've had batteries die at just over one year old.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
So i took the battery to Advanced Auto Parts and found out the battery was actually bad.... $200 later i have a bigger and badder battery with a 3 year warranty.
Good to go now??

Just thankful it wasn't any other problem like a mysterious parasite.
 

·
Registered
Joined
·
28 Posts
I also saw on the news that FCA will be releasing another alternator recall, not sure if this is the cause of if it will be on your specific model, but just my .02
 
1 - 5 of 5 Posts
Top