Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello!
I bought preowned 2016 Challenger R/T Plus with 6-speed MT.
One thing which bothers me is the brake pedal returning slowly. It takes about 1 second for the pedal to return to default position.

I have prepared a short video demonstrating it, but since I cannot post URLs yet - you can find it on youtube looking for "Challenger 2016 RT brake pedal".

I took the car to the dealer, they did some checks and I was told it's perfectly fine.
As there was no 6-speed available for test drive, I couldn't check it on different car.

Is it normal in this model?
Otherwise the brake works perfect...
 

·
Registered
Joined
·
1,544 Posts
How long ago did it start? I would check the brake/clutch fluid to start because they share a tank. How many miles on your car?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Comapred with other one - it seems to be ok

Thanks for replies.
I was able to find the same model around and I had a test drive - the brake pedal was working exactly the same, so I assume this is how it is supposed to work.
I had it checked by the dealer before, they did all the brake systems testing and the result was - everything's ok.
The car has 4500 miles on it.
 

·
Registered
Joined
·
27 Posts
Mine has done the same from new ('15 RT Manual) - I too asked the dealership to confirm it's operation was normal and was told the same. It's working as designed.
 
1 - 5 of 5 Posts
Top