Dodge Challenger Forum banner

2015 SXT won't turn off with push button

2178 14
Not really sure what's happening. Battery needed to be jumped off for the first time last weekend. Horn blared and would not turn off with key fob. Car cranked and drove home. Once in driveway, car will not turn off. I can push the button as may times as I want and car will not move from RUN position. The car is registering that the transmission is in Park.
I pull the ignition relay to turn the engine off, and then disconnect the battery because the interior stays on. Then when I am ready to do more troubleshooting, connect the battery to the horn blaring and same situation again.

Car cranks and drives fine, no issues. Battery has held a charge since jumping off.

Any magic wand or experiences I can lean on from someone?? Thanks in advance.
1 - 4 of 4 Posts

·
Registered
2015 RT 5.7 M6
Joined
·
12,768 Posts
Best scanner software (there is an android and PC version) is alfaOBD, it sees codes that most generic scanners won't read. Requires an OBD interface like OBDlink MX bluetooth (has a superior chipset to ELM327 in most generic interfaces).


FWIW my JGC went crazy when the battery died. Once I disconnected the battery and charged it up there were a ton of codes stored by my BCM/ABS/Climate control module that I cleared.
 

·
Registered
2015 RT 5.7 M6
Joined
·
12,768 Posts
According to the FSM apparently if you repeatedly hit the button it will cause the engine to shut off.

"After putting the vehicle into park, pushing the KIN’s Go-Button allows the vehicle’s engine to be shut off. In an emergency, pressing the Go-Button continuously for 2 seconds or repeatedly (one hit every 30- 500ms) will cause the engine to shut off when vehicle speed is greater than 5 mph."

On a side note, I did see a guy on the HC forum with a similar problem where the car would not shut off after having his front window tinted. Apparently water from the tinting process shorted out something on the dash...apparently has happened to other HC owners.
 

·
Registered
2015 RT 5.7 M6
Joined
·
12,768 Posts
Sounds like you have:

U1433-24-Implausible Ignition Switch Status Message Received - Signal Stuck High

Set Conditions:
  • The Body Control Module (BCM) detects the CAN Bus message from the Radio Frequency (RF) Hub Module transitions between ignition off and ignition on, but the hardwired ignition input from the RF Hub Module did not change states for greater than 10 seconds.
Default Actions:
  • The vehicle will not transfer to the Off position.

Possible Causes
IGNITION RUN-START OUTPUT CIRCUIT SHORTED TO VOLTAGE
RADIO FREQUENCY (RF) HUB MODULE
BODY CONTROL MODULE (BCM)

If you go through the chiltons manual you can view the diagnostic steps.
 

·
Registered
2015 RT 5.7 M6
Joined
·
12,768 Posts
Glad you finally got it fixed and appreciate you posting the fix. Can't believe these cars are so sensitive to dead batteries, although the pre-2015s seem to ship the bed more often than the newer models. My 2013 JGC recently had a dead battery and trying to jump it made the BCM freak out...it does not like low voltage. There were a bunch of codes I had to clear once I charged the battery and reinstalled it.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top