Dodge Challenger Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Back I. 2018 I took my 2016 Challenger in due to the green screen, squiggly view (similair to tuning an old television), blank screen at times when my vehicle was in reverse. The dealership could not find anything wrong so they said they replaced the camera and it was working after that. About a few months later and started the issues all over again and by this time my warranty was up. To this day it continues to work when it wants, I did how ever try something new from what I saw on others who had this problem by putting the grease on the connections like the old light bulbs, it worked for a bit and is back to it's old games. Does anyone know if Dodge has put a recall on this camera to have it replaced or is it a lost cause?
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
26,715 Posts
Welcome to Challengertalk ;) No camera recalls for 2016, sorry. I know many camera issues are harness related, another reason they work for a while after camera replacement as the harness has been moved in replacing

A Guy
 

·
Registered
Joined
·
26 Posts
I have a 2016 Challenger Hellcat with the same problems, i.e., Green screen, squiggly lines, and mine started doing it about 2 months ago. Anyone with remedy's without having to go back to the dealer for high dollar repairs, please share. Driven over 131,000 miles, and will continue to love it for many miles to come.
 

·
Premium Member
Joined
·
2,989 Posts
I have a 2016 Challenger Hellcat with the same problems. Driven over 131,000 miles, and will continue to love it for many miles to come.
Wowsa!
131,000 miles on a Hellcat is crazy. You must be loving life with it. I'm so envious. I can't help you with your problem, but I just wanted to acknowledge the amount of fun you must be having.
 
  • Like
Reactions: 19johned53

·
Premium Member
Joined
·
1,925 Posts
I have a 2016 Challenger Hellcat with the same problems, i.e., Green screen, squiggly lines, and mine started doing it about 2 months ago. Anyone with remedy's without having to go back to the dealer for high dollar repairs, please share. Driven over 131,000 miles, and will continue to love it for many miles to come.
It is possible that your Uconnect software is not up-to-date. Enter your VIN in the following link: Software Update for Uconnect® - Check For Updates to make sure. If this is not the case, you can send us a private message and we would be happy to look into this further for you.

Alison
DodgeCares
 

·
Registered
Joined
·
90 Posts
I had this on my 2015 RT and I disconnected the connector in the trunk added dielectric grease, put it back together and wire tied it so it didn't bounce around. Problem was fixed.
 
1 - 6 of 6 Posts
Top