Dodge Challenger Forum banner

1 - 20 of 139 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
a little over a week ago I picked up my 2017 T/A 392. It is a fantastic car! However I am having some issues with the Uconnect 8.4 I wanted to see if anyone else has run into this

2 nights ago the unit froze on my way home from work and would not shut off despite me getting out of the car and waiting for about 20 min, and the screen was getting hot. In the meantime, I called uconnect but they suggested that I get to a dealer, which would be impossible due to the time. So then the guy I spoke to mentioned disconnecting the battery for 10 min. I did just that uconnect came back but without some of the features (xm) and I called a few dealers and left messages to try to get something set up.
The next day uconnect was back fully but then on the way home it froze again. Uconnect support said they cannot do anything and it needs to go to the dealer and to let it sit until the battery dies. Luckily this time it was not frozen on and did turn off once I opened the door as it is supposed to. The earliest I can get in to the dealer is next week, but I’m hoping this is an isolated incident.

Any suggestions on what to do in the meantime? I have removed my phone from BT to see if that was the cause.
 

·
Registered
Joined
·
200 Posts
a little over a week ago I picked up my 2017 T/A 392. It is a fantastic car! However I am having some issues with the Uconnect 8.4 I wanted to see if anyone else has run into this

2 nights ago the unit froze on my way home from work and would not shut off despite me getting out of the car and waiting for about 20 min, and the screen was getting hot. In the meantime, I called uconnect but they suggested that I get to a dealer, which would be impossible due to the time. So then the guy I spoke to mentioned disconnecting the battery for 10 min. I did just that uconnect came back but without some of the features (xm) and I called a few dealers and left messages to try to get something set up.
The next day uconnect was back fully but then on the way home it froze again. Uconnect support said they cannot do anything and it needs to go to the dealer and to let it sit until the battery dies. Luckily this time it was not frozen on and did turn off once I opened the door as it is supposed to. The earliest I can get in to the dealer is next week, but I’m hoping this is an isolated incident.

Any suggestions on what to do in the meantime? I have removed my phone from BT to see if that was the cause.

It sounds like to me you have a bum unit... Have the dealer replace for new (IMHO)...
 

·
Premium Member
Joined
·
2,722 Posts
I agree with the above. This is a head unit issue, not Uconnect.
 
  • Like
Reactions: Razman247

·
Registered
2019 Sublime Shaker, 2010 Plum Crazy R/T Classic, 2010 Detonator Yellow R/T Classic
Joined
·
1,977 Posts
So I have a 2017 Uconnect unit and mine did freeze up for the first time at around 1500 miles and it was doing it for 2 days. I was pretty pissed but after disconnecting the battery a couple of times and manually shutting the radio unit off (push on the volume button) the problem went away and it has not returned in the last 1000 miles. Now when you disconnect the battery the XM radio and NAV will not work for about 5-10 minutes after it's reconnected and turned on. That's been my experience so far. I have owned a number of these cars and every so often one of the head units will act up for a day or two and then I never see a problem again, no idea why.
 

·
Registered
Joined
·
39 Posts
I had a problem with my UConnect module. To be more specific, the Bluetooth was not connecting and the Android Auto was no longer connecting to my phone. Not to mention that on a random basis, it was shutting itself while I was driving down the road.

Luckily, my dealership was quickly able to acquire the parts needed to fix my UConnect module. Turns out that the mechanics there had to take the dash off and replace the entire UConnect module wholesale. After that, no problems and all under warranty.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #6
update: dropped off at a dealer close to my house they tried the update and said it did not work so it needs a new Uconnect unit which they have ordered.
:)
 

·
Premium Member
Joined
·
592 Posts
The U-connect person on the phone was wanting you to have to replace the battery after getting the system fixed? Just leaving it stuck on till the battery goes dead! They should know that every time a battery is drained completely flat you lose half your reserve capacity. If it stays on again the best thing to do is disconnect the battery. Or if I was going to follow their advice I would record their telling you to just leave it alone and park it out in the driveway so if it overheats and burns the car up it would not burn my garage and my other cars with it. Then the u-connect people would be replacing a ruined battery or the whole car because of what happen from following their advice.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #8
The U-connect person on the phone was wanting you to have to replace the battery after getting the system fixed? Just leaving it stuck on till the battery goes dead! They should know that every time a battery is drained completely flat you lose half your reserve capacity. If it stays on again the best thing to do is disconnect the battery. Or if I was going to follow their advice I would record their telling you to just leave it alone and park it out in the driveway so if it overheats and burns the car up it would not burn my garage and my other cars with it. Then the u-connect people would be replacing a ruined battery or the whole car because of what happen from following their advice.
That was not the worst part. that first person I called at Uconnect hesitantly told me the only thing to do would be to disconnect the battery. I called later that night to tell them that it was working now but I lost XM ( I later found out that you lose xm for the first few min as the radio is reloading it). The second Uconnect rep I spoke with asked me why I disconnected the battery and that I can/could have voided my warranty if I do that. she asked 2-3 times if the previous rep told me to disconnect the battery. I told her that the screen was frozen, and getting hot and no dealer was open that late so that was the only option, and yes the previous rep said to do so...
 

·
Registered
R/T Plus Shaker
Joined
·
31 Posts
Just had a problem with our 2016 R/T this morning. The car has 1100 miles on it. We bought it new a couple of months ago. When my wife started the car uconnect 8.4 was stuck on the home screen. She had no idea what to do. She turned the car off and back on but that didn't clear it. I drove up to her work to disconnect the battery, but when I started her car uconnect started working right away, so I left it alone... Fortunatly it didn't stay on while the car was turned off. It was still annoying to say the least.. Hopefully it won't happen again. Nothing sucks more than going to a dealer to explain a problem while the problem isn't present at that time...
 

·
Premium Member
Joined
·
1,700 Posts
Just had a problem with our 2016 R/T this morning. The car has 1100 miles on it. We bought it new a couple of months ago. When my wife started the car uconnect 8.4 was stuck on the home screen. She had no idea what to do. She turned the car off and back on but that didn't clear it. I drove up to her work to disconnect the battery, but when I started her car uconnect started working right away, so I left it alone... Fortunatly it didn't stay on while the car was turned off. It was still annoying to say the least.. Hopefully it won't happen again. Nothing sucks more than going to a dealer to explain a problem while the problem isn't present at that time...
Hi Jeff Rodriguez,

If the concern reappears please don't hesitate to reach out for further assistance, I'd be happy to look into it further for you!

Andrea
Dodge Social Care Specialist
 

·
Registered
Joined
·
71 Posts
My Uconnect locked up while being test driven by the tech for another issue. My car was made 11/16 and there was an update released 12/16 that he installed and so far everything is ok.
 

·
Premium Member
Joined
·
277 Posts
That was not the worst part. that first person I called at Uconnect hesitantly told me the only thing to do would be to disconnect the battery. I called later that night to tell them that it was working now but I lost XM ( I later found out that you lose xm for the first few min as the radio is reloading it). The second Uconnect rep I spoke with asked me why I disconnected the battery and that I can/could have voided my warranty if I do that. she asked 2-3 times if the previous rep told me to disconnect the battery. I told her that the screen was frozen, and getting hot and no dealer was open that late so that was the only option, and yes the previous rep said to do so...
Sounds like UConnect has well trained support specialists. *rolls eyes*

Sent from my SM-G935V using Tapatalk
 

·
Registered
Joined
·
1,118 Posts
From what I read there are a lot of bugs in 2017 with these radios. When I picked up my car from the dealer the radio screen was blank. I went after work to pick up car so no one there except salesman to help me out. He swore that it was working when they parked the car. I was furious. I could leave the car " outside" and he would give me a loaner or bring it back the next day. I had to bring back anyway for paint/ interior/ wheel protection anyway so I took car home. I did a battery disconnect and it came back to life without any issues. I will wait for a month or so and bring it back for a reflash. Hopefully the will have it figured out by then.
 

·
Registered
Joined
·
8 Posts
Has anyone had any problems getting Bluetooth to connect? My phone and my new Challenger won't seem to communicate, but I have no problem pairing in my 14 Avenger or any other Bluetooth device I have. Is there anything I need to do to activate it?
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
22,430 Posts

·
Registered
Joined
·
8 Posts
Thanks A Guy. I tried using those documents before, but no luck. My phone doesn't show the UConnect as an available device to connect to. I've never had this problem before.
 

·
Registered
Joined
·
71 Posts
My 2017 won't connect or recognize uconnect. While having my differential replaced today, the tech did a search and found that a service bulletin revision was issued on 5/12/17 for vehicle built before 4/2017. The dealer is still waiting for the software update to be available and will contact me when ready. The update covers about 24 issues that have been occurring with uconnect, one being paired phones will not connect. The service bulletin number is 08-007-17 Rev. C.
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
22,430 Posts
1 - 20 of 139 Posts
Top