Dodge Challenger Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all-

Well, after wanting one for a few years now, I finally pulled the trigger last weekend and bought the beauty in my avatar!

I had hoped for the V8 but was just not in my budget right now.

So 2 days after I bought the car, I was on my way home and the radio stops working- the climate controls stop working. My iPhone won't connect. What the hell is what I am thinking. Dealer is closed. Eh let's check online see if anyone has had this problem.

I love this Forum! Disconnected the battery. Didn't fix it. In fact, locked the radio. Checked the Forum again and pull the fuse. I now have a working radio again! My iPhone works. My climate controls works.

Time to stop sitting on the sidelines and join the Forum!

Thanks to all who help!
 

·
Premium Member
The Pork Wagon (‘14 Cop Charger)
Joined
·
7,725 Posts
Welcome to the forum, and congrats on the new car!

Good to hear you've already solved your first problem using info from CT!

Hopefully you won't have any more problems with your car, but if you do and cannot find the resolution by searching on here, create a thread in the appropriate section to ask some questions on it. Not only will you get input on possible fixes, but you'll be paying it forward by creating something searchable that can be found later on by other users who encounter the same problem and come here looking for help.

Regards,
Nuke
 
  • Like
Reactions: silver scat

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
20,715 Posts
Welcome from California ;)

A Guy
 

·
Registered
2014 SRT Core
Joined
·
10,054 Posts
Welcome to the forum and congrats on your new ride.
 

·
Registered
Joined
·
1,075 Posts
Welcome from central Maryland!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
168 Posts
Welcome from NJ
 

·
Premium Member
Joined
·
2,874 Posts
Welcome from Illinois!! Great job on the repair on the fly. Great people here. Good luck.
 
1 - 9 of 9 Posts
Top