Dodge Challenger Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi...I have a 2018 Challenger T/A/, 6.4, 6-speed manual, VIN Number: 2C3CDZFJ7JH111202.

All of a sudden the display for the backup camera became very dark. Worked fine until a couple of days ago. No modifications. How can I get it fixed.

Thanks
 

·
Registered
2018 Dodge Challenger T/A Plus in Yellow Jacket w/5.7L and A8 automatic
Joined
·
659 Posts
Do you have any warranty remaining?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Yes, the car has 14,000 miles on it, plus I have the 8 year Mopar Vehicle Protection warranty.
 

·
Registered
Joined
·
56 Posts
My 2016 SPS does this from time to time. I tap the rear spoiler near the camera, then open the trunk and tap the trunk liner near the camera and it fixes it every time. I haven't had a chance to take it in to get it looked at, but I have 8 months of warranty left, and the 8 year plan like you. I hate taking it to the dealer but I guess I will when i get a chance.
 

·
Registered
2018 Dodge Challenger T/A Plus in Yellow Jacket w/5.7L and A8 automatic
Joined
·
659 Posts
Yes, the car has 14,000 miles on it, plus I have the 8 year Mopar Vehicle Protection warranty.
Sounds like a trip to the dealership is in order then...
 

·
Registered
Joined
·
70 Posts
I have read other posts where the connector to the camera in the deck lid is loose. You might want to remove the decklid liner & check this connector. Would also be a good idea to put some dielectric grease on the connector as well. Otherwise, a trip to the dealer would be your other option.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
I have read other posts where the connector to the camera in the deck lid is loose. You might want to remove the decklid liner & check this connector. Would also be a good idea to put some dielectric grease on the connector as well. Otherwise, a trip to the dealer would be your other option.
Thanks for the tip. I'll give it a try.
 

·
Registered
Joined
·
1,962 Posts
as stated, prob loose cam connector. get in there, unplug it, clean terminals with soft wire brush, reinstall and secure it with electrical tape or silicone. common problem.
 

·
Premium Member
Joined
·
1,525 Posts
Hi...I have a 2018 Challenger T/A/, 6.4, 6-speed manual, VIN Number: 2C3CDZFJ7JH111202.

All of a sudden the display for the backup camera became very dark. Worked fine until a couple of days ago. No modifications. How can I get it fixed.

Thanks
Hi bp7260,
We sincerely regret to hear that this happened to you. If you have not done so already, we recommend addressing this with your local Dodge dealer. We are just a DM away if you are in need of any additional support for that process.
Rob
DodgeCares

My 2016 SPS does this from time to time. I tap the rear spoiler near the camera, then open the trunk and tap the trunk liner near the camera and it fixes it every time. I haven't had a chance to take it in to get it looked at, but I have 8 months of warranty left, and the 8 year plan like you. I hate taking it to the dealer but I guess I will when i get a chance.
Hi Rocket Man,
We certainly understand why this may be concerning. If you do end up connecting with your dealer for this, our team is just a private message away and happy to provide an additional layer of assistance.
Rob
DodgeCares
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
Thanks all. I'm taking it in to the dealer next Monday. Will let you know how it turns out.
 
1 - 10 of 10 Posts
Top