Dodge Challenger Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi. Newbie here. I have a new 2018 SXT with what appears to be the basic uConnect stereo system with no access to the uConnect home network. I guess mine didn't come with that option (should've done more homework on the car). Anyways. My system likes to freeze and then either reboot or stay frozen. I have also had it stay on even while the car is off and exited. I have tried every troubleshooting skill I could think of aside from disconnecting the battery. Right now I'm waiting for a new system to come in at the dealer, but I'm still curious to know who else may have this issue and how they may or may not have fixed it.


-Aaron
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
17,045 Posts

·
Premium Member
Joined
·
564 Posts
My 17 GT is having the same problems only it has only stayed on after exiting once. The freezing, going blank and rebooting maybe a half dozen times in 7 months. I am not very worried about it has been fine the last 6 or 8 weeks if it starts happing again I will take it in and have it replaced.
 

·
Premium Member
Joined
·
1,642 Posts
Hi. Newbie here. I have a new 2018 SXT with what appears to be the basic uConnect stereo system with no access to the uConnect home network. I guess mine didn't come with that option (should've done more homework on the car). Anyways. My system likes to freeze and then either reboot or stay frozen. I have also had it stay on even while the car is off and exited. I have tried every troubleshooting skill I could think of aside from disconnecting the battery. Right now I'm waiting for a new system to come in at the dealer, but I'm still curious to know who else may have this issue and how they may or may not have fixed it.


-Aaron
Hi Aaron,

Sorry to hear about your concerns with your Uconnect system! If you need further assistance please don't hesitate to send us a PM with your VIN, we're happy to help if needed.

Andrea
Dodge Social Care Specialist
 

·
Premium Member
Joined
·
1,642 Posts
My 17 GT is having the same problems only it has only stayed on after exiting once. The freezing, going blank and rebooting maybe a half dozen times in 7 months. I am not very worried about it has been fine the last 6 or 8 weeks if it starts happing again I will take it in and have it replaced.
Hi UP3985,

Sorry to hear about this! If it happens again please don't hesitate to send us a PM for further assistance if needed.

Andrea
Dodge Social Care Specialist
 

·
Premium Member
Joined
·
103 Posts
My 17 GT is having the same problems only it has only stayed on after exiting once. The freezing, going blank and rebooting maybe a half dozen times in 7 months. I am not very worried about it has been fine the last 6 or 8 weeks if it starts happing again I will take it in and have it replaced.
I have a 2017 SRT392. The day I picked it up the screen went blank, but the radio continued to play. When I turned the car off and then back on, it was normal. I figured this to be an anomaly so I really didn't think too much of it at the time. But it happened again, and then a third time at which time I took a video (worthless to the dealer and Uconnect). I opened up a case with Uconnect and was told to take it to the dealer when I experience the issue. Unfortunately, I usually only drive the car on weekends when the service department is closed. To make a long story short, I happened to take it out on a Friday, and the screen was blank. I drove it directly to the dealer and had a service manager verify it. They ordered a new unit and had it installed two days ago. I'll see if this fixes it.
 

·
Registered
Joined
·
38 Posts
I have this problem on both my current cars and also had it on my 13 Charger. I am not very happy at this moment because multiple visits to the dealer has not fixed my problem and I expect more from a car that stickers for over $45K. I use my Challenger for a pleasure car only. It is a 2015 with only 10800 miles and it froze up tonight on an hour and a half drive and was very upsetting because I was looking forward to a nice drive with my music and it ended up a silent drive. I will make another appointment but am already thinking of changing car brands because I have no faith that the problems wont show back up after warranty is expired. What good is a nice looking car if it is plagued with problems? My 17 Charger with 8000 miles has been in twice for media player problems and is going in next Wed. for an annoying air leak. My 15 Challenger I bought new by dealer trade and that was a mistake because I had not inspected it and the hood is not aligned very well and it is wavy all down one side not to mention I will be taking it in for the second radio repair. I had to vent.
 

·
Registered
Joined
·
8 Posts
We had this issue happen at time of delivery on my wifes 2017 Challenger R/T. We still took delivery of the vehicle and opened a repair to be assesed a few days later. The dealer ordered a new screen and whatever other associated parts required for the repair.
Meanwhile after playing with the new car that evening the radio began working properly. The next day it froze again, and again a few days later.
Our daughters friend with a 2016 Challenger told us she had the same issue until she was advised to put the ignition in the acc position once a day allow the system to boot up and stabilize, then start the car.
My wife has been doing this at first start every day for 3 months and has yet to have the issue occur again.
 
1 - 8 of 8 Posts
Top