Dodge Challenger Forum banner

1 - 20 of 51 Posts

·
Premium Member
Joined
·
350 Posts
Discussion Starter #1
I Super Charged my 2010 RT auto last Oct 10, within weeks of LUV’s RT same vendor. He PM me when he started to have problems. I didn’t have any problems until 4 Apr 11 when I took my car out of winter storage to mount my wheels and tires to get ready for CF2. I put about 10 miles on my car and it was running a little rough. All my gauges (AFR and boost) looked normal, NO CEL’s. I just thought it was from sitting through the winter. On 8 Apr 11 I was headed out to dealership to have the AC checked out. I made it two blocks before my car stalled at stop sign. I decided to run it back around to my home. Pulled up in front of my house and heard a ping or knock sound come from engine. No CEL’s but AFR was erratic, oil pressure 59#. Shut engine down lifted hood. Super charger was leaking the RED lube out through the CAI and air filter onto the ground. checkout pictures. I don’t have a large garage so I flat bedded the car to dealership to check out the engine, remove Super Charger, ship it to Vortech, and fix the AC. Dealership called 3 days later reporting I had a major engine problem, checkout pictures of 7 & 8 plugs . Now for facts: (1) My RT had 5474 miles on it and the super charger had 822 total miles. (2) I only made three trips down the ¼ mile, PB 12.34. (3) No problems right up to winter storage. (4) Vortech inspected the blower head said there was nothing wrong with the blower when they checked it out. Gee where did the Red lube come from??? (5)There was NO Vortech tune for my 5.7 RT’s. (6) DCX installed a custom tune; 6.5# boost, dyno, 468 RWHP and 485 RWTQ. I was told this is a conservative tune. (7) Stock fuel rails, SRT4 injectors 57#, KB installed BAP no problem with lack of fuel I noticed. I have AEM digital, AFR and Boost gauges. AFR at WOT 11-11.5 cruising 14-15. . Vortechs did replace seals and bearings. DCX did say bring it back and we’ll check it out. Distance 230 miles to DCX. Both vendors stated not responsible nor their problem with product or installation. I know if you play you're going to pay!!!! I posted this for those that may think about MODS. Just like LUV RT I sent my car to Arrington for a 392 Stroker. I know I will get a great engine and a warranty backing up their product. IT IS GOING TO BE VERY INTERESTING TO FIND OUT WHAT CAUSED THE PROBLEMS OF BOTH CARS??????
 

Attachments

·
Registered
Joined
·
266 Posts
Either Ring Lands on the pistons broke off or you dropped some valves, broke some springs?

Sorry to hear Homey!:scratchhead:

Marion
 

·
Registered
Joined
·
435 Posts
I Super Charged my 2010 RT auto last Oct 10, within weeks of LUV’s RT same vendor. He PM me when he started to have problems. I didn’t have any problems until 4 Apr 11 when I took my car out of winter storage to mount my wheels and tires to get ready for CF2. I put about 10 miles on my car and it was running a little rough. All my gauges (AFR and boost) looked normal, NO CEL’s. I just thought it was from sitting through the winter. On 8 Apr 11 I was headed out to dealership to have the AC checked out. I made it two blocks before my car stalled at stop sign. I decided to run it back around to my home. Pulled up in front of my house and heard a ping or knock sound come from engine. No CEL’s but AFR was erratic, oil pressure 59#. Shut engine down lifted hood. Super charger was leaking the RED lube out through the CAI and air filter onto the ground. checkout pictures. I don’t have a large garage so I flat bedded the car to dealership to check out the engine, remove Super Charger, ship it to Vortech, and fix the AC. Dealership called 3 days later reporting I had a major engine problem, checkout pictures of 7 & 8 plugs . Now for facts: (1) My RT had 5474 miles on it and the super charger had 822 total miles. (2) I only made three trips down the ¼ mile, PB 12.34. (3) No problems right up to winter storage. (4) Vortech inspected the blower head said there was nothing wrong with the blower when they checked it out. Gee where did the Red lube come from??? (5)There was NO Vortech tune for my 5.7 RT’s. (6) DCX installed a custom tune; 6.5# boost, dyno, 468 RWHP and 485 RWTQ. I was told this is a conservative tune. (7) Stock fuel rails, SRT4 injectors 57#, KB installed BAP no problem with lack of fuel I noticed. I have AEM digital, AFR and Boost gauges. AFR at WOT 11-11.5 cruising 14-15. . Vortechs did replace seals and bearings. DCX did say bring it back and we’ll check it out. Distance 230 miles to DCX. Both vendors stated not responsible nor their problem with product or installation. I know if you play you're going to pay!!!! I posted this for those that may think about MODS. Just like LUV RT I sent my car to Arrington for a 392 Stroker. I know I will get a great engine and a warranty backing up their product. IT IS GOING TO BE VERY INTERESTING TO FIND OUT WHAT CAUSED THE PROBLEMS OF BOTH CARS??????
Sorry to hear about your trouble!Do you know if the blow off valve was working correctly?Sounds like back pressure blowing oil out of the head unit??
 

·
Registered
Joined
·
435 Posts
I'm sure Arrington will figure it out.A hole in a piston will cause a lot of blowby and oil in the intake.
 

·
Banned
Joined
·
4,698 Posts
Looks like you popped a ring land or two. Sorry for your troubles. Arrington will take great care of you.

Look forward to your build thread.

HemiSam
 

·
Premium Member
Joined
·
867 Posts
The red lube is disturbing, why would that leak out? Could a piece of the supercharger get in the combustion chamber or valve seat? I always thought the Vortech was the safest of them all.

Any info yet on what was found on LUVRT Motor?
 

·
Registered
Joined
·
298 Posts
that sucks! wtf? that is what....the 3rd one now? just recent? I will be checking my vortech oil every 1000 miles from here on out, just hit over 1000 miles on the vortech and oil looks perfect (knock on wood). But this is scary! pleeeaaassse 'luv my RT' can you post what exactly happened to your engine soon? I will send you a six pack of beer for the post! lol. I want to know what went wrong. Also Iron6, if you can post or keep us posted on what went wrong with yours. I just installed a vortech on mine with vortech canned tune, no vendor tune, and is running good, but when post like this keep showing up, drives me nuts! Especially since nobody has posted what exactly has gone wrong.
 

·
Registered
Joined
·
298 Posts
The red lube is disturbing, why would that leak out? Could a piece of the supercharger get in the combustion chamber or valve seat? I always thought the Vortech was the safest of them all.

Any info yet on what was found on LUVRT Motor?
same reason I went with vortech, suppose to be the safest. I got a chance to meet 2 guys that had charger srt8's, both 2008 cars and one had 68k on the blower and the other guy had 73k and daily driven with the blower, and both had factory vortech tunes and they have had no problems they said. that was my final buying point in going with the vortech when I got back from springfest, I swear out of all the supercharged cars there, there was 5 vortechs to 1 of other kind of brand supercharger there. I mean maybe there is that much vortechs out there, that there is more of a possiblity of failures happening? dont know, but hopefully somebody can shed some light on what is going on
 

·
Banned
Joined
·
4,698 Posts
There wasn't anything wrong with LUV's blower.

Looks like this one lost a seal and probably the bearing went after. Shouldn't pop the motor...

HemiSam
 

·
Registered
Joined
·
298 Posts
ok, so luv's motor had nothing to do with the blower or tune? it was just one of those things that just happen sometimes? because I know nothing was wrong with the blower, but I thought it was because the tune was wrong? just want to be clear, trying to learn all I can as I have the same kit.
 

·
Banned
Joined
·
7,566 Posts
Jury's still out on what was damaged on Luv's car. I'll touch base with him this weekend for an update, but we're pretty sure two pistons broke.

Blower is fine and will be going on the new motor. Same with Iron6. Bottom line, I don't think it's the supercharger causing the problem.
 

·
Banned
Joined
·
7,566 Posts
Mine too. I don't think Vortech offers a canned tune for the 5.7s so these were both custom tunes from DCX.
 

·
Premium Member
Joined
·
350 Posts
Discussion Starter #15
Speedy's right, Vortech 5.7 kit didn't or don't have a tune when my blower was installed, it was a custom DCX tune. I really don't believe the blower was defective. The oil shown in the pic's on the ground, under the car and intake could have come from the crank vent hose connected to the end of the air filter. Not real sure. Also Vortech did inspect the blower head, put bearings and seals in it at NO charge. I had to pay shipping only. Arrington has both cars so I guess we have to wait to find out the cause.
Mine too. I don't think Vortech offers a canned tune for the 5.7s so these were both custom tunes from DCX.
 

·
Administrator
2009 Challenger R/T
Joined
·
8,919 Posts
maybe flat top could weigh in I know he was having issues until he got fixed in Houston with a new tune :thumbsup:
me i'm going to say it's all in the tuning guys the 5.7's are strong but the tune makes the difference :)
Iron 6 sorry to hear of your problem with no accountability :scratchhead:
 

·
Registered
Joined
·
287 Posts
Iron6, you running red oil in your engine?
You know where that oil came from.
A picture of a dry dipstick from your Vortech.
That charger failed, and leaked all the oil through your filter and some into the engine.
I was at Quaker City when you made your runs.
You held back on that thing, easy launches.
That's all I'm going to say about this right now Bill.

Brad
 

·
Premium Member
09 RT Challenger auto
Joined
·
3,467 Posts
To my understanding the canned tune was just to get it up and running. So it can be data logged or put on drums for final tuning. To my understanding anyway. Many use the canned tune, and no clean up / logging,,,I wouldnt. I think they should be cleaned up after logging. Alot of stuff in a tune. I put down 491whp canned SC tune.
You have to be able to get the right info to the tuner like A/F, timing, is so important.
In my case Dyno Steve had his CMR software with him. He took my stock tune and built a SC tune in the parking lot. Used the street for a dyno. Just to say the tune pushed me 11:80s last weekend, not a one hit wonder either, pass after pass. 11:8
I have tryed other tunes, some good, some NO good.
Starting to get worried all these motors going pop ! Really got me interested in why.
I use the KB bap with the adj hobbs switch, instead of the vortech kit non adjustable hobbs unit. I also spool my FP up (17v)at blower 2 psi when im at 4-5-6000 rpm fuel is already there. I didnt like waiting for 4 or 5 blower psi for the pumps to spool up with non adj hobbs switch. To me its too late. But im no tuner, thats just what I did.
I have put 4000 miles on the Vortech blower, many, hard 1/4 miles. I beat it.
Iron 6, looks like to me the vortech lost a seal and puked its fluid into the motor, slugging the piston. Like Hydrolock. Breakes pistons bends rods all kinda stuff. jmo
Luvs motor Id bet fuel/tuning, timing, killed it. jmo
Keep it posted guys great info.
FT
P.S. Iron 6 sorry to hear about this. Thanks for the early PM about it.
 

·
Registered
Joined
·
298 Posts
just keep us posted, lots of info on this thread and could use it all. flat top is one of the reasons I didnt mash on my motor for 2 weeks after install, waited to get some datalogging and check AF, timing, Knk, it was torture! When I did the install and I fired her up, I wanted to get out and start just boosting and just get it! but flattop put slapped me calm me down, lol lol. and I waited to get it tuned on the dyno with datalogging. The thing is these supercharger kits are sold with "ready to go out of the box, all you need, all bells and whisltes, tune and all out of the box" but that is not the case. I was one of these guys who talking to vortech, they told me this was all I needed, they never once recommended me gauges, or to get some datalogging or anything, they said bolt it on and go! but this is so wrong, there is so much more that goes with a supercharger, ya need AF gauge, boost gauge, even a fuel if you want, get'er on the drums asap! or if no access to a dyno, use the street and datalog and get with your tuner, so important. If it wernt for you guys on here, I would did something stupid. lol.
Now things still happen and can still go wrong, $hit happens too. I know luv my rt and iron6 did all their homework, I guess that is the price we pay to go faster, but this shouldnt happen, we spend 6-10k on blowers! not cool. But I am now a strong believer in the tune, other then the crappy BAP MSD that came with my kit, lol lol.
I will be glued to this post and luv rt's thread, to see what the final result was on the engine failure.
 

·
Registered
Joined
·
1,113 Posts
490 s not conservative.. my conservative tune is a little on the hot side and is a 479/479 on 93... my track day tune is pushing over 500
 
1 - 20 of 51 Posts
Top