Dodge Challenger Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
The water temp on my 392 is running around 205 degrees at highway speeds and 215 around town. This seems a little high so I called the SRT Tech at my dealer and he said this is normal operating temp for this engine. He also said the fan kicks on at 220 degrees. Does this sound about right to you guys?
 

·
Premium Member
Joined
·
541 Posts
I'm seeing the same. I don't recall the 6.1 being much different. All seems normal to me.
 

·
Registered
Joined
·
432 Posts
The water temp on my 392 is running around 205 degrees at highway speeds and 215 around town. This seems a little high so I called the SRT Tech at my dealer and he said this is normal operating temp for this engine. He also said the fan kicks on at 220 degrees. Does this sound about right to you guys?
yep, sounds about right. The 6.1 runs at the same temps, which is why so many of us are running a cooler t-stat. Don't know if heat soak will be as big an issue with the 392, seeing it's got a composite intake manifold. But with the 6.1, performance would get a bit sluggish at those temperatures.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #4
Sounds exactly right. Most engines today have aluminium heads and it does not retain heat like cast iron. To get the efficiency and emissions required, more engine temperature is needed. Take a look at NASCAR..they want every bit out of those engines they can get and they run 230-240 degrees. If more power was to be made by simply running cooler, don't you think they would do it?
For those of you who answered my question, I appreciate your responses. For Curt LF, thank you for the detailed explanation, but I really don't appreciate the last comment in your post!! I'm not a newbie, I'm not an idiot. Have owned 6 Vipers, but have never owned a 6.1 or 6.4 and just wanted to make sure the operating temps I was seeing were within the normal ranges. This is what forums are for.......right???? Please keep the editorializing comments to yourself!
 

·
Registered
Joined
·
1,077 Posts
The water temp on my 392 is running around 205 degrees at highway speeds and 215 around town. This seems a little high so I called the SRT Tech at my dealer and he said this is normal operating temp for this engine. He also said the fan kicks on at 220 degrees. Does this sound about right to you guys?
Seeing the same temps here on my IE as well. So I'm guessing based on what everybody is saying they're spot on where they should be. :thumbsup:
 

·
Registered
Joined
·
83 Posts
Discussion Starter #6
Sorry you took it the wrong way. It was just a rhetorical question. I guess your skin's a little thin. I suggest...........you'd just take that wrong.
I visit 7 other car forums on a regular basis and will certainly admit that one has to be thick skinned when posting. I asked a very simple question and recieved simple, informative answers from everybody........except you! So go ahead, let's hear your suggestion.........maybe I won't take it the wrong way! I might even have a suggestion for you.
 

·
Registered
Joined
·
1,077 Posts
Relax guys, I personally did not read anything worth arguing over. :)
 

·
Premium Member
Joined
·
456 Posts
Dont ask a question oh smart one, and expect a perfect answer! Get over it allready!



Make it happen or move out of the way
 
1 - 8 of 8 Posts
Top