Dodge Challenger Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
I installed a skip shift eliminator last summer on my 09 r/t. Never had any problem with forced 1st-4th shifts. Starting yesteday, however, I see the "shift 1>4" illuminated on the display when rpms hit 2500. One time yesterday - a dozen times today.

Driving back from dinner with my dad tonight I got the display. Stopped numerous times to try to replicate - radio on, radio off, complete stop, rolling stop, neutral to first, stay in first, etc. About the best I can figure, it seems to display only when radio is off and I start from a complete stop, but not every time.

I can still shift to 2nd without any problem but I wonder why I'm getting the display. Definitely not the case that I haven't noticed it before. I've driven 7k miles in the last year. Surely I would have seen it by now.


Any thoughts?:scratchhead:
 

·
Registered
Joined
·
3,532 Posts
the skip shift eliminator doesnt stop the car from trying to make you skip the shift (the SSE will make sure you dont have to go to 4th by locking out the 2nd gear shift solenoid). so youll still see the indication on the dash. you just wont be forced to go to 4th cause the SSE is installed
 

·
Premium Member
Joined
·
362 Posts
You will continue to get the display in the evic even though the feature has been defeated. The reason is in my best guess is that the cars computer still triggers the the feature but the resistor in the SS eliminator keeps the solenoid from activating. I still occasionally see it displayed as well.
 

·
Registered
Joined
·
352 Posts
Definitely not the case that I haven't noticed it before. I've driven 7k miles in the last year. Surely I would have seen it by now.


Any thoughts?:scratchhead:
Depends on how you drive actually. I bought the skip shift eliminator almost two years ago... it's sitting in my armrest console now. I never got around to putting it on. The other day, I tried to go into second and it wouldn't, I was surprised. I can't remember the last time it did that, it's been a year probably. The way I drive, the skip shift just rarely engages.
 

·
Premium Member
2012 Challenger SRT in BSP
Joined
·
440 Posts
I installed a skip shift eliminator last summer on my 09 r/t. Never had any problem with forced 1st-4th shifts. Starting yesteday, however, I see the "shift 1>4" illuminated on the display when rpms hit 2500. One time yesterday - a dozen times today.

Driving back from dinner with my dad tonight I got the display. Stopped numerous times to try to replicate - radio on, radio off, complete stop, rolling stop, neutral to first, stay in first, etc. About the best I can figure, it seems to display only when radio is off and I start from a complete stop, but not every time.

I can still shift to 2nd without any problem but I wonder why I'm getting the display. Definitely not the case that I haven't noticed it before. I've driven 7k miles in the last year. Surely I would have seen it by now.


Any thoughts?:scratchhead:
You've either been "driving around it" maybe without being aware, or just haven't noticed the display OR you had a predator tune and recently went back to stock. the pred tunes will prevent the 1--4 display. The SSE with a stock tune will still display the 1--4 in the EVIC, but the solenoid will not block 2nd. You can shift however you choose.

Otherwise, just consider it a suggestion. I know I do. :)
 

·
Registered
Joined
·
119 Posts
Discussion Starter #6
You've either been "driving around it" maybe without being aware, or just haven't noticed the display OR you had a predator tune and recently went back to stock. the pred tunes will prevent the 1--4 display. The SSE with a stock tune will still display the 1--4 in the EVIC, but the solenoid will not block 2nd. You can shift however you choose.

Otherwise, just consider it a suggestion. I know I do. :)
Good points.

Stock tune. Assuming I just never noticed before because it doesn't seem to display when radio is on.

Ya. Good suggestion to shift at 2500 but it sounds so nice to let rpms get a tad higher. Hard to resist!
 

·
Premium Member
2012 Challenger SRT in BSP
Joined
·
440 Posts
Good points.

Stock tune. Assuming I just never noticed before because it doesn't seem to display when radio is on.

Ya. Good suggestion to shift at 2500 but it sounds so nice to let rpms get a tad higher. Hard to resist!
The display and skip shift should occur at around 19-20 MPH under light throttle (which may be why you've never noticed it before :), but it's certainly not right for the radio to affect it.

I'm presently running the stock tune and I know the display occurs pretty often in traffic even though I rarely notice it. Leave the radio on for a while - maybe with the volume down if you don't want to listen to it. I'm betting you'll still see the display if you're looking at the right time. Remember that it will only occur with very conservative driving conditions. Light throttle at low speed.

Maybe the radio is affecting the angle of your right foot. I know it does mine! Some music (Boston, Fleetwood Mac) makes my car really fast.
 
1 - 7 of 7 Posts
Top