Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So i had my rotors and pads checked by les schwab ( tire and brakes shop) shortly after my abs and esc lights would flicker on and off while driving. Please note i did not have brakes or pads changed, only had them checked for wear n tear. Now the brake light pops on and off while abs and esc stay on. Les schwab told me they got 29 codes on their scanner, i tried to recreate this with autozone and oriellys scanners but no codes even with the light s on the dash showing up. Talked to the dealer and they think its rats chewing wires but want me to fork 200 over for diagnosing this.
Im wondering if it may be a worn abs sensor and maybe brake booster. Brake fluid is good. Braking isnt an issue right now even though the light pops up. And to add, my steering is loose now, had the tie rods and bearings checked, all hardware is in good condition.

Big question is if anyone can direct me to check electrical myself? And other stuff. Dont have enough cash right now to afford dealer fixing it. 2015 sxt plus.

Sorry if this is jumbled, firat post, new here. Thank you guys!
 

·
Super Moderator
2016 SXT Plus Blacktop
Joined
·
20,683 Posts
Welcome to Challengertalk Bi0freeze. Likely a bad wheel sensor. Apprarently easy enough to change, determining which is bad is an issue I believe. Hopefully someone with this experience will be along to help you. I believe the dealer has scanners that can pinpoint which one...at a cost of course ;) I believe they are 2 connectors so you can test the resistance once you locate them. One will have a different resistance.

A Guy
 

·
Registered
2015 Dodge Challenger SRT
Joined
·
647 Posts
Had this happen on my 2011 back in ‘13. Back then I was told that the right front was where to start looking. Sure enough.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
110 Posts
I had the bas esp light on , I would reset it and it would come back on, after hours of online search I did this. Took the front tires off, removed the speed sensor and cleaned the surface of the rotor it was reading, it had tons of debris on it. After I cleaned it the light turned off immediately on a short drive.
 
1 - 5 of 5 Posts
Top