Dodge Challenger Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I was cruising down the road the other day and my car spit once or twice and then the ABS, Traction Control, & ESP BAS lights came on. My traction control will not turn on and my cruise control will not turn on. I have disconnected the battery for 24 hours and they are still on. Any solutions?????
 

·
Registered
Joined
·
1,951 Posts
I was cruising down the road the other day and my car spit once or twice and then the ABS, Traction Control, & ESP BAS lights came on. My traction control will not turn on and my cruise control will not turn on. I have disconnected the battery for 24 hours and they are still on. Any solutions?????
Go to one of your local auto parts stores and get them to pull the codes and post up here. Some one will help.
 

·
Registered
Joined
·
272 Posts
Unless it stays on long enough to set a code in the PCM, the generic code reader won't help. But you may get lucky.

Odds are its a failed wheel speed sensor. Most likely passenger rear.

Where in Alabama are you located silver? Not too many people on here from my neck of the woods!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Yes, I have heard it could be the wheel speed sensor. How much do those run?

Im near birmingham 09RT6MT
 

·
Registered
Joined
·
272 Posts
I had to replace one on my SRT, I think I paid about $20 from Steve White on ebay.
 

·
Registered
Joined
·
1,122 Posts
Just got home and plugged in my Predator to read the codes but screen says no trouble codes found. I defiant key have no ABS or Traction Control. Car sliding all over the place on way home on icy roads.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
272 Posts
Your predator only reads PCM codes. It will take time before the ABS module will store a code in the PCM. The only way to directly read the ABS module is with a star scan or a snap-on scanner.
 

·
Registered
Joined
·
272 Posts
Hope you get it straightened out!
 

·
Registered
Joined
·
1,122 Posts
Just an update.

I went to my local mechanic and had him hook up his scanner. It showed that the problem was a front wheel speed sensor.

I ordered the new one from Dodge for $50 and installed it today myself. Took about 30 minutes. Very easy. Anyone can do it.

Problem solved !

Thanks everyone for your help.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
272 Posts
That's the ETC light...indicating a problem with the throttle control system.
 
1 - 13 of 13 Posts
Top