Dodge Challenger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
2015 SXT plus with dual climate controls. I have searched and found many post about similar problems, but not exactly.

Passenger side does not get cold AC. I can watch the blend door operate while I change the temp and it does get hotter as I increase temp, but when I ask for cold air, the door does moves but does not provide cold AC air as the drivers side does.

Anyone else came across this? I see plenty of post for no temp change, which makes it easy, its the blend actuator, but mine does in fact move when asked. Maybe it does not move fully in the cold position? How much should it move, 1/4 turn, half turn?

Thanks in advance!
 

·
Registered
2011 R/T STP M6
Joined
·
66 Posts
Possible low refrigerant charge.
I don't think it could be the charge since one side of the car is getting cold air no problem.

2015 SXT plus with dual climate controls. I have searched and found many post about similar problems, but not exactly.

Passenger side does not get cold AC. I can watch the blend door operate while I change the temp and it does get hotter as I increase temp, but when I ask for cold air, the door does moves but does not provide cold AC air as the drivers side does.

Anyone else came across this? I see plenty of post for no temp change, which makes it easy, its the blend actuator, but mine does in fact move when asked. Maybe it does not move fully in the cold position? How much should it move, 1/4 turn, half turn?

Thanks in advance!
This is an odd one.

It may be the actuator that is able to open up fully to one side when heat is on but unable to fully open to the other side when blowing cold air. Double check me but I think the 2015 models would have to have blend doors on either side because of the dual climate control. The driver side is probably functioning properly but the passenger side might be getting stuck when switching to cold.

To rule it out, I think the first thing I would try before spending any money is to unplug the battery for a few and reconnect just to see if that might allow the computer to reset.
 

·
Registered
2011 R/T STP M6
Joined
·
66 Posts
Let me know what happens
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Sorry for the late update. Took a little while to receive the R-1234yf freon and charging hose. It in fact was low on freon, which I was leaning towards once the blend doors proved to be operating properly. Once filled, its been ice cold on both sides. I'll have to add some dye to locate the leak now.

Thanks for the input!
 
1 - 5 of 5 Posts
Top